summaryrefslogtreecommitdiff
path: root/dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild')
-rw-r--r--dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild b/dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild
deleted file mode 100644
index 63cfe3ff8054..000000000000
--- a/dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PHP_EXT_NAME="http"
-PHP_EXT_PECL_PKG="pecl_http"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-PHP_INI_NAME="50-http"
-
-USE_PHP="php5-6 php7-0 php7-1 php7-2"
-
-inherit php-ext-pecl-r3
-
-USE_PHP="php5-6"
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Extended HTTP Support for PHP"
-LICENSE="BSD-2 MIT"
-SLOT="2"
-IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
-
-DEPEND="php_targets_php5-6? (
- dev-libs/libevent
- dev-php/pecl-propro:0[php_targets_php5-6]
- dev-php/pecl-raphf:0[php_targets_php5-6]
- net-dns/libidn
- sys-libs/zlib
- ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
- !ssl? ( net-misc/curl[-ssl] )
- dev-lang/php:5.6[hash,session,iconv] )"
-RDEPEND="${DEPEND}"
-PDEPEND="
- php_targets_php7-0? ( dev-php/pecl-http:7[php_targets_php7-0] )
- php_targets_php7-1? ( dev-php/pecl-http:7[php_targets_php7-1] )
- php_targets_php7-2? ( dev-php/pecl-http:7[php_targets_php7-2] )"
-
-PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps )
-
-src_prepare() {
- if use php_targets_php5-6 ; then
- php-ext-source-r3_src_prepare
- else
- default_src_prepare
- fi
-}
-
-src_install() {
- if use php_targets_php5-6 ; then
- php-ext-pecl-r3_src_install
- fi
-}
-
-src_test() {
- for slot in $(php_get_slots); do
- php_init_slot_env "${slot}"
- ln -s "${EXT_DIR}/propro.so" "modules/propro.so" || die
- ln -s "${EXT_DIR}/raphf.so" "modules/raphf.so" || die
- sed -i \
- 's/PHP_TEST_SHARED_EXTENSIONS)/PHP_TEST_SHARED_EXTENSIONS) -d extension=propro.so -d extension=raphf.so/' \
- Makefile || die
- NO_INTERACTION="yes" emake test
- rm modules/propro.so modules/raphf.so || die
- done
-}
-
-pkg_postinst() {
- ewarn "This API has drastically changed and is not compatible with the 1.x syntax."
- ewarn "Please review the documentation and update your code."
-}