summaryrefslogtreecommitdiff
path: root/dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
commit4650985dd0e898b82e0d2ec225931297d4fadccf (patch)
treeeb0e8002cf3ebf1009110b6fec47fa90f873d824 /dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild
parent67f76a858f1ac826bd8a550d756d9ec6e340ed4f (diff)
gentoo resync : 31.01.2018
Diffstat (limited to 'dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild')
-rw-r--r--dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild b/dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild
new file mode 100644
index 000000000000..3a3e49cd8b34
--- /dev/null
+++ b/dev-php/pecl-http/pecl-http-2.6.0-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PHP_EXT_NAME="http"
+PHP_EXT_PECL_PKG="pecl_http"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_INI_NAME="50-http"
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Extended HTTP Support for PHP"
+LICENSE="BSD-2 MIT"
+SLOT="2"
+IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
+
+DEPEND="php_targets_php5-6? (
+ dev-libs/libevent
+ dev-php/pecl-propro:0[php_targets_php5-6]
+ dev-php/pecl-raphf:0[php_targets_php5-6]
+ net-dns/libidn
+ sys-libs/zlib
+ ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
+ !ssl? ( net-misc/curl[-ssl] )
+ dev-lang/php:5.6[hash,session,iconv] )"
+RDEPEND="${DEPEND}"
+PDEPEND="
+ php_targets_php7-0? ( dev-php/pecl-http:7[php_targets_php7-0] )
+ php_targets_php7-1? ( dev-php/pecl-http:7[php_targets_php7-1] )
+ php_targets_php7-2? ( dev-php/pecl-http:7[php_targets_php7-2] )"
+
+PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps )
+
+src_prepare() {
+ if use php_targets_php5-6 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_install() {
+ if use php_targets_php5-6 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}
+
+pkg_postinst() {
+ ewarn "This API has drastically changed and is not compatible with the 1.x syntax."
+ ewarn "Please review the documentation and update your code."
+}