summaryrefslogtreecommitdiff
path: root/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r3.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r3.ebuild')
-rw-r--r--dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r3.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r3.ebuild b/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r3.ebuild
index 467867d6f62c..fbb86a1f78f8 100644
--- a/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r3.ebuild
+++ b/dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r3.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
PHP_EXT_NAME="radius"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
-USE_PHP="php7-2 php7-3 php7-4"
+USE_PHP="php7-4"
PHP_EXT_PECL_FILENAME="${PN/pecl-/}-${PV/_beta/b}.tgz"
PHP_EXT_S="${WORKDIR}/${PHP_EXT_PECL_FILENAME%.tgz}"
+PHP_EXT_NEEDED_USE="pcntl(-),sockets(-)"
inherit php-ext-pecl-r3
@@ -18,14 +19,6 @@ KEYWORDS="~amd64 ~x86"
DESCRIPTION="Provides support for RADIUS authentication (RFC 2865) and accounting (RFC 2866)"
LICENSE="BSD"
SLOT="0"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
+IUSE="examples"
S="${PHP_EXT_S}"
-
-RDEPEND="
- php_targets_php7-2? ( dev-lang/php:7.2[pcntl(-),sockets(-)] )
- php_targets_php7-3? ( dev-lang/php:7.3[pcntl(-),sockets(-)] )
- php_targets_php7-4? ( dev-lang/php:7.4[pcntl(-),sockets(-)] )
-"
-DEPEND="test? ( ${RDEPEND} )"