summaryrefslogtreecommitdiff
path: root/dev-php/pecl-stomp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-25 03:02:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-25 03:02:44 +0000
commit7f0b7329b3aa78ea82792fdf68ab48415fe4cc35 (patch)
tree5c9f3c3f65f2be496e4d9778fdeb4d0da2207c29 /dev-php/pecl-stomp
parent530a5a826feeb71085fb8a01927f4d775a0b131b (diff)
gentoo auto-resync : 25:11:2024 - 03:02:44
Diffstat (limited to 'dev-php/pecl-stomp')
-rw-r--r--dev-php/pecl-stomp/Manifest1
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-2.0.3-r1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/pecl-stomp/Manifest b/dev-php/pecl-stomp/Manifest
index 723fe61bd2fd..f23fa8f94d08 100644
--- a/dev-php/pecl-stomp/Manifest
+++ b/dev-php/pecl-stomp/Manifest
@@ -1,3 +1,4 @@
DIST stomp-2.0.3.tgz 23518 BLAKE2B f0253d0e6d1bb51d95007ce2580cb4e5a271547b73705d1ab5be36975cd58068e5fceea64b1451e438fb17601c1b1f513f287b189e3d2922747f735a48e582ef SHA512 e34a63d776cb79da7676d200e4aa2b4a9d4272014fff30eb4c07bc27417d8dc4e7738fb8d62e283cdaac0a411a7bd6e06ef5b06171caa629a404601d14da71d6
+EBUILD pecl-stomp-2.0.3-r1.ebuild 653 BLAKE2B 674e3fa1152c8406643f33e0e60f232d4aa8e6868753cb6dfca2884b821fcaa667d6668a0649057665dc21581974c233a312dff0acdad8d59657db1a21abc5da SHA512 6ddbd9eae7704888b2925f71d88bd7aa222f2dd658ab716a2e8d1c12312ade65e3c1ed7f932903bb16d05553b21707e6407021481ec0624d4153db470756b992
EBUILD pecl-stomp-2.0.3.ebuild 609 BLAKE2B ff6681235f1ac3fe60aff56c2242c07f14feb9f6ddda553a52872fdf83768a70ce37677d82cf154b7be1836a3cfcecda9c51c1ae0835b274172b37646fef458e SHA512 1178acc4f82e9d44bbab42690e7b05497d1e87468da96f3d52435aea559baecaef592045a90b4fa0ce97adc07a57c95320bd3b402837f8bb6bb506be23e45da2
MISC metadata.xml 240 BLAKE2B f60f325331d493a555e53c29c7cf2742a415356da28a467505f1441f3fd790fd0d59050df84854bdc379d19d94a46121216479807975a2922d5a2fefde83416b SHA512 fada9d69055f2be962b95aac82f260ec5db7a3f4392d10f0458a1d125938fa17539f7ec486000f3a95cff85a3fbb6bbf1f6f4fe6c2de7aa420a7543a3e89d03e
diff --git a/dev-php/pecl-stomp/pecl-stomp-2.0.3-r1.ebuild b/dev-php/pecl-stomp/pecl-stomp-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..4662ba6ae5c2
--- /dev/null
+++ b/dev-php/pecl-stomp/pecl-stomp-2.0.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_PHP="php8-2 php8-3"
+PHP_EXT_NAME="stomp"
+PHP_EXT_NEEDED_USE="ssl(-)?"
+DOCS=( CREDITS doc/classes.php doc/functions.php )
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP extension to communicate with Stomp message brokers"
+HOMEPAGE="https://pecl.php.net/package/stomp"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples ssl test"
+RESTRICT="!test? ( test )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-stomp
+ --with-openssl-dir=$(usex ssl yes no)
+ )
+ php-ext-source-r3_src_configure
+}