summaryrefslogtreecommitdiff
path: root/dev-php/pecl-stomp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/pecl-stomp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/pecl-stomp')
-rw-r--r--dev-php/pecl-stomp/Manifest5
-rw-r--r--dev-php/pecl-stomp/metadata.xml8
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-1.0.9-r1.ebuild48
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-2.0.1-r1.ebuild52
4 files changed, 113 insertions, 0 deletions
diff --git a/dev-php/pecl-stomp/Manifest b/dev-php/pecl-stomp/Manifest
new file mode 100644
index 000000000000..82e52dddb9fa
--- /dev/null
+++ b/dev-php/pecl-stomp/Manifest
@@ -0,0 +1,5 @@
+DIST stomp-1.0.9.tgz 23166 BLAKE2B 804fbe2703f5035a8faa744cddc84de5249b74186c22ab5e26c075a2f241262cadd237c7f566262fcdc25def846968a7788d80817743cdf53eb255cbc25053e1 SHA512 e3ab5bfb03c29edde63de4006b448e0204efbac5817b1443ee5b1a0249c2f96d58443847b878e838108b66e5307f6e803f807aff7430af748af4994bfca5199a
+DIST stomp-2.0.1.tgz 23494 BLAKE2B 3e9f042ffa4a8f54a0746db638ade4bf75febad0359e398894714c6c4d4b6bbaee65cfa384c379d14387026219f02013c6dbb7faba62ae11b4231215be7310ad SHA512 61cfacbd96f1061dc869ede6c1ca0f7bceb6120b28cc4a78fabcbace54a66ba540faf41ef72747b8bcc6a4ef98e405daac04e82bd4e079d90293f030684b04d3
+EBUILD pecl-stomp-1.0.9-r1.ebuild 899 BLAKE2B edeab12f987c00ac202b5bcdf848757ec686b56d602e6761741ca7d703a2733e8e81704c7ca47ec8825c0305767b12175911563515b69fad567c9e6c3d429a3e SHA512 1b645c6e9e90ea33397e7c963f1551c9b369100e65b085229f3882ca6d6f9a341b1f224ccb399bf147f330fde6ba218ca20b192973b598a5b170fce80fe73d67
+EBUILD pecl-stomp-2.0.1-r1.ebuild 1206 BLAKE2B 4bf5f2d2003a7cd3799218dbfd4025c88fcecfff01ef365a75250aea5a35a7fe21beb7b0e060b4b01897c0bb0c685718902d817c68d60678e241d37dec11b62d SHA512 45d183ed424595af9de5a600e1fdcc9faf4246a2779b6d25040684c2bd6db0ff296a1e6677099350936dda1fe427822deb7bcb16574e5804b19fb4672d452bc9
+MISC metadata.xml 239 BLAKE2B 9b7c5dcb74289073481cf07031b7a92f32496cc1097becb074d74a8fbb8133de429ce1baf284e446e44132943c8b32e6b824570f15828588e42ea49ef5661f00 SHA512 2181b874bfe8cd31e7730d8207e26cfd2f272eaf2d1b57ae0faff126347a5298fa1c506d9107e1da9736c8a0ed9c8c339e4d9509a8726b79dbe86e073c12dee0
diff --git a/dev-php/pecl-stomp/metadata.xml b/dev-php/pecl-stomp/metadata.xml
new file mode 100644
index 000000000000..b86acf66c756
--- /dev/null
+++ b/dev-php/pecl-stomp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/pecl-stomp/pecl-stomp-1.0.9-r1.ebuild b/dev-php/pecl-stomp/pecl-stomp-1.0.9-r1.ebuild
new file mode 100644
index 000000000000..8349a99f9a6c
--- /dev/null
+++ b/dev-php/pecl-stomp/pecl-stomp-1.0.9-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6 php7-0"
+PHP_EXT_NAME="stomp"
+DOCS=( CREDITS doc/classes.php doc/functions.php )
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension to communicate with Stomp message brokers"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="examples ssl"
+
+DEPEND="${DEPEND}
+ php_targets_php5-6? ( dev-lang/php:5.6[ssl?] )
+"
+
+RDEPEND="${DEPEND}"
+PDEPEND="php_targets_php7-0? ( dev-php/pecl-stomp:7 )"
+
+src_prepare() {
+ if use php_targets_php5-6 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-stomp
+ --with-openssl-dir=$(usex ssl "${EPREFIX}/usr")
+ )
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ if use php_targets_php5-6 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}
diff --git a/dev-php/pecl-stomp/pecl-stomp-2.0.1-r1.ebuild b/dev-php/pecl-stomp/pecl-stomp-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..dc494fe74045
--- /dev/null
+++ b/dev-php/pecl-stomp/pecl-stomp-2.0.1-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+PHP_EXT_NAME="stomp"
+DOCS=( CREDITS doc/classes.php doc/functions.php )
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php7-0 php7-1 php7-2"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension to communicate with Stomp message brokers"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE="examples ssl test"
+
+DEPEND="${DEPEND}
+ php_targets_php7-0? ( dev-lang/php:7.0[ssl?] )
+ php_targets_php7-1? ( dev-lang/php:7.1[ssl?] )
+ php_targets_php7-2? ( dev-lang/php:7.1[ssl?] )
+"
+
+RDEPEND="${DEPEND}
+ php_targets_php5-6? ( dev-php/pecl-stomp:0 )"
+
+src_prepare() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default
+ fi
+}
+
+src_configure() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7_2 ; then
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-stomp
+ --with-openssl-dir=$(usex ssl "${EPREFIX}/usr")
+ )
+ php-ext-source-r3_src_configure
+ fi
+}
+
+src_install() {
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7_2 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}