summaryrefslogtreecommitdiff
path: root/dev-php/pecl-stomp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-php/pecl-stomp
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-php/pecl-stomp')
-rw-r--r--dev-php/pecl-stomp/Manifest2
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-2.0.2-r1.ebuild29
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild55
3 files changed, 30 insertions, 56 deletions
diff --git a/dev-php/pecl-stomp/Manifest b/dev-php/pecl-stomp/Manifest
index 1afd91e7d058..c75e17bbe711 100644
--- a/dev-php/pecl-stomp/Manifest
+++ b/dev-php/pecl-stomp/Manifest
@@ -1,3 +1,3 @@
DIST stomp-2.0.2.tgz 23609 BLAKE2B b6ed89b5b8fd0bb501b2337e87107797eedc6ac53c81ba86d2e755cfa2dd716bf4e409cee623430791e0b4854833ef44ed7f6f9e1d89fcd2250d598af0dcaea6 SHA512 577a781b45ef394cd833fb69c808da9b8a8ff69b31b1093c5eef3f7b5d1b37cd0b45c32a03883f56f86213e32bb18aaf0a80010c6bec7efa7239ea48bc57b4b4
-EBUILD pecl-stomp-2.0.2.ebuild 1258 BLAKE2B f6fbfb7f5ef066b69880e44714c575bbf05740b7e9442f37b8e95729cb7d1a50fd47df7197ed89c5c9f348a89a4737ce9d7be9f7c5b5af1fbf8898d6f3c0c846 SHA512 867ff41dff254251b76f892f3d3826fe5301a2fe3e06fe1f9da38eb915379891168d6a6692fef26dad47aeafd18283f36e0160f6d2905a5e4d7c483b59e9c4af
+EBUILD pecl-stomp-2.0.2-r1.ebuild 616 BLAKE2B 97c500a0868257e0c688871f8c5a08973cb2390ebd49b3de2a9e2d91bae5e9417cf6914a62a07d863ffe69d9cabb600fd8f4dadc4dc37fee2be16e3a817486c0 SHA512 9a985bcad1c6c7fbacf128810330d52afeb3d7e235234606a579596d7a14fbc738c2127578c729d2ba1e4f245f881efed1b346e961e2c4a2258bc54624ca647b
MISC metadata.xml 239 BLAKE2B 9b7c5dcb74289073481cf07031b7a92f32496cc1097becb074d74a8fbb8133de429ce1baf284e446e44132943c8b32e6b824570f15828588e42ea49ef5661f00 SHA512 2181b874bfe8cd31e7730d8207e26cfd2f272eaf2d1b57ae0faff126347a5298fa1c506d9107e1da9736c8a0ed9c8c339e4d9509a8726b79dbe86e073c12dee0
diff --git a/dev-php/pecl-stomp/pecl-stomp-2.0.2-r1.ebuild b/dev-php/pecl-stomp/pecl-stomp-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..bc5c1a2e4ad0
--- /dev/null
+++ b/dev-php/pecl-stomp/pecl-stomp-2.0.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_PHP="php7-2 php7-3 php7-4"
+PHP_EXT_NAME="stomp"
+PHP_EXT_NEEDED_USE="ssl(-)?"
+DOCS=( CREDITS doc/classes.php doc/functions.php )
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension to communicate with Stomp message brokers"
+LICENSE="PHP-3.01"
+SLOT="7"
+IUSE="examples ssl test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-stomp
+ --with-openssl-dir=$(usex ssl yes no)
+ )
+ php-ext-source-r3_src_configure
+}
diff --git a/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild b/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild
deleted file mode 100644
index b4813f56c437..000000000000
--- a/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_PHP="php5-6 php7-1 php7-2 php7-3"
-PHP_EXT_NAME="stomp"
-DOCS=( CREDITS doc/classes.php doc/functions.php )
-
-inherit php-ext-pecl-r3
-
-USE_PHP="php7-1 php7-2 php7-3"
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="PHP extension to communicate with Stomp message brokers"
-LICENSE="PHP-3.01"
-SLOT="7"
-IUSE="examples ssl test"
-RESTRICT="!test? ( test )"
-
-DEPEND="${DEPEND}
- php_targets_php7-1? ( dev-lang/php:7.1[ssl?] )
- php_targets_php7-2? ( dev-lang/php:7.2[ssl?] )
- php_targets_php7-3? ( dev-lang/php:7.3[ssl?] )
-"
-
-RDEPEND="${DEPEND}
- php_targets_php5-6? ( dev-php/pecl-stomp:0 )"
-
-DEPEND="virtual/pkgconfig ${DEPEND}"
-
-src_prepare() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
- php-ext-source-r3_src_prepare
- else
- default
- fi
-}
-
-src_configure() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
- local PHP_EXT_ECONF_ARGS=(
- --enable-stomp
- --with-openssl-dir=$(usex ssl yes no)
- )
- php-ext-source-r3_src_configure
- fi
-}
-
-src_install() {
- if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
- php-ext-pecl-r3_src_install
- fi
-}