summaryrefslogtreecommitdiff
path: root/dev-php/phar-io-version/phar-io-version-3.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-php/phar-io-version/phar-io-version-3.1.0.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-php/phar-io-version/phar-io-version-3.1.0.ebuild')
-rw-r--r--dev-php/phar-io-version/phar-io-version-3.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-php/phar-io-version/phar-io-version-3.1.0.ebuild b/dev-php/phar-io-version/phar-io-version-3.1.0.ebuild
new file mode 100644
index 000000000000..1c28ee251730
--- /dev/null
+++ b/dev-php/phar-io-version/phar-io-version-3.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Library for handling version information and constraints"
+HOMEPAGE="https://github.com/phar-io/version"
+SRC_URI="https://github.com/phar-io/version/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/version-${PV}"
+
+CDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.2:*"
+
+BDEPEND="dev-php/theseer-Autoload"
+
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ default
+
+ phpab \
+ --output src/autoload.php \
+ --template fedora2 \
+ --basedir src \
+ src \
+ || die
+}
+
+src_install() {
+ insinto /usr/share/php/PharIo/Version
+ doins src/*.php
+ dodoc README.md
+}