summaryrefslogtreecommitdiff
path: root/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild')
-rw-r--r--dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild b/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild
new file mode 100644
index 000000000000..48f99127a9eb
--- /dev/null
+++ b/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Automatic documenting of php api directly from the source"
+HOMEPAGE="http://phpdoc.org"
+SRC_URI="https://github.com/${PN}/${PN}2/releases/download/v${PV}/${PN}.phar -> ${P}.phar"
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# block old version that provides the same binary
+RDEPEND="!dev-php/PEAR-PhpDocumentor
+ media-gfx/graphviz
+ dev-lang/php:*[cli,iconv,intl,phar,xmlreader,xslt]"
+S="${WORKDIR}"
+
+src_unpack() { :; }
+
+src_install() {
+ exeinto /usr/share/php/${PN}
+ newexe "${DISTDIR}/${P}.phar" ${PN}.phar
+ dosym "../share/php/${PN}/${PN}.phar" /usr/bin/phpdoc
+}