summaryrefslogtreecommitdiff
path: root/dev-php/phpcov/phpcov-5.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/phpcov/phpcov-5.0.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/phpcov/phpcov-5.0.0.ebuild')
-rw-r--r--dev-php/phpcov/phpcov-5.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/phpcov/phpcov-5.0.0.ebuild b/dev-php/phpcov/phpcov-5.0.0.ebuild
new file mode 100644
index 000000000000..366e9349d37d
--- /dev/null
+++ b/dev-php/phpcov/phpcov-5.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="CLI frontend for PHP_CodeCoverage"
+HOMEPAGE="https://github.com/sebastianbergmann/phpcov"
+SRC_URI="https://phar.phpunit.de/${P}.phar"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php:*[phar]
+ dev-php/xdebug"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ return
+}
+
+src_install() {
+ exeinto /usr/share/php/${PN}
+ newexe "${DISTDIR}"/${P}.phar "${PN}.phar"
+ dosym "../share/php/${PN}/${PN}.phar" /usr/bin/${PN}
+}