summaryrefslogtreecommitdiff
path: root/dev-php/phpdocumentor-reflection-docblock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/phpdocumentor-reflection-docblock
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/phpdocumentor-reflection-docblock')
-rw-r--r--dev-php/phpdocumentor-reflection-docblock/Manifest4
-rw-r--r--dev-php/phpdocumentor-reflection-docblock/files/autoload.php14
-rw-r--r--dev-php/phpdocumentor-reflection-docblock/metadata.xml11
-rw-r--r--dev-php/phpdocumentor-reflection-docblock/phpdocumentor-reflection-docblock-3.1.1.ebuild30
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-php/phpdocumentor-reflection-docblock/Manifest b/dev-php/phpdocumentor-reflection-docblock/Manifest
new file mode 100644
index 000000000000..8be122bbb93f
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-docblock/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 499 BLAKE2B 8e159b25c5682a68259674aa256c667da624f17b1b784c93cbdcd792f4fe4066122f5848ddb99a7011022b389a1cf2dc955c1b45c4771446363f1e873b32b3ac SHA512 9674ebd512047c27ac986eb63395cc4762c4b0dce3ad5ba1fd76284767e1c724c1b61855a32d96fe925bc1d8c1f76e8c12e016156028a66f7d909dbbf4d676ad
+DIST phpdocumentor-reflection-docblock-3.1.1.tar.gz 42935 BLAKE2B a18fbc5012a28e9f0ab59c6f485bec692aed5e7d245845be1c20a34e51b646b3cfd57d84f10f60a5e64c3ad0cc916b1bd97f07629035d3d4991056665012bb39 SHA512 43f1824db3a7a3793db88817e3cedd6379c8e9074fac1a3e781d049a74a13bde3c519c0a9b2a9219d7869339ab16276229d5d3d9398d9bf7f6cdac6dea5a12d5
+EBUILD phpdocumentor-reflection-docblock-3.1.1.ebuild 768 BLAKE2B c5e018a70473c1e8454b585f15af2ef58568d6e745eb6920536013d70b786184cb9e42efce50167184802f8e90c806b722b87324e81ade163399f36155a96513 SHA512 5d4252a78dad89968eaacfba0f3d3a728cf87915ad76520c3152323520ce857f6f994d6b0420a7cb0096fcfed0d4c75938850cf08cea6122001d5888b020050a
+MISC metadata.xml 336 BLAKE2B b7192560a302045b5f417f3e9c1330c0e73b0fe6c95b79dcacdcae41db70b8b4ef749b7eec902dacbd9e11750d5487c6260013446044dd0cc4a610bcfc83a697 SHA512 6e525276f4719b05ca8d891b76a742450940dd4b6a2bbdb839a5c7556f3ddff370f3e504f9a05449161105b838228519d5d14be2d3994335d7f8e4f90d7eec61
diff --git a/dev-php/phpdocumentor-reflection-docblock/files/autoload.php b/dev-php/phpdocumentor-reflection-docblock/files/autoload.php
new file mode 100644
index 000000000000..70091f310ed1
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-docblock/files/autoload.php
@@ -0,0 +1,14 @@
+<?php
+/* Autoloader for dev-php/phpdocumentor-reflection-common */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+Fedora\Autoloader\Autoload::addPsr4('phpDocumentor\\Reflection\\', __DIR__);
+
+\Fedora\Autoloader\Dependencies::required(array(
+ '/usr/share/php/phpDocumentor/TypeResolver/autoload.php',
+ '/usr/share/php/phpDocumentor/ReflectionCommon/autoload.php',
+ '/usr/share/php/Webmozart/Assert/autoload.php',
+));
diff --git a/dev-php/phpdocumentor-reflection-docblock/metadata.xml b/dev-php/phpdocumentor-reflection-docblock/metadata.xml
new file mode 100644
index 000000000000..b6164cd9043f
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-docblock/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">phpDocumentor/ReflectionDocBlock</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/phpdocumentor-reflection-docblock/phpdocumentor-reflection-docblock-3.1.1.ebuild b/dev-php/phpdocumentor-reflection-docblock/phpdocumentor-reflection-docblock-3.1.1.ebuild
new file mode 100644
index 000000000000..0ab2ddb1f323
--- /dev/null
+++ b/dev-php/phpdocumentor-reflection-docblock/phpdocumentor-reflection-docblock-3.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="ReflectionDocBlock"
+MY_VENDOR="phpDocumentor"
+
+DESCRIPTION="Provide support for annotations via DocBlocks"
+HOMEPAGE="https://www.phpdoc.org"
+SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ <dev-php/phpdocumentor-reflection-common-2
+ <dev-php/phpdocumentor-type-resolver-1
+ <dev-php/webmozart-assert-2
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/${MY_VENDOR}/${MY_PN}
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}