summaryrefslogtreecommitdiff
path: root/dev-php/phpdocumentor-type-resolver/phpdocumentor-type-resolver-0.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/phpdocumentor-type-resolver/phpdocumentor-type-resolver-0.2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/phpdocumentor-type-resolver/phpdocumentor-type-resolver-0.2.1.ebuild')
-rw-r--r--dev-php/phpdocumentor-type-resolver/phpdocumentor-type-resolver-0.2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/phpdocumentor-type-resolver/phpdocumentor-type-resolver-0.2.1.ebuild b/dev-php/phpdocumentor-type-resolver/phpdocumentor-type-resolver-0.2.1.ebuild
new file mode 100644
index 000000000000..5de350bc86e4
--- /dev/null
+++ b/dev-php/phpdocumentor-type-resolver/phpdocumentor-type-resolver-0.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="TypeResolver"
+MY_VENDOR="phpDocumentor"
+
+DESCRIPTION="PSR-5 based resolver of Class names, Types and Structural Element Names"
+HOMEPAGE="https://www.phpdoc.org"
+SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ <dev-php/phpdocumentor-reflection-common-2
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/${MY_VENDOR}/${MY_PN}
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}