summaryrefslogtreecommitdiff
path: root/dev-php/recaptcha
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/recaptcha
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/recaptcha')
-rw-r--r--dev-php/recaptcha/Manifest3
-rw-r--r--dev-php/recaptcha/metadata.xml11
-rw-r--r--dev-php/recaptcha/recaptcha-1.1.3.ebuild34
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-php/recaptcha/Manifest b/dev-php/recaptcha/Manifest
new file mode 100644
index 000000000000..7f1f03a4bf16
--- /dev/null
+++ b/dev-php/recaptcha/Manifest
@@ -0,0 +1,3 @@
+DIST recaptcha-1.1.3.tar.gz 12909 BLAKE2B cbffb64148f3359f4d351089fde65d2b9c8136e0814b5f6aedb3cd9b7f7d3f8f77d9673059f3909b381cf9151ca34a31bb961fe8686bdda4612c718828e46036 SHA512 54e22654d3b24400e448260f1d075ba2586d33cf44e0a5187b5c1288705b29bf9de394f8ca48f7717a2480cb1ae21348cc63e724f1eb93f268407a942b13f9dd
+EBUILD recaptcha-1.1.3.ebuild 919 BLAKE2B 8e8949018ab7f21addc45fe32ffff4cba9031d2045f0133e41024f39049b9a59d43f9c848b1dec9c3ab779b8aaa52727d15f5f355d6628dc8d6b95d6b69f4eb5 SHA512 87b6ea66c192985a3e9a6502cefd9e7710a7ba6545201bd2f26245db4577ddaa9511ba26f3e56a62309bf46cb7745c568022cbea967a40c6e2e2594a363a23ac
+MISC metadata.xml 337 BLAKE2B f5bf73fb4a4f700d08f240f2f5fbf629322ab2f8db346085d09331b69958545dbbf53973a6f04d105edc070901b2cc82ee7800f6be134f159bd7b6587631119b SHA512 abbe5982149863ee6b21edcc5299238a1449ec2ff4088b86453ef4196a2903c1d6fe38cec785562904369944fc6231b463cc1c4914e3eba8e6744bbe2a8ed520
diff --git a/dev-php/recaptcha/metadata.xml b/dev-php/recaptcha/metadata.xml
new file mode 100644
index 000000000000..199668983735
--- /dev/null
+++ b/dev-php/recaptcha/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">google/recaptcha</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/recaptcha/recaptcha-1.1.3.ebuild b/dev-php/recaptcha/recaptcha-1.1.3.ebuild
new file mode 100644
index 000000000000..c91f2b60d6f1
--- /dev/null
+++ b/dev-php/recaptcha/recaptcha-1.1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="PHP client library for Google's reCAPTCHA service"
+HOMEPAGE="https://github.com/google/recaptcha"
+SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples test"
+
+DEPEND="test? ( dev-php/phpunit )"
+RDEPEND="dev-lang/php"
+
+src_install(){
+ insinto "/usr/share/php/${PN}"
+ doins -r src/autoload.php src/ReCaptcha
+ dodoc CONTRIBUTING.md README.md
+ use examples && dodoc -r examples
+}
+
+src_test(){
+ phpunit || die "test suite failed"
+}
+
+pkg_postinst(){
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog "To use it in a script, require('${PN}/autoload.php'),"
+ elog "and then use the ${PN} class normally. Most of the examples in"
+ elog "the documentation should work without further modification."
+}