summaryrefslogtreecommitdiff
path: root/dev-php/smarty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-php/smarty
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-php/smarty')
-rw-r--r--dev-php/smarty/Manifest2
-rw-r--r--dev-php/smarty/smarty-4.0.3.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-php/smarty/Manifest b/dev-php/smarty/Manifest
index bff8b74715c6..01516091c15d 100644
--- a/dev-php/smarty/Manifest
+++ b/dev-php/smarty/Manifest
@@ -1,4 +1,6 @@
DIST manual-en.3.1.14.zip 408414 BLAKE2B 03d4e7a386eb3bd5b19e5c555ec34b86812838a5b5fac8ec0ab9701fba89a5867714da57d950f68224a89bbe2267c18d638ee850681860de309c74bbfb3d0a0b SHA512 d384e3856b45ed3f992f3732a5465120abe9fb947cdf13ff67a9c4264f72987d24885ee61cd7309b728e64cdfe4f34c3e7f757096d35de56d962f3b78def9e58
DIST smarty-3.1.39.tar.gz 264604 BLAKE2B ab5e8e052fd83e38a99725f03dcc4a206848c153b0584c12de1c605d9a9a5b47d23c29bd8a5179e53cf73921c89632ee2c4e9921002f41a4de97c6dc2e7d91a1 SHA512 84566bdefd83784c5b22ea4c21405261010a03e07839b15f6e1837aeb93ae12ae724a31648627b5f8794659e2fcd6cbbcd633be8d290dd1744e45e87fbe60fd2
+DIST smarty-4.0.3.tar.gz 358999 BLAKE2B 13866ff2da1d99672337815eb264b3941a51ef4b26079995790a1759e7a1acd1e6c724af25eae5eec18f992f1a1f08564746867d5c715df9755a8899cd96c641 SHA512 9a3cf224b38e4e0fd55d2242f4b09531ae44f581979b64754fea1bab4f540b49c0222e9a43622d87d3d82e68c6d8aaca31bb34dc0b1b691ed413de6af06e69cb
EBUILD smarty-3.1.39.ebuild 1332 BLAKE2B 6223fcc88515195b121844c10598bfa3759d28943cc06c4295a2fdbd50f422d19e1bfd7dc720a93a0859eccf935acdc6331954a6f08163ef10bde05a59edf5de SHA512 ffa1e8578375016ed486ca4a81585acdacb96e82bf42fa52dd7950759cc31582ad67de1a4143c31d55a975f6baae877bba164a414e5fb7ed315601b4cb823f72
+EBUILD smarty-4.0.3.ebuild 1349 BLAKE2B 21a788ae2556328e15ff8153fb71e385ad2eca62126d87abd9f121f416a6d46646f1c211ffa876c4fa475265db8653033bb606ca3f786359125e4660f601e997 SHA512 7e1db2a808be9b30b9e7af27ce643b02406e3ce59eee3d0385b06b1b5127a2284e48c56909f4723093039d268f8a7027567f0779068b0d18d873f3211f24bff3
MISC metadata.xml 742 BLAKE2B 2e882a2cd16715923bd3b93e032b2680fe07853bc0a1a03a62690f57a0254373611e5dd323dec285ac3d051dfdfd167f114c68ad4ca2caa916a76262d71e4725 SHA512 3589fb45084564c669e97fdebab3964ced2500dea7a53dd452961e71a3a2d5070cb71467dc3489a4a2474858ebf8f4d05d8b01728382e08215752b535b6a3681
diff --git a/dev-php/smarty/smarty-4.0.3.ebuild b/dev-php/smarty/smarty-4.0.3.ebuild
new file mode 100644
index 000000000000..b8594fc0e25c
--- /dev/null
+++ b/dev-php/smarty/smarty-4.0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOC_PV="3.1.14"
+
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="https://www.smarty.net/"
+SRC_URI="https://github.com/smarty-php/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://www.smarty.net/files/docs/manual-en.${DOC_PV}.zip )"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+BDEPEND="doc? ( app-arch/unzip )"
+
+# PHP unicode support is detected at runtime, and the cached templates
+# that smarty generates depend on it. If, later on, PHP is reinstalled
+# without unicode support, all of the previously-generated cached
+# templates will begin to throw 500 errrors for missing mb_foo
+# functions. See bug #532618.
+RDEPEND="dev-lang/php:*[unicode]"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+
+ local DOCS=( CHANGELOG.md README.md SECURITY.md )
+ local HTML_DOCS
+ use doc && HTML_DOCS="${WORKDIR}/manual-en/"*
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog
+ elog 'To use it in your scripts, include the Smarty.class.php file'
+ elog "from the \"${PN}\" directory; for example,"
+ elog
+ elog " require('${PN}/Smarty.class.php');"
+ elog
+ elog 'After that, the Smarty class will be available to you.'
+}