summaryrefslogtreecommitdiff
path: root/dev-php/smarty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-31 15:02:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-31 15:02:11 +0000
commite860dfa5acdb67f8e2b8938b005dbaaaaf2c984a (patch)
tree38fd83ad8fb940fa7c8b31bc24cda66c9346ca80 /dev-php/smarty
parente9bf3526a3a5e02396f24203bf8535a21b6f9784 (diff)
gentoo auto-resync : 31:01:2023 - 15:02:11
Diffstat (limited to 'dev-php/smarty')
-rw-r--r--dev-php/smarty/Manifest2
-rw-r--r--dev-php/smarty/smarty-4.3.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-php/smarty/Manifest b/dev-php/smarty/Manifest
index 9a855ce51467..4864d3729caa 100644
--- a/dev-php/smarty/Manifest
+++ b/dev-php/smarty/Manifest
@@ -1,3 +1,5 @@
DIST smarty-4.2.1.tar.gz 236881 BLAKE2B 4014178cfc4411a9ded3120d0e3e977af0190bc03f6ed21bbd2c484ca8fb4e5aa79fe9c606ee13be87db94c17a00d7d0399cb04fe09c4b439b95bc7b9331d675 SHA512 0d55ab1d329aaa0853a1c40b5b0207d3ddc8b0c25d863a217b3c4ac8bb0a796bb60eda2919b5dda569565b03b8dd44dff67b55d8fafc005164f2848bb481d131
+DIST smarty-4.3.0.tar.gz 360023 BLAKE2B 7f3fbeab71b9deb30242cfaf62a67380397a0ad0ca6c657186aa8150f27df46b33dbe55d32657f71f13ea6fe31d37dbfba44dee43ab21ef6906ba56e1ccdff60 SHA512 7db02a455ab4a6aeb69792f5cdd043a2045fa3a2045d06e1a2423cd4dae48c306be149c25567d1be92f50789e14c4d314b7bd29f3f52b74b00bfeeedc0be7ca9
EBUILD smarty-4.2.1.ebuild 1298 BLAKE2B e7baa39168bfc8f7f5b9ad465088715372e26075c46503000bd1c6d8d5ff9c6f7153f3da1ea338c444a73c17fca2e4d7b2d539837dc2639a472b0620dea20663 SHA512 a92a651a124653fa81f7c61bdad55ede0d79b65986c1aa00406fe6594a3d32c3d9132b9e58dcceb38c3f653a9b274cf18f78c7517f4575d5050592a442cfc0d2
+EBUILD smarty-4.3.0.ebuild 1303 BLAKE2B 5ab3bbd4161bfb09163559181d7c527c10a78b5cdde3d3075adbf9ab5acc9cba6d31312ba58e64ef5393ab715b53a54c923db0c908b41404003ff5f61f5ccb85 SHA512 3d4ad6635c88797dd38f9807ce57285c2e844feab688dbcb03f6ac9a189194b8285c3ac9c6a1c8ce1c1b296012d1302ad624e6df78094f68e5edd974b4b2e2ad
MISC metadata.xml 742 BLAKE2B 2e882a2cd16715923bd3b93e032b2680fe07853bc0a1a03a62690f57a0254373611e5dd323dec285ac3d051dfdfd167f114c68ad4ca2caa916a76262d71e4725 SHA512 3589fb45084564c669e97fdebab3964ced2500dea7a53dd452961e71a3a2d5070cb71467dc3489a4a2474858ebf8f4d05d8b01728382e08215752b535b6a3681
diff --git a/dev-php/smarty/smarty-4.3.0.ebuild b/dev-php/smarty/smarty-4.3.0.ebuild
new file mode 100644
index 000000000000..312ca47189f6
--- /dev/null
+++ b/dev-php/smarty/smarty-4.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="https://www.smarty.net/ https://github.com/smarty-php/smarty/"
+SRC_URI="https://github.com/smarty-php/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# PHP unicode support is detected at runtime, and the cached templates
+# that smarty generates depend on it. If, later on, PHP is reinstalled
+# without unicode support, all of the previously-generated cached
+# templates will begin to throw 500 errrors for missing mb_foo
+# functions. See bug #532618.
+RDEPEND="dev-lang/php:*[unicode]"
+
+src_install() {
+ insinto "/usr/share/php/${PN}"
+ doins -r libs/*
+
+ # The smarty docs and examples aren't part of the tarball,
+ # https://github.com/smarty-php/smarty/issues/799
+ local DOCS=( CHANGELOG.md README.md SECURITY.md )
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "${PN} has been installed in /usr/share/php/${PN}/."
+ elog
+ elog 'To use it in your scripts, include the Smarty.class.php file'
+ elog "from the \"${PN}\" directory; for example,"
+ elog
+ elog " require('${PN}/Smarty.class.php');"
+ elog
+ elog 'After that, the Smarty class will be available to you.'
+}