summaryrefslogtreecommitdiff
path: root/dev-php/spdx-licenses/spdx-licenses-1.5.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-php/spdx-licenses/spdx-licenses-1.5.4.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-php/spdx-licenses/spdx-licenses-1.5.4.ebuild')
-rw-r--r--dev-php/spdx-licenses/spdx-licenses-1.5.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-php/spdx-licenses/spdx-licenses-1.5.4.ebuild b/dev-php/spdx-licenses/spdx-licenses-1.5.4.ebuild
new file mode 100644
index 000000000000..98621560f378
--- /dev/null
+++ b/dev-php/spdx-licenses/spdx-licenses-1.5.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tools for working with and validating SPDX licenses"
+HOMEPAGE="https://github.com/composer/spdx-licenses"
+SRC_URI="https://github.com/composer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+src_install() {
+ insinto "/usr/share/php/Composer/res"
+ doins -r res/.
+
+ insinto "/usr/share/php/Composer/Spdx"
+ doins -r src/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}