summaryrefslogtreecommitdiff
path: root/dev-php/symfony-finder
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/symfony-finder
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/symfony-finder')
-rw-r--r--dev-php/symfony-finder/Manifest5
-rw-r--r--dev-php/symfony-finder/files/autoload.php8
-rw-r--r--dev-php/symfony-finder/files/skip-file-time-sort-tests.patch24
-rw-r--r--dev-php/symfony-finder/metadata.xml22
-rw-r--r--dev-php/symfony-finder/symfony-finder-3.2.8.ebuild39
5 files changed, 98 insertions, 0 deletions
diff --git a/dev-php/symfony-finder/Manifest b/dev-php/symfony-finder/Manifest
new file mode 100644
index 000000000000..ca7c20fa8789
--- /dev/null
+++ b/dev-php/symfony-finder/Manifest
@@ -0,0 +1,5 @@
+AUX autoload.php 272 SHA256 8523f889d0fc1508cd4ecf768a83820ae5ec78c04f795d6bdb288ba4b310d224 SHA512 b10296ebdf173be6e8b4d98013888778269d08915e1e30f1c00f59dbfb15af5b8a39d59a302b3ea65ba811d8c51c975b876fff1a3adf2a6cf6cf129172525f17 WHIRLPOOL 2e9bab728dafd7717aa9c1a103f6bddeaca16ff79a08e64c8f939881ca59c1a4445234f849a4ae6674954eb0453b6e934ebb675bb15578c8ebcc93920a8b155c
+AUX skip-file-time-sort-tests.patch 1211 SHA256 4cf73faaf7b93b1393d4a8e4e8cd61936a40befd93acd4d43696b3ea369e3f71 SHA512 bf8e229ab4d9afbe991c60710eefc4a741ee87671dd3fef386548cacfff160e56b455437c9af94dc1e88253111d10edb3133762c781673e962428150589231e3 WHIRLPOOL 2c4c1f623d84d90e669765dbebb1e03caa02c08b7a914ec53f1c227d636fffdac61d64c07aeb1c8fbec17d48509082414fad80b90223f0553b7a19a554ecbb83
+DIST symfony-finder-3.2.8.tar.gz 24452 SHA256 57d9e3380558188719a6ed6a6767f41feacc0e08935e94ca7469abdbc7d68837 SHA512 7eff457c6c70bf58b4af7e9adbeeb68a1ad684b95510d929f137545be6b755ece37949687f4de27c7fb4d5f208e30c6b0b3a32a804f7a6a6b8ed0d4ed7dfd9cd WHIRLPOOL 0733e6c28a408fb410006bf8edf2f03f1d32a9cece384e11a830f11910e53e92559efe10aff626e2207e42199d4b057b20ef927be3f7e4bf5774b824a087c9db
+EBUILD symfony-finder-3.2.8.ebuild 915 SHA256 64ca4fcc811e7db02f8075a5f5ea13792bb3b4417677987c86176ff3aa6b0c82 SHA512 4d94ab39c65d1d7cb343a2cee5dff85acc4c6ce67e9801b36fdb731d366f3545b15d966334c963d14f2d35dab582f2453acae89e324b9a1a6bc0172f69eff9ff WHIRLPOOL 159a4c0224020debb4a414c5330cbf456a8bf536cc4f0d01984d08cb169aca050bef2974e065d919333d541171fd33fed2de6bcd0e13cbd32e642f9d37f289c0
+MISC metadata.xml 685 SHA256 1bdbe4831d7c697cbe6fbdecd5f8c03d0b85d0b0bb0dc671da9b517ef834923e SHA512 664abc5b0e4894c547f4d39ed3cc3c4f4b6526e0ad9dec4a83f43410121b2aaeccc969bf4393a899d309e71c21fd6e06df7f4547927a8ae1ee0b1382a8c5dc92 WHIRLPOOL 22b8d1a7b86e9ec4195fd28b91bdf25cb7e45cfac48f1fa742da6524dbc3f08dbdfb5cb038aa8d45a0d49956f102dfc23ec9739f2d6df1c151d055175869b11b
diff --git a/dev-php/symfony-finder/files/autoload.php b/dev-php/symfony-finder/files/autoload.php
new file mode 100644
index 000000000000..f08b7856a720
--- /dev/null
+++ b/dev-php/symfony-finder/files/autoload.php
@@ -0,0 +1,8 @@
+<?php
+/* Autoloader for symfony-finder and its dependencies */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addPsr4('Symfony\\Component\\Finder\\', __DIR__);
diff --git a/dev-php/symfony-finder/files/skip-file-time-sort-tests.patch b/dev-php/symfony-finder/files/skip-file-time-sort-tests.patch
new file mode 100644
index 000000000000..d0ee130b4e76
--- /dev/null
+++ b/dev-php/symfony-finder/files/skip-file-time-sort-tests.patch
@@ -0,0 +1,24 @@
+There's one set of tests that tries to sort an array of files by their
+access and modification times, and that doesn't work if your filesystem
+is mounted with noatime (a lot of our users do that).
+
+This should probably be fixed upstream, and has been reported here:
+
+ https://github.com/symfony/symfony/issues/17489
+
+diff --git a/Tests/Iterator/SortableIteratorTest.php b/Tests/Iterator/SortableIteratorTest.php
+index 4750f25..29d176a 100644
+--- a/Tests/Iterator/SortableIteratorTest.php
++++ b/Tests/Iterator/SortableIteratorTest.php
+@@ -62,10 +62,7 @@ class SortableIteratorTest extends RealIteratorTestCase
+ || $mode === SortableIterator::SORT_BY_CHANGED_TIME
+ || $mode === SortableIterator::SORT_BY_MODIFIED_TIME
+ ) {
+- if ('\\' === DIRECTORY_SEPARATOR && SortableIterator::SORT_BY_MODIFIED_TIME !== $mode) {
+- $this->markTestSkipped('Sorting by atime or ctime is not supported on Windows');
+- }
+- $this->assertOrderedIteratorForGroups($expected, $iterator);
++ $this->markTestSkipped('Sorting by time is failure-prone on Gentoo');
+ } else {
+ $this->assertOrderedIterator($expected, $iterator);
+ }
diff --git a/dev-php/symfony-finder/metadata.xml b/dev-php/symfony-finder/metadata.xml
new file mode 100644
index 000000000000..b0b66ef709b8
--- /dev/null
+++ b/dev-php/symfony-finder/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ The Finder component finds files and directories
+ via an intuitive fluent interface.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">symfony/finder</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/symfony-finder/symfony-finder-3.2.8.ebuild b/dev-php/symfony-finder/symfony-finder-3.2.8.ebuild
new file mode 100644
index 000000000000..50e82b6605cb
--- /dev/null
+++ b/dev-php/symfony-finder/symfony-finder-3.2.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION=" Symfony Finder Component"
+HOMEPAGE="https://github.com/symfony/finder"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> symfony-finder-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-lang/php:*
+ dev-php/fedora-autoloader"
+DEPEND="test? ( ${RDEPEND} >=dev-php/phpunit-5.7.15 )"
+
+S="${WORKDIR}/finder-${PV}"
+
+PATCHES=( "${FILESDIR}/skip-file-time-sort-tests.patch" )
+
+src_prepare() {
+ default
+ if use test; then
+ cp "${FILESDIR}/autoload.php" "${S}/autoload-test.php" || die
+ fi
+}
+
+src_install() {
+ insinto "/usr/share/php/Symfony/Component/Finder"
+ doins -r Comparator Exception Iterator
+ doins *.php "${FILESDIR}"/autoload.php
+ dodoc CHANGELOG.md README.md
+}
+
+src_test() {
+ phpunit --bootstrap "${S}/autoload-test.php" || die 'test suite failed'
+}