summaryrefslogtreecommitdiff
path: root/dev-php/theseer-tokenizer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-php/theseer-tokenizer
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-php/theseer-tokenizer')
-rw-r--r--dev-php/theseer-tokenizer/Manifest2
-rw-r--r--dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-php/theseer-tokenizer/Manifest b/dev-php/theseer-tokenizer/Manifest
index e0b9630034b0..b4429648b990 100644
--- a/dev-php/theseer-tokenizer/Manifest
+++ b/dev-php/theseer-tokenizer/Manifest
@@ -1,4 +1,6 @@
AUX autoload.php 740 BLAKE2B 1776060d0cbd86a165e293cf24ba31c7c6eef748f7d34681d110f1f99f62909f6619f4917743a995c2c9f2edc5de99b5762d3997d09f14c66a6bfe3569f5e17a SHA512 23ec36f9afc24a4df46a866376db86727127351a1c6d9c16f864804ff31fe64c0c0c8a8306fb1a91fce0dd165cbf5fb02cbe545b4f00dc96bcff2dcce7a82b7c
DIST theseer-tokenizer-1.1.0.tar.gz 10163 BLAKE2B b2360f901d60f784db2045912707a8e293a55967d60d4e72168a1c4b0c9a2d5bdb739fbed9bfec02075476e7bf6762eb1cc7e36870b84fcc341b609527579ca2 SHA512 8b500565dc0d6c8513db3aa72a7ee1fa04510a712ce9b0977feccddc6b2dae53825e39182d43508e196f326776115789e81697116418f6f9f63d08f0c05d0543
+DIST theseer-tokenizer-1.1.3.tar.gz 10553 BLAKE2B 4bed1623abe110cec432a97fbd28752618420a188b450c935c77b5771d6986be9a51c8f100fd81a89d892b0c1e2b46b0124e3c35e3cbe2138eee2d520c74933a SHA512 e29fd41b311bac8021f4c0593d79a9c1bde4b6ccf4774e94d27a0e8a97bac3844109f9312c4aab6e239365630394b602b56a084c291dc13fb439dc8ac22944e3
EBUILD theseer-tokenizer-1.1.0.ebuild 838 BLAKE2B 7330514a58ed439162ba8e4673ecf1bb9c2a754cd9279ee457b5667ba91222ca4bb79c756501e5cfcaf378e816931fffb80eb9242c36a3106d9498cb720a4f29 SHA512 45cf1d3481aeb6950dcac62c378c10af0ffcdbd6e0a412310008b0fa2095704adeca25e90c0e62f312f5b055ef368ef52c5f8ffbfeb6edf34511ff33f877ff45
+EBUILD theseer-tokenizer-1.1.3.ebuild 838 BLAKE2B 1e960b74da6e8dd886dcd57a1c3796ea11db25ac2e1bcaa33e788bf42362c3f06512a2f49b88c6266c4e5536ff69098dbfc64850a728ca6e5b17881060818cd6 SHA512 a354444d077638e3b2cb810684b3635bfb19e1f0ab8ad7d9e4dc1db22d8854cd12baead07a60548d73299b31a1172a11bbc2fa649625a38085f015435c07c94c
MISC metadata.xml 321 BLAKE2B c4c16164af66494e41a3bfe90f4943c905560440eaea9de1a4f82148e1cdc353f9b6871efb618af4ab7ddb8c9fa1dfd931e0610b79c41750744aa6e5dd70580d SHA512 75a4155fe11d88a9d1bde7d46f68954c175c2b8d89872bd53496f11ffd22aa4cbf9f487e36217522e7201aae85c089422a3c7bea3fdec21fc3048b20aad6e5a9
diff --git a/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild b/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild
new file mode 100644
index 000000000000..5e52b63d58ae
--- /dev/null
+++ b/dev-php/theseer-tokenizer/theseer-tokenizer-1.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Convert tokenized PHP source code into XML and other formats"
+HOMEPAGE="https://github.com/theseer/tokenizer"
+SRC_URI="https://github.com/theseer/tokenizer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/tokenizer-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-7.0:*[tokenizer,xmlwriter]"
+
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+src_prepare() {
+ cp "${FILESDIR}/autoload.php" src/ || die
+ default
+}
+
+src_install() {
+ insinto /usr/share/php/TheSeer/Tokenizer
+ doins src/*.php
+ dodoc README.md
+}
+
+src_test() {
+ phpunit || die "Unit testing failed!"
+}