summaryrefslogtreecommitdiff
path: root/dev-php/xcache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/xcache
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/xcache')
-rw-r--r--dev-php/xcache/Manifest3
-rw-r--r--dev-php/xcache/metadata.xml15
-rw-r--r--dev-php/xcache/xcache-3.2.0-r2.ebuild62
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-php/xcache/Manifest b/dev-php/xcache/Manifest
new file mode 100644
index 000000000000..548cdb34b8b7
--- /dev/null
+++ b/dev-php/xcache/Manifest
@@ -0,0 +1,3 @@
+DIST xcache-3.2.0.tar.bz2 148392 BLAKE2B f366b3b3563f6e150851bc2b2cea099abb29c778bebbbd69d83ec1d7f6dd4f808d28e082c945ffee49b303af34a9c43a0f9f1c61fb1072b57cc28d85bb2fa3c8 SHA512 9d7bec73ac941c8e38b2cda15af65044291adc0806b39586048943515d67656d64871bea4ea05b3dff76761ebed462db2d6ad0e489079291abc55313b1508946
+EBUILD xcache-3.2.0-r2.ebuild 1462 BLAKE2B 9e2fda3e6e46837fa50baf95c1b1cac36db88f0436a70979b7c7c938982b98c6c3e44a9a28eb6339dcba03b12c8c27ca9bd9f73ddb4a822034617a5b0ae6b3ae SHA512 822c073f2892b314bfc7ba123080fb48544e16f322df49501e556e4877f7218f63d735c52859826f4ce0fe869e768a867cdf31b20b446d6e432f3435d1319486
+MISC metadata.xml 384 BLAKE2B a5308404632412bfa16b41ae5605d58bb6a97a29e9c6ad82d53ec9d8407e342437835b169d19d55d32382953a13950f2f51c3ae138c9f7d07a6aab723e559ec0 SHA512 45a0dea232bce265fcf7d6dceb8529ad81aa3df55b6dd83e45fb4d5d2063cee0c05dc61582c2e095f196d6c812be3f8e089e2bdffb7d5ca7f3b6301be8dcb450
diff --git a/dev-php/xcache/metadata.xml b/dev-php/xcache/metadata.xml
new file mode 100644
index 000000000000..c8185e7f2890
--- /dev/null
+++ b/dev-php/xcache/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+
+ <use>
+ <flag name="coverage">
+ Enable the coverager module (not recommended for
+ production servers).
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-php/xcache/xcache-3.2.0-r2.ebuild b/dev-php/xcache/xcache-3.2.0-r2.ebuild
new file mode 100644
index 000000000000..64e55e43a542
--- /dev/null
+++ b/dev-php/xcache/xcache-3.2.0-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="xcache"
+PHP_EXT_SAPIS="apache2 cgi fpm"
+USE_PHP="php5-6"
+
+inherit php-ext-source-r3
+
+DESCRIPTION="A fast and stable PHP opcode cacher"
+HOMEPAGE="http://xcache.lighttpd.net/"
+SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="coverage"
+
+# make test would just run php's test and as such need the full php source
+RESTRICT="test"
+
+DEPEND="
+ !dev-php/eaccelerator
+ !dev-php/pecl-apc
+ virtual/httpd-php:*
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-xcache=shared
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ $(use_enable coverage xcache-coverager) \
+ --enable-xcache-assembler \
+ --enable-xcache-encoder \
+ --enable-xcache-decoder )
+
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ php-ext-source-r3_src_install
+
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins lib/Decompiler.class.php
+
+ # Install the admin interface somewhere where it can be
+ # copied/symlinked into a document root.
+ insinto "/usr/share/${PN}"
+ doins -r htdocs
+}
+
+pkg_postinst() {
+ elog "The lib/Decompiler.class.php file shipped with this release"
+ elog "was installed into ${PHP_EXT_SHARED_DIR}. The htdocs/ admin"
+ elog "interface directory can be found under ${EPREFIX}/usr/share/${PN}."
+}