summaryrefslogtreecommitdiff
path: root/dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild')
-rw-r--r--dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild b/dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild
new file mode 100644
index 000000000000..ad9f7604ad52
--- /dev/null
+++ b/dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Restart a CLI process without loading the xdebug extension"
+HOMEPAGE="https://github.com/composer/xdebug-handler"
+SRC_URI="https://github.com/composer/xdebug-handler/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/psr-log-1.0.2"
+
+src_install() {
+ insinto /usr/share/php/Composer/XdebugHandler
+ doins src/*.php "${FILESDIR}/autoload.php"
+ dodoc README.md
+}