summaryrefslogtreecommitdiff
path: root/dev-python/Babel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-python/Babel
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-python/Babel')
-rw-r--r--dev-python/Babel/Babel-2.8.1.ebuild36
-rw-r--r--dev-python/Babel/Babel-2.9.1.ebuild (renamed from dev-python/Babel/Babel-2.9.0.ebuild)17
-rw-r--r--dev-python/Babel/Manifest8
-rw-r--r--dev-python/Babel/files/Babel-2.8.0-py39.patch169
-rw-r--r--dev-python/Babel/files/Babel-2.9.0-pypy3.patch33
5 files changed, 10 insertions, 253 deletions
diff --git a/dev-python/Babel/Babel-2.8.1.ebuild b/dev-python/Babel/Babel-2.8.1.ebuild
deleted file mode 100644
index 59a1c0b8d639..000000000000
--- a/dev-python/Babel/Babel-2.8.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="https://babel.pocoo.org/ https://pypi.org/project/Babel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${DEPEND}
- test? ( dev-python/freezegun[${PYTHON_USEDEP}] )"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/Babel-2.8.0-py39.patch
- "${FILESDIR}"/Babel-2.9.0-pypy3.patch
-)
-
-src_test() {
- local -x TZ=UTC
- distutils-r1_src_test
-}
diff --git a/dev-python/Babel/Babel-2.9.0.ebuild b/dev-python/Babel/Babel-2.9.1.ebuild
index 55fd72ae8906..7dd2c3755132 100644
--- a/dev-python/Babel/Babel-2.9.0.ebuild
+++ b/dev-python/Babel/Babel-2.9.1.ebuild
@@ -20,18 +20,17 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x
RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
- ' python3_{6..8} pypy3)"
-DEPEND="${DEPEND}
- test? ( dev-python/freezegun[${PYTHON_USEDEP}] )"
+ ' python3_{7..8} pypy3)"
+BDEPEND="test? ( dev-python/freezegun[${PYTHON_USEDEP}] )"
distutils_enable_sphinx docs
distutils_enable_tests pytest
-PATCHES=(
- "${FILESDIR}"/Babel-2.9.0-pypy3.patch
-)
-
-src_test() {
+python_test() {
local -x TZ=UTC
- distutils-r1_src_test
+ local deselect=()
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ tests/messages/test_extract.py::ExtractPythonTestCase::test_extract_strip_comment_tags
+ )
+ epytest ${deselect[@]/#/--deselect }
}
diff --git a/dev-python/Babel/Manifest b/dev-python/Babel/Manifest
index 3954e1dfd3da..cc7fb647bef8 100644
--- a/dev-python/Babel/Manifest
+++ b/dev-python/Babel/Manifest
@@ -1,7 +1,3 @@
-AUX Babel-2.8.0-py39.patch 7421 BLAKE2B 94a9b55504214b4c422cab61651dcc4c9192f438635e0ec6aa77ea1b53fefb782dd4a1d13ba89500fc2c2e13bebfc616529aaf74c18a55304fd23c2c53fb77cc SHA512 8d738bb0140c80bb2db8a2180c563f61500df42de1b69f0b2a36dea23aad889fe59451fca993161f6ca6a2f6006d98ce94ab139eb5be4a1a25f43e922e3fc9de
-AUX Babel-2.9.0-pypy3.patch 1130 BLAKE2B 23abff434e982c8d8f8350c599b3b94ee07775e7244ce26f9bdd1d91b00ca0f25c03ee2b52b466b42de10036ad2004b6bfc53a1abf10bc328f5ad98a48604078 SHA512 8cae713129f7fb87d22b7cd5f5eb196a2f8990f83141bc9617f79b3e9c56e1873e1d74adaec79b4bacf0c6a7d721fb9ce5cd747fef355a55a1e518b94536d978
-DIST Babel-2.8.1.tar.gz 8471453 BLAKE2B bc2e66a3c1c77e5b190cdb3f53d149268b6f49adde3040cbe6a3dd8eb98f6caffb3988232e76083e606186a87b9ee6b2b5352de89b7bc43d4f72905f1f594127 SHA512 ed39ad01b873d40d0bc611739761d412ff442b2df3d4c2363ec24501547da678cb752f640a02470c8513073a76c468c27fc16248820c779ef7adbe14d0f07199
-DIST Babel-2.9.0.tar.gz 8682986 BLAKE2B 0e1e8fe647fdd27230ee9c97f0994772bd5877f262f9cd00eb450445c5780b278249f87d50f98c5ca3fa5eca287c6b4fc74c5e082c522c250d640912f0ebc581 SHA512 250d1a19741eb0d1bda9d6b862f2d4779b6c67f10b8e045f450a271a16587e30f26f35ccccfea8ca13bb519582d2ef83569fa4381d0590fb9b61bf3ebf67e5f6
-EBUILD Babel-2.8.1.ebuild 967 BLAKE2B 477668d4aed90f8e92a2b7130e37816f046d2a530174b40945ca480a9401c76e5a97c50047265c51ae9b3866b6e93982af4427200fed6f138ba4600eb0db1fc5 SHA512 892e023892b84836dbdc35cc4d59f1a9ded0593804addf757829a7434c3312aa8b04d4a4365b78cc8dc51fe6f1175324c99f89eb8d514c05317dbfc911ca5a48
-EBUILD Babel-2.9.0.ebuild 934 BLAKE2B 18ff81f0510d7b348566e8b8e41e7463ec7700cb8a1b6a9614d0334a7e2a7e859df426451a9fe05aa62766e1b4d9781e63dd957f31781d4f2bb2bec49b1a1d11 SHA512 844edc216546b31a8573795b135e751bd819782a453efe178c2551f170d95791286bcb4fedcd1901ec4b87fb8d4e2653b6f03b1006a5f66556542b25f10553ec
+DIST Babel-2.9.1.tar.gz 8683505 BLAKE2B e4c6fe7284f03cd9e3e712156d87a520a437316955679f765aa68ca941bf668c544c96598486f3dad1bbb1f1d9a0719ccd527f23a2b1fb0274e453bdba557bd7 SHA512 89a2ce18301b522907bb66ec5453cbcd4c6b2d494d6928c9c62dc07bd8b6983982db571a85e251a1ea413b6f76fbd515f65c67c9bccf5441c62d351a57f2f4d0
+EBUILD Babel-2.9.1.ebuild 1043 BLAKE2B b781e3c932b3121e68021087f77f984867f0284999c05f19cee7779bfe4ff2a0b322b0697e696b68d7fcef61cab666e0b6e8ab73fddc6ce467b530d757775c6e SHA512 5630aa39aa17bbe79d63a5eaf2535f6caa6cbb095b232e7833a7dba97e30589d9f06bcd40034974ecaa5acdbdaeb21eb22baa9c6fa12747b07527b843f425755
MISC metadata.xml 839 BLAKE2B d9916ce88ce8436bb28d15300e78013e1c9e0f88f385a369c0ad6840f0fe81ad136052a3c257cef50a2fd86500bcde2b652ad0ed664f95d6affa4ccc8770445b SHA512 3688c1488c552b84c685d0aeb6251aea4f9d41be3db3aeb226291655107e1332df13445545b3742587e133de7468a40f22ca53fa67fd8d2e0db570069498654f
diff --git a/dev-python/Babel/files/Babel-2.8.0-py39.patch b/dev-python/Babel/files/Babel-2.8.0-py39.patch
deleted file mode 100644
index efada9c1d08c..000000000000
--- a/dev-python/Babel/files/Babel-2.8.0-py39.patch
+++ /dev/null
@@ -1,169 +0,0 @@
-From 167b71421f113e2210e4deefef5020402492e5be Mon Sep 17 00:00:00 2001
-From: Felix Schwarz <felix.schwarz@oss.schwarz.eu>
-Date: Tue, 5 May 2020 09:58:01 +0200
-Subject: [PATCH] stop using deprecated ElementTree methods "getchildren()" and
- "getiterator()"
-
-Both methods were removed in Python 3.9 as mentioned in the release notes:
-
-> Methods getchildren() and getiterator() of classes ElementTree and Element in
-> the ElementTree module have been removed. They were deprecated in Python 3.2.
-> Use iter(x) or list(x) instead of x.getchildren() and x.iter() or
-> list(x.iter()) instead of x.getiterator().
----
- scripts/import_cldr.py | 18 +++++++++---------
- 1 file changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/scripts/import_cldr.py b/scripts/import_cldr.py
-index 8993b68e..2ed3af91 100755
---- a/scripts/import_cldr.py
-+++ b/scripts/import_cldr.py
-@@ -598,7 +598,7 @@ def parse_calendar_months(data, calendar):
- for width in ctxt.findall('monthWidth'):
- width_type = width.attrib['type']
- widths = ctxts.setdefault(width_type, {})
-- for elem in width.getiterator():
-+ for elem in width.iter():
- if elem.tag == 'month':
- _import_type_text(widths, elem, int(elem.attrib['type']))
- elif elem.tag == 'alias':
-@@ -616,7 +616,7 @@ def parse_calendar_days(data, calendar):
- for width in ctxt.findall('dayWidth'):
- width_type = width.attrib['type']
- widths = ctxts.setdefault(width_type, {})
-- for elem in width.getiterator():
-+ for elem in width.iter():
- if elem.tag == 'day':
- _import_type_text(widths, elem, weekdays[elem.attrib['type']])
- elif elem.tag == 'alias':
-@@ -634,7 +634,7 @@ def parse_calendar_quarters(data, calendar):
- for width in ctxt.findall('quarterWidth'):
- width_type = width.attrib['type']
- widths = ctxts.setdefault(width_type, {})
-- for elem in width.getiterator():
-+ for elem in width.iter():
- if elem.tag == 'quarter':
- _import_type_text(widths, elem, int(elem.attrib['type']))
- elif elem.tag == 'alias':
-@@ -649,7 +649,7 @@ def parse_calendar_eras(data, calendar):
- for width in calendar.findall('eras/*'):
- width_type = NAME_MAP[width.tag]
- widths = eras.setdefault(width_type, {})
-- for elem in width.getiterator():
-+ for elem in width.iter():
- if elem.tag == 'era':
- _import_type_text(widths, elem, type=int(elem.attrib.get('type')))
- elif elem.tag == 'alias':
-@@ -676,7 +676,7 @@ def parse_calendar_periods(data, calendar):
- def parse_calendar_date_formats(data, calendar):
- date_formats = data.setdefault('date_formats', {})
- for format in calendar.findall('dateFormats'):
-- for elem in format.getiterator():
-+ for elem in format.iter():
- if elem.tag == 'dateFormatLength':
- type = elem.attrib.get('type')
- if _should_skip_elem(elem, type, date_formats):
-@@ -696,7 +696,7 @@ def parse_calendar_date_formats(data, calendar):
- def parse_calendar_time_formats(data, calendar):
- time_formats = data.setdefault('time_formats', {})
- for format in calendar.findall('timeFormats'):
-- for elem in format.getiterator():
-+ for elem in format.iter():
- if elem.tag == 'timeFormatLength':
- type = elem.attrib.get('type')
- if _should_skip_elem(elem, type, time_formats):
-@@ -717,7 +717,7 @@ def parse_calendar_datetime_skeletons(data, calendar):
- datetime_formats = data.setdefault('datetime_formats', {})
- datetime_skeletons = data.setdefault('datetime_skeletons', {})
- for format in calendar.findall('dateTimeFormats'):
-- for elem in format.getiterator():
-+ for elem in format.iter():
- if elem.tag == 'dateTimeFormatLength':
- type = elem.attrib.get('type')
- if _should_skip_elem(elem, type, datetime_formats):
-@@ -880,7 +880,7 @@ def parse_interval_formats(data, tree):
- interval_formats[None] = elem.text
- elif elem.tag == "intervalFormatItem":
- skel_data = interval_formats.setdefault(elem.attrib["id"], {})
-- for item_sub in elem.getchildren():
-+ for item_sub in elem:
- if item_sub.tag == "greatestDifference":
- skel_data[item_sub.attrib["id"]] = split_interval_pattern(item_sub.text)
- else:
-@@ -903,7 +903,7 @@ def parse_currency_formats(data, tree):
- type = '%s:%s' % (type, curr_length_type)
- if _should_skip_elem(elem, type, currency_formats):
- continue
-- for child in elem.getiterator():
-+ for child in elem.iter():
- if child.tag == 'alias':
- currency_formats[type] = Alias(
- _translate_alias(['currency_formats', elem.attrib['type']],
-From 7bdaa28a55e8d8228d5434effa4b1473ab7b3669 Mon Sep 17 00:00:00 2001
-From: Felix Schwarz <felix.schwarz@oss.schwarz.eu>
-Date: Tue, 5 May 2020 08:05:56 +0000
-Subject: [PATCH] fix tests when using Python 3.9a6
-
-In Python 3.9a6 integer values for future flags were changed to prevent
-collision with compiler flags. We need to retrieve these at runtime so
-the test suite works with Python <= 3.8 as well as Python 3.9.
----
- tests/test_util.py | 17 ++++++++++++-----
- 1 file changed, 12 insertions(+), 5 deletions(-)
-
-diff --git a/tests/test_util.py b/tests/test_util.py
-index a6a4450c..b9343aaa 100644
---- a/tests/test_util.py
-+++ b/tests/test_util.py
-@@ -11,6 +11,7 @@
- # individuals. For the exact contribution history, see the revision
- # history and logs, available at http://babel.edgewall.org/log/.
-
-+import __future__
- import unittest
-
- import pytest
-@@ -20,6 +21,12 @@
- from babel.util import parse_future_flags
-
-
-+class _FF:
-+ division = __future__.division.compiler_flag
-+ print_function = __future__.print_function.compiler_flag
-+ with_statement = __future__.with_statement.compiler_flag
-+ unicode_literals = __future__.unicode_literals.compiler_flag
-+
- def test_distinct():
- assert list(util.distinct([1, 2, 1, 3, 4, 4])) == [1, 2, 3, 4]
- assert list(util.distinct('foobar')) == ['f', 'o', 'b', 'a', 'r']
-@@ -70,25 +77,25 @@ def test_parse_encoding_non_ascii():
- from __future__ import print_function,
- division, with_statement,
- unicode_literals
--''', 0x10000 | 0x2000 | 0x8000 | 0x20000),
-+''', _FF.print_function | _FF.division | _FF.with_statement | _FF.unicode_literals),
- ('''
- from __future__ import print_function, division
- print('hello')
--''', 0x10000 | 0x2000),
-+''', _FF.print_function | _FF.division),
- ('''
- from __future__ import print_function, division, unknown,,,,,
- print 'hello'
--''', 0x10000 | 0x2000),
-+''', _FF.print_function | _FF.division),
- ('''
- from __future__ import (
- print_function,
- division)
--''', 0x10000 | 0x2000),
-+''', _FF.print_function | _FF.division),
- ('''
- from __future__ import \\
- print_function, \\
- division
--''', 0x10000 | 0x2000),
-+''', _FF.print_function | _FF.division),
- ])
- def test_parse_future(source, result):
- fp = BytesIO(source.encode('latin-1'))
diff --git a/dev-python/Babel/files/Babel-2.9.0-pypy3.patch b/dev-python/Babel/files/Babel-2.9.0-pypy3.patch
deleted file mode 100644
index 45d50f5ff0b7..000000000000
--- a/dev-python/Babel/files/Babel-2.9.0-pypy3.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From a291ee5da29fb9767ce8dc5f94e3fa19908f2596 Mon Sep 17 00:00:00 2001
-From: Keri Volans <keri.volans@gmail.com>
-Date: Sun, 10 May 2020 18:43:58 +0100
-Subject: [PATCH] tests/test_dates.py: Fix broken test
-
-datetime was being incorrectly patched, so the unittest was failing
-
-Closes https://github.com/python-babel/babel/issues/675
----
- tests/test_dates.py | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/tests/test_dates.py b/tests/test_dates.py
-index 5be0d16a..3cd70d3e 100644
---- a/tests/test_dates.py
-+++ b/tests/test_dates.py
-@@ -761,7 +761,6 @@ def test_zh_TW_format():
-
-
- def test_format_current_moment(monkeypatch):
-- import datetime as datetime_module
- frozen_instant = datetime.utcnow()
-
- class frozen_datetime(datetime):
-@@ -771,7 +770,7 @@ def utcnow(cls):
- return frozen_instant
-
- # Freeze time! Well, some of it anyway.
-- monkeypatch.setattr(datetime_module, "datetime", frozen_datetime)
-+ monkeypatch.setattr(dates, "datetime_", frozen_datetime)
- assert dates.format_datetime(locale="en_US") == dates.format_datetime(frozen_instant, locale="en_US")
-
-