summaryrefslogtreecommitdiff
path: root/dev-python/Babel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
commite91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (patch)
treeee7587dfd365faadd9b297d595c31368bf94f9ca /dev-python/Babel
parent2d446203bcf1a0db08e99abca43513d246dfa73d (diff)
gentoo resync : 07.04.2018
Diffstat (limited to 'dev-python/Babel')
-rw-r--r--dev-python/Babel/Babel-2.5.3-r1.ebuild49
-rw-r--r--dev-python/Babel/Manifest1
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/Babel/Babel-2.5.3-r1.ebuild b/dev-python/Babel/Babel-2.5.3-r1.ebuild
new file mode 100644
index 000000000000..70d214cb4144
--- /dev/null
+++ b/dev-python/Babel/Babel-2.5.3-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of tools for internationalizing Python applications"
+HOMEPAGE="http://babel.edgewall.org/ https://pypi.python.org/pypi/Babel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="doc test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Make the tests use implementation-specific datadir,
+ # because they try to write in it.
+ sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
+ -i tests/messages/test_frontend.py || die
+ sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Create implementation-specific datadir for tests.
+ cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
+ py.test || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/Babel/Manifest b/dev-python/Babel/Manifest
index 66836f7af81b..d4ecba1a91d6 100644
--- a/dev-python/Babel/Manifest
+++ b/dev-python/Babel/Manifest
@@ -1,5 +1,6 @@
DIST Babel-2.5.0.tar.gz 6612353 BLAKE2B 85268f0226f1db019fb906da0dfbbc6b6aa199ab491e9d767c932fb5ca77cb6d86328ebaa9c6eb61fb8d28c8e566babd435cdcee9b900c3c680d0dfb49c2bcac SHA512 b24b74121695e0068fb28a6294d4b5b2065e94dcd62ca0d70c8fde3a00cb5ff111480505594460989c6f67a75935f55e153b1b493f917317d2c5ee0f0d7921fc
DIST Babel-2.5.3.tar.gz 6611941 BLAKE2B 99b71642b00a853fea844220c0ce5ef2fe425906cbdd1618e31f39b60d16382d54ff5e00c493153eee2be8894edc8c96e57fc2703620db5bafcf7b7a4f1b72ef SHA512 1a41f69141da9f66e27110e7a1a5955f76d8ae9353ff7e54182c5bb6ca16e8b4799031e4df1049af54de513da9f101e171e4312b2e7775f2cab9116d5b50c0fb
EBUILD Babel-2.5.0.ebuild 1477 BLAKE2B 340f4e488117ed48288f9d842ec23b9fbd70294bfd471a4fec68d1fade530c8455435280d11b201307cd98e8300d46f544448cb7bf399cc70a439009a9aa8e16 SHA512 db072a3022bf1558201853cddc02a7b0614ffdd474a467fb4d819f7dcde5fcdd227dd37a65205b530bee715ebbd16dcbd0ac00af8b5759e52ab63def0b9948c6
+EBUILD Babel-2.5.3-r1.ebuild 1528 BLAKE2B 543f0e06a57ccba2d069b4eb4b89412c01098ec467be3c894238e4627c77b3b444cef2abb41adc4f9ffa5a8b63d4739843d7e6501f6bab89d300c75f7466c666 SHA512 552301531114bc906245919d1ed8639288d3b3af9ac384358e2b401524ceb231a8eb3b8017cea371affe48d901939ed11666ab1faf137bb74f2106e2f5919976
EBUILD Babel-2.5.3.ebuild 1478 BLAKE2B 78ac9ba8239fc1d6da3981d3a7e50e51c8e229ffe71578e71da5ac6c1634b710aa65cee0ca547a17a1f46ad491def4bf40afa60eff62ac6d4b1e05850e24b2a3 SHA512 7c5137bcc60576c5c8227a958cc8640924fa3f56bc66b7387d1c7b8e7a2be0157595f2803500a0ee37cb34a48f92dc40c26cc455562ae6041cd67ac939b4c0af
MISC metadata.xml 691 BLAKE2B 9e0ec2fb9848f2994ed990ba0e9de14963eac7f1847fe7918e64030af2c3189ed194775a9ae7c506cb923ca7421f309fda970a8c97cf3bf8d7feab55ac15045a SHA512 91b4f1fa5ceebae1ded51ef3bee9a5c47380709eb3ededd83f8cbb20a85c45acd0603fb8c7244910c15037036056047b074b79c5d6668f68c44d29cb507e76e7