summaryrefslogtreecommitdiff
path: root/dev-python/BitVector/BitVector-3.4.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/BitVector/BitVector-3.4.7.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/BitVector/BitVector-3.4.7.ebuild')
-rw-r--r--dev-python/BitVector/BitVector-3.4.7.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/BitVector/BitVector-3.4.7.ebuild b/dev-python/BitVector/BitVector-3.4.7.ebuild
new file mode 100644
index 000000000000..7d2d6cb3cf16
--- /dev/null
+++ b/dev-python/BitVector/BitVector-3.4.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python memory-efficient packed representation for bit arrays"
+HOMEPAGE="https://engineering.purdue.edu/kak/dist/ https://pypi.org/project/BitVector/"
+SRC_URI="https://engineering.purdue.edu/kak/dist/${P}.tar.gz"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" TestBitVector/Test.py || die "Tests fail with ${EPYTHON}"
+}