summaryrefslogtreecommitdiff
path: root/dev-python/CacheControl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/CacheControl
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/CacheControl')
-rw-r--r--dev-python/CacheControl/CacheControl-0.11.5.ebuild36
-rw-r--r--dev-python/CacheControl/CacheControl-0.11.7.ebuild36
-rw-r--r--dev-python/CacheControl/Manifest6
-rw-r--r--dev-python/CacheControl/metadata.xml12
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/CacheControl/CacheControl-0.11.5.ebuild b/dev-python/CacheControl/CacheControl-0.11.5.ebuild
new file mode 100644
index 000000000000..2251e541e473
--- /dev/null
+++ b/dev-python/CacheControl/CacheControl-0.11.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="The httplib2 caching algorithms packaged up for use with requests"
+HOMEPAGE="https://github.com/ionrock/cachecontrol https://pypi.python.org/pypi/cachecontrol/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
+DEPENDS="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+# Not included
+RESTRICT=test
+
+python_test() {
+ py.test -v -v || die
+}
+
+pkg_postinst() {
+ optfeature "Redis based caches" dev-python/redis-py
+}
diff --git a/dev-python/CacheControl/CacheControl-0.11.7.ebuild b/dev-python/CacheControl/CacheControl-0.11.7.ebuild
new file mode 100644
index 000000000000..32bda26542db
--- /dev/null
+++ b/dev-python/CacheControl/CacheControl-0.11.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="The httplib2 caching algorithms packaged up for use with requests"
+HOMEPAGE="https://github.com/ionrock/cachecontrol https://pypi.python.org/pypi/cachecontrol/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+# Not included
+RESTRICT=test
+
+python_test() {
+ py.test -v -v || die
+}
+
+pkg_postinst() {
+ optfeature "Redis based caches" dev-python/redis-py
+}
diff --git a/dev-python/CacheControl/Manifest b/dev-python/CacheControl/Manifest
new file mode 100644
index 000000000000..c09306853e47
--- /dev/null
+++ b/dev-python/CacheControl/Manifest
@@ -0,0 +1,6 @@
+DIST CacheControl-0.11.5.tar.gz 13104 SHA256 b78484d6feb17b501267f4048c364a8fc26fcef35ca3ff62bdba63d41fa4cf42 SHA512 2acce5a8be2e409a1a18254cfe71314074037bce3341f8b8fdec52c43500c90bfdb6063b2121c5cf6c8a2fc7c0903e4fd0c15813ffdfa547810b33571d211deb WHIRLPOOL 5e12640ba5c952ee8a83f5271bbbd105f148cd080bf6ae5c2cbc9c6cc20361005aa5cf1a95feaa1a808c56c26b7abdfbde3b7bffc873f26072d23262c12b49ca
+DIST CacheControl-0.11.7.tar.gz 13902 SHA256 8f7829d92584f1f2360ebfff4517ee359787d5b7dfa2ef9579f871b628745a1e SHA512 fad1f93140dd6fcedb3797f4dbc1587045ade8dafe6cbc6774bf62bd635fbc1ba08b2dec124745cffed5259606b55f0e2edee036b5b5e34156d3114f6bf63493 WHIRLPOOL 736a503fae24d8ba1ecc13a1d47d8f51b0f478f1890de52747b56b3aba770e44aba4eae48bd6140a0611931fa1cdfb5ee5315f833abb997aa69143ee9b84b9e4
+EBUILD CacheControl-0.11.5.ebuild 899 SHA256 27fdf3c06a987c430b60aed1c7fee5fd6416bf5d1ec4c22f283162f4b451896a SHA512 c9906e082893ab15edca724ed14007ded9bafec5d2cd22f9517284a9777722d481027a050b963f277885cd7fa2c6078935987c98e25037c09244de80855062e4 WHIRLPOOL 08baa76e442cb1250b8657736729111df6ddbf941fb12b5873632c190df45198d818662fce33ef4e76bb32ae7db5d9c943ba46e5d7179d00558bfe347547e726
+EBUILD CacheControl-0.11.7.ebuild 907 SHA256 5e2bfbd24f02c88334ed339cbbb6f9ebcca190eecd4c9ad21d456813a85d7e0b SHA512 f83ade5f30ebd6e15f06322bf865a5d174d1acd8e66a849ce671c46e808586ebd7fc7de77e3dbef3140c76b413f8fc97bac8cbf49f5825b918864c33d9d02b7e WHIRLPOOL c2fa6fd01bdfb5a6bafdb977254305bee5a619cf53812d5f0f63eb1290d316f1f50688af649a3c846f11002602be07a146690b0bced5b49154a088bf45c6ef4e
+MISC ChangeLog 5489 SHA256 c37192cdf6cb9429ca232e1865da23066f928439329dcbac8010426d34a1e65a SHA512 a66163fd2f87fd88d2d30bc829f4d909d80be23f0d3be973a3dcce4a32cff80a1d9779f6014cf3d3b764c54710cec1482ded78aa94aa0c2981d82deb97989283 WHIRLPOOL aa04bf146db18049f384576aca4e569ca70e012234fe0020df2241d776bff0cf1815db24ff574695f6c03fd6aa572275082002d1fca18cfa27d70985cccfffac
+MISC metadata.xml 387 SHA256 2489e872a5c0fe2c69017187eb092455259e344699bf597870bc50e2c3ed606c SHA512 c80bc300402e7cac33d5350aafda6c93579b3d14094ea34bfe4dd898ca498ab0139c428f01e4917544df64a1aef0022a4868650e2bb66f2cf9606c28fe885f65 WHIRLPOOL 85d1c45a9d00892d1c45ec1143488c644f94c42190de5d235dcd5477536a7f144a21c65065ba64c79b0b8680f2ada86bab24c12a8827d2e5f536006d3e6ad97f
diff --git a/dev-python/CacheControl/metadata.xml b/dev-python/CacheControl/metadata.xml
new file mode 100644
index 000000000000..54195ee03e79
--- /dev/null
+++ b/dev-python/CacheControl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ionrock/cachecontrol</remote-id>
+ <remote-id type="pypi">CacheControl</remote-id>
+ </upstream>
+</pkgmetadata>