summaryrefslogtreecommitdiff
path: root/dev-python/CommonMark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/CommonMark
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/CommonMark')
-rw-r--r--dev-python/CommonMark/CommonMark-0.5.4.ebuild33
-rw-r--r--dev-python/CommonMark/CommonMark-0.7.3.ebuild31
-rw-r--r--dev-python/CommonMark/CommonMark-0.7.4.ebuild45
-rw-r--r--dev-python/CommonMark/Manifest7
-rw-r--r--dev-python/CommonMark/metadata.xml19
5 files changed, 135 insertions, 0 deletions
diff --git a/dev-python/CommonMark/CommonMark-0.5.4.ebuild b/dev-python/CommonMark/CommonMark-0.5.4.ebuild
new file mode 100644
index 000000000000..e25cf425023e
--- /dev/null
+++ b/dev-python/CommonMark/CommonMark-0.5.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python parser for the CommonMark Markdown spec"
+HOMEPAGE="https://github.com/rtfd/CommonMark-py"
+LICENSE="BSD"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+IUSE=""
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# unrestrict for versions >= 0.7.2
+RESTRICT=test
+
+python_test() {
+ LC_ALL='en_US.utf8' LC_CTYPE='en_US.utf8' LANG=en_US.utf8 PYTHONIOENCODING=UTF-8 \
+ esetup.py test
+}
diff --git a/dev-python/CommonMark/CommonMark-0.7.3.ebuild b/dev-python/CommonMark/CommonMark-0.7.3.ebuild
new file mode 100644
index 000000000000..95f715545b5d
--- /dev/null
+++ b/dev-python/CommonMark/CommonMark-0.7.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python parser for the CommonMark Markdown spec"
+HOMEPAGE="https://github.com/rtfd/CommonMark-py"
+LICENSE="BSD"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE=""
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ PYTHONIOENCODING='utf8' \
+ esetup.py test
+}
diff --git a/dev-python/CommonMark/CommonMark-0.7.4.ebuild b/dev-python/CommonMark/CommonMark-0.7.4.ebuild
new file mode 100644
index 000000000000..bd4fc9bf81bd
--- /dev/null
+++ b/dev-python/CommonMark/CommonMark-0.7.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python parser for the CommonMark Markdown spec"
+HOMEPAGE="https://github.com/rtfd/CommonMark-py"
+LICENSE="BSD"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="test"
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/flake8-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.7.1[${PYTHON_USEDEP}]
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ PYTHONIOENCODING='utf8' \
+ esetup.py test
+}
+
+src_prepare() {
+ default
+ # Fix file collision with app-text/cmark, see bug #627034
+ sed -i -e "s:'cmark\( = CommonMark.cmark\:main'\):'cmark.py\1:" \
+ setup.py || die
+}
+
+pkg_postinst() {
+ ewarn "/usr/bin/cmark has been renamed to /usr/bin/cmark.py due file"
+ ewarn "collision with app-text/cmark (see bug #627034)"
+}
diff --git a/dev-python/CommonMark/Manifest b/dev-python/CommonMark/Manifest
new file mode 100644
index 000000000000..fda464fb309f
--- /dev/null
+++ b/dev-python/CommonMark/Manifest
@@ -0,0 +1,7 @@
+DIST CommonMark-0.5.4.tar.gz 120316 SHA256 34d73ec8085923c023930dfc0bcd1c4286e28a2a82de094bb72fabcc0281cbe5 SHA512 1983714a50a627f30f86af0d02dad9e52cb7b0ffce29691d0e740f587e599ead6de2412d72b895b7df772e1c81e171e56dfecaf593e611af65bd5798632a98ad WHIRLPOOL f375b772faff450af98d73b3559dabe7b7369951cd8cf9ea45046bf5de875022212b7e92daee3fa7d3fb63d44894a301991a4561ac8a8b0c78eef64c83062fad
+DIST CommonMark-0.7.3.tar.gz 85177 SHA256 5f20ebd91614c8d339d4cded314894feb5d9a54c3b52c1ff9883794557149ea8 SHA512 34ddf0539b54d79cd16356124a15e4f51076a7afdde78fbaa0cab06658279357c5523d89bdfa7d595d85da9df9b194491ddac22b78444b230f53298ffd11c8cf WHIRLPOOL 41b1da6e2c1479b8b47b048d529282a8618f455653ad88e65f1460c55c74ccb7df563e159470ae8d912deede190d5da18b88111420a0d48fe264724e993871ef
+DIST CommonMark-0.7.4.tar.gz 87841 SHA256 24678b72094398df96312fb927e274ccaf5148f25e47aca9f7fc062693ae7577 SHA512 7c76a5f0dec02e9ae8c2f73ebd2980a5a684b43ee8a82ea23b72c7f2332e1d4316a7b2d7b66ad8fe912803115a57e03b2ae4c7b042cc53e1205e579093053b89 WHIRLPOOL 22a9ce7fd17dbf2b441b870b458a0cd257f6e343aeae837ebad452d4ada58dceaede631409c11ba87d81ba4fce14d68d2c6e9e9d3e0a42de2b3aac790b4adf75
+EBUILD CommonMark-0.5.4.ebuild 745 SHA256 e3dd4f6acf36d0253c36442740205bfe15bdf4dd4fa6b8e742f2ed21c6e7703f SHA512 ef3f8cd93fd9d24d576a53837747b7c41bdfca3ff6b98e16975b0b91dd993c115e21fba3a0dccb83ba9a6db7e8c7fb3f2840578557819f7fd8c5f0fd965fbac3 WHIRLPOOL c9f7d0926ee5684224a7494bfeaf18cdd545a7627c44855e6c132b0db6445b77269d527d5bbff738a14f6b4ca99aebd7060ae5259d9c1669bcea67224b9c0867
+EBUILD CommonMark-0.7.3.ebuild 674 SHA256 a443bfce3005ce5e6ccfba9a60be17ee42797bf88c365ea6d0c1c9c36877af1c SHA512 c12aaa35eab159bd46736ba914a0b5828e8a8660fd2e6d321905a42178ff06e8fa61eb3cd59cd5dcbadcd492bc26e6a4589c4a595a66e1326fdfe6b6f7e907f0 WHIRLPOOL 5d1b5e0ec7366c6934fb5f42246fd0fabb6ddba4a425436fbb6d0646a980b9946231eee48287c76daa9a9224cb07057c64e7568825e1c13484baa13612274749
+EBUILD CommonMark-0.7.4.ebuild 1028 SHA256 a57d7e7c5118427d181356d1e2f70c362cf8156972b080c84dad9b2898638291 SHA512 6346dd647dd2a40844c0b9521fd15d4658c79db46e52c6456f5802de305a28201cc33a565a2a29699cd79f602867079a83a84ec007889d0014f1d2474105896a WHIRLPOOL ba71d1534578dd9f8ed47ad3a7680c9eb2ada0415f4bed291ba9fc38bf8b2d74af1ba1ad5680e18ebe2c50e622ce161ae81b940503741b17e8111a44bd4ac881
+MISC metadata.xml 756 SHA256 cb2d2b45347118348704b7b8fb2df45e22b6361eb8545839ff90444823dc0af7 SHA512 1a28755c041abef9cb797c8d9ea448a62a500a915ae9c4002a22f85886fbae62c2574675926e80e5ffdcacf3a3257fc9065a14d6495574c556288b334274b03c WHIRLPOOL a9a537dfcff3a3deff48af9f9aff9333705095a27658429ca59aa6ec87b5614eff2e7d8bef6a91004e3afa219ad06c990e802582cfc43e73b0c86215ff5a260a
diff --git a/dev-python/CommonMark/metadata.xml b/dev-python/CommonMark/metadata.xml
new file mode 100644
index 000000000000..fc5b696a8da1
--- /dev/null
+++ b/dev-python/CommonMark/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Pure Python port of jgm’s commonmark.js, a Markdown parser and
+ renderer for the CommonMark specification, using only native
+ modules. Once both this project and the CommonMark specification
+ are stable we will release the first 1.0 version and attempt to
+ keep up to date with changes in commonmark.js.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">CommonMark</remote-id>
+ <remote-id type="github">rtfd/CommonMark.py</remote-id>
+ </upstream>
+</pkgmetadata>