summaryrefslogtreecommitdiff
path: root/dev-python/DBUtils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/DBUtils
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/DBUtils')
-rw-r--r--dev-python/DBUtils/DBUtils-3.0.2-r1.ebuild30
-rw-r--r--dev-python/DBUtils/DBUtils-3.0.2.ebuild28
-rw-r--r--dev-python/DBUtils/Manifest4
-rw-r--r--dev-python/DBUtils/metadata.xml26
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/DBUtils/DBUtils-3.0.2-r1.ebuild b/dev-python/DBUtils/DBUtils-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..20fcb08c9bda
--- /dev/null
+++ b/dev-python/DBUtils/DBUtils-3.0.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Database connections for multi-threaded environments"
+HOMEPAGE="
+ https://webwareforpython.github.io/DBUtils/
+ https://github.com/WebwareForPython/DBUtils/
+ https://pypi.org/project/DBUtils/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ dodoc docs/*.rst
+ rm docs/*.rst || die
+ local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/DBUtils/DBUtils-3.0.2.ebuild b/dev-python/DBUtils/DBUtils-3.0.2.ebuild
new file mode 100644
index 000000000000..a4bba141fed4
--- /dev/null
+++ b/dev-python/DBUtils/DBUtils-3.0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Database connections for multi-threaded environments"
+HOMEPAGE="
+ https://webwareforpython.github.io/DBUtils/
+ https://github.com/WebwareForPython/DBUtils/
+ https://pypi.org/project/DBUtils/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ dodoc docs/*.rst
+ rm docs/*.rst || die
+ local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/DBUtils/Manifest b/dev-python/DBUtils/Manifest
new file mode 100644
index 000000000000..51d6fe1c3813
--- /dev/null
+++ b/dev-python/DBUtils/Manifest
@@ -0,0 +1,4 @@
+DIST DBUtils-3.0.2.tar.gz 92566 BLAKE2B ee63b252eedeba18ab1db68c10ebe7b2204bef4d2f7d07fc09a095d632dca97304280ed7f14994644e42835fd61717b88de6902feb97df04533979b2b82625ed SHA512 3e4631b8c30466e0f8be438b980fe98071535ea63e06c69161ffda89ed2716fd84c406ace1b3b78e7811bebbc7d0383f080a43b58ed073c37280a7282cb9ccb6
+EBUILD DBUtils-3.0.2-r1.ebuild 661 BLAKE2B ab5329da7c96719ab116560b8739f6a30d159e4301f1fa7e4c6ba75c917200cc2ef23e9c133d56a26951543b1c903eef131e14ef85b674fbc1ea8916b11e03e1 SHA512 09eabb22d195dbf04ab8b5da0352944da3db46eeb9534530ac964df042a325f00c32ddabc06c07759908251b89bf0505293643834ffd467bc016e512a8480c01
+EBUILD DBUtils-3.0.2.ebuild 628 BLAKE2B 295ca8c8d083e38894582e716fb8cc665d60938a5978347eb92844415a30680f29939cfb7b5c87cb15e18c85ea5bd7e5337b6cab17b5e1395f11388d0bca77cd SHA512 36ad2f2ae864622bd4e7a488fedabaeddec494c75630c6e4c007f313df5df96e1d17ec87457631d3f7108b33ce1b05587fc279bc0123cb6b99399f7fa77aefae
+MISC metadata.xml 1005 BLAKE2B e6d13ea0ffdc7d972db2bd8f5f0e2212937e36c1646e900f2eb76cf270ae840db7211d218e6900208bafab3fef0c5226128cebabeb52a51e8204b1981809683c SHA512 ba6884914df60365c4b085b56abcc3e927e780f4f8baa6e2cca745cdc53a1fb18917f1b1532d9e957e515a7d5b8e190d87e556547b98a094062f672b3a1b14cf
diff --git a/dev-python/DBUtils/metadata.xml b/dev-python/DBUtils/metadata.xml
new file mode 100644
index 000000000000..5890a14a76bf
--- /dev/null
+++ b/dev-python/DBUtils/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ DBUtils is a suite of tools providing solid, persistent and pooled connections
+ to a database that can be used in all kinds of multi-threaded environments
+ like Webware for Python or other web application servers. The suite supports
+ DB-API 2 compliant database interfaces and the classic PyGreSQL interface.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">WebwareForPython/DBUtils</remote-id>
+ <remote-id type="pypi">DBUtils</remote-id>
+ </upstream>
+</pkgmetadata>