summaryrefslogtreecommitdiff
path: root/dev-python/Faker/Faker-19.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-13 10:34:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-13 10:34:32 +0100
commit9005249591e1f61febbb2a3176f9b40e6d7d2063 (patch)
tree6f23e32a7a97fb2b9719c6283e0006d6a7916369 /dev-python/Faker/Faker-19.1.0.ebuild
parent1206d22a2d6005bb271c68ea4e9b5c610a74b225 (diff)
gentoo auto-resync : 13:07:2023 - 10:34:32
Diffstat (limited to 'dev-python/Faker/Faker-19.1.0.ebuild')
-rw-r--r--dev-python/Faker/Faker-19.1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-19.1.0.ebuild b/dev-python/Faker/Faker-19.1.0.ebuild
new file mode 100644
index 000000000000..48c456a2d7b5
--- /dev/null
+++ b/dev-python/Faker/Faker-19.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest