summaryrefslogtreecommitdiff
path: root/dev-python/Faker/Faker-19.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-02 15:47:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-02 15:47:42 +0000
commit48ee15e0d6219049c34310890504cad652b756ea (patch)
tree18384522dd86149666e4e97758cf77e4151f694f /dev-python/Faker/Faker-19.13.0.ebuild
parenta0c5e9067531830baf9160de325fe77145f02987 (diff)
gentoo auto-resync : 02:11:2023 - 15:47:42
Diffstat (limited to 'dev-python/Faker/Faker-19.13.0.ebuild')
-rw-r--r--dev-python/Faker/Faker-19.13.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-19.13.0.ebuild b/dev-python/Faker/Faker-19.13.0.ebuild
new file mode 100644
index 000000000000..34d2cdd3a7af
--- /dev/null
+++ b/dev-python/Faker/Faker-19.13.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
+ epytest
+}