summaryrefslogtreecommitdiff
path: root/dev-python/GitPython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/GitPython
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/GitPython')
-rw-r--r--dev-python/GitPython/GitPython-3.1.2.ebuild57
-rw-r--r--dev-python/GitPython/GitPython-3.1.3.ebuild57
-rw-r--r--dev-python/GitPython/GitPython-3.1.7.ebuild (renamed from dev-python/GitPython/GitPython-3.1.1.ebuild)19
-rw-r--r--dev-python/GitPython/Manifest16
-rw-r--r--dev-python/GitPython/metadata.xml1
5 files changed, 17 insertions, 133 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.2.ebuild b/dev-python/GitPython/GitPython-3.1.2.ebuild
deleted file mode 100644
index 4c35f34de642..000000000000
--- a/dev-python/GitPython/GitPython-3.1.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-TEST_P=GitPython-3.1.0
-GITDB_P=gitdb-4.0.2
-SMMAP_P=smmap-3.0.1
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
- test? (
- https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests unittest
-
-src_test() {
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
-
- git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
- git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb || die
- git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
-
- cd "${T}"/test || die
- # remove performance tests
- rm -r git/test/performance || die
- # tests requiring network access
- sed -i -e 's:test_fetch_error:_&:' git/test/test_remote.py || die
- # broken apparently
- sed -i -e 's:test_rev_parse:_&:' git/test/test_repo.py || die
-
- distutils-r1_src_test
-}
diff --git a/dev-python/GitPython/GitPython-3.1.3.ebuild b/dev-python/GitPython/GitPython-3.1.3.ebuild
deleted file mode 100644
index 4ac8b651ff03..000000000000
--- a/dev-python/GitPython/GitPython-3.1.3.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-TEST_P=GitPython-3.1.0
-GITDB_P=gitdb-4.0.2
-SMMAP_P=smmap-3.0.1
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
- test? (
- https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
- https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests unittest
-
-src_test() {
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
-
- git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
- git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb || die
- git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
- "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
-
- cd "${T}"/test || die
- # remove performance tests
- rm -r git/test/performance || die
- # tests requiring network access
- sed -i -e 's:test_fetch_error:_&:' git/test/test_remote.py || die
- # broken apparently
- sed -i -e 's:test_rev_parse:_&:' git/test/test_repo.py || die
-
- distutils-r1_src_test
-}
diff --git a/dev-python/GitPython/GitPython-3.1.1.ebuild b/dev-python/GitPython/GitPython-3.1.7.ebuild
index 828e9672b499..e7aa556f3932 100644
--- a/dev-python/GitPython/GitPython-3.1.1.ebuild
+++ b/dev-python/GitPython/GitPython-3.1.7.ebuild
@@ -3,14 +3,14 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
-TEST_P=GitPython-3.1.0
-GITDB_P=gitdb-4.0.2
-SMMAP_P=smmap-3.0.1
+TEST_P=GitPython-${PV}
+GITDB_P=gitdb-4.0.5
+SMMAP_P=smmap-3.0.4
DESCRIPTION="Library used to interact with Git repositories"
HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
@@ -46,12 +46,13 @@ src_test() {
"${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
cd "${T}"/test || die
- # remove performance tests
- rm -r git/test/performance || die
+ rm -r test/performance || die
# tests requiring network access
- sed -i -e 's:test_fetch_error:_&:' git/test/test_remote.py || die
- # broken apparently
- sed -i -e 's:test_rev_parse:_&:' git/test/test_repo.py || die
+ sed -i -e 's:test_fetch_error:_&:' test/test_remote.py || die
+ rm test/test_installation.py || die
+ # broken apparently (also fails in git clone)
+ sed -e 's:test_rev_parse:_&:' \
+ -i test/test_repo.py || die
distutils-r1_src_test
}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index 1ac7e9f561bf..d6672e33aa05 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,10 +1,6 @@
-DIST GitPython-3.1.0.gitbundle 8618276 BLAKE2B a1ecf49c47804b399453c6931fb54903309944b47a5a8ccd02d62f4b27943e60b4b58a9e67567008fa4d5bc791b1c86642659c045c885e2155e2c44bb1a4ea81 SHA512 a71463f861f840d3169a8351155665243d9f0f0a72e210940f9f7872cfd49b6ddfac827f0ec5bc61079d8066fc7ba210a03dd99f3bbd598e22ccbcacfe8e61b3
-DIST GitPython-3.1.1.tar.gz 430310 BLAKE2B f6402c4f8d72f4352bf97b72ac0c39b347683c411dcb7b74405119773954a185fe7dc11e13232d56f4a9f938e64b865f42cbd3a857427d985e29f024eb4e0880 SHA512 a913fb611479456d4b804c56039ed8d8ac8cb183f58c874e265141f2b5b46befd4a8a2f5d94ac1cf8ea7fc99e901568a9fc054d50df0ac242d7d184add8ca1b3
-DIST GitPython-3.1.2.tar.gz 430474 BLAKE2B bda0fc9d591dd3b64158e318386349c18ed0775f462c487726faed7ce10781296103133b64cdbfd56947e38621790b177b6c9869596dc8a523a17b00690fe5e4 SHA512 051b59b56a163839bf7754860bfc8e21cfde08b8e7d0fd66239c234b89ba5a83fa7e8540a12c5df3563e5353d1e01119dd1b0a5ea1c22daf7e071fb963cbc3a4
-DIST GitPython-3.1.3.tar.gz 430558 BLAKE2B 0a36e066ad4d3d994ebaa76492f4953c0eaf8b4a0fc163af646f288ed45591e0dee532502c03007af5f6d6cf5633a32bc12a9a777fad6d745bdbc286a4815de4 SHA512 ea4043c8be79cec7ffc9c6b6383be37dcf7b4a877cf02d6fc8c9e7d39a5005e088c8780dd6e0fcd72c0711c997228f417773c82572f569c5ca1128f5ebe56736
-DIST gitdb-4.0.2.gitbundle 1474197 BLAKE2B 93dc8aeb3a43f0950bec1e8dc0c0156543a0a1ce1f20a7f0b2cd05c110338af05b6c6300c3f4b2c05e0f895496248e5fdca74eb599a4ea9aa983ed399d91f7c6 SHA512 8d4ebc93d6869a60b7717fc090000067e86a7e0373c281d0fb9939a6e2e283864256f827919eeb13be977254c0c71a4864d8e7c9b4b6dcc0af6275aa59681960
-DIST smmap-3.0.1.gitbundle 263781 BLAKE2B 6e06586010814ce0f59367c7f9289dad4891ee1debbc020b192af3945207da05b1e34907f1871f5b6b9638706b9e2fdacf390fcfff6bd06af84b9fd80f7e63a8 SHA512 c2b6c0b295c2997ed53727d3d1458ae7ec5ddbde9c83349286904726865fc026a70161955498b1a06371fb8d937e7386b80b4ea0c2e5d1c647718e6dbea93104
-EBUILD GitPython-3.1.1.ebuild 1565 BLAKE2B 188eee0c7d2caafe5aa17989fa5bec5f903b42ec644805b69b03fedb82325aaa3a47987062d685e5b427775505b6320b974cc594cff1ceb5878468914796cf9b SHA512 5153569d57e66bd7698de8e7adc3fcfa8ecbf79ab929364bd16a368afdb01390d79195f1880b17e9e9e2e67b22aa4713e812eeea4c65e00c19cca329fde47723
-EBUILD GitPython-3.1.2.ebuild 1568 BLAKE2B 5bd129321bc6012432a32586c2c6c13dc96821bc7cb6f322cf7cb03763c06d746d4907e628c9376fcb154d2c45f52a6dd40d61f08372f91d778a8ccbba1ce331 SHA512 4688e66c53578accc218eaa25f4aa2fcbffc4c24782a5dd2a23067e6c60f9bdfb008771aee62f8dd98082766da16b4a71d777307a25aa5378144946d62d0aba8
-EBUILD GitPython-3.1.3.ebuild 1567 BLAKE2B a1d065baf60b83b194cd0d2e7751546e1540de4d49ecf5f941ea19c5864474ea004897c257c2052b2b2ecd6305a34512537976556695d1f238459456d9599b25 SHA512 be6f9cb0d027fa9424fc88661f34f721ce94d706f45d221539a52a398bbba32c274709bd66eab7ba61182d1b8c1f60bb530104e9666cc1ba2bea7bbe54c8f1b2
-MISC metadata.xml 382 BLAKE2B 9853412552202bb0134ea88f7eae6b36c5c17920cd2834bec4a487cd6e1e6a5421db13a5b5ca7de1bc366ca057c17e2d89f3ea0973023de76a0a0783065d6dc6 SHA512 3f31be6d8a7fc5622f56141778f1779ff092a7e50f6ee162edc7854eb84b896206382edacf678e3f53f513727ca67e3cce0b6b6f50be7cbc93533201533ebe85
+DIST GitPython-3.1.7.gitbundle 8821099 BLAKE2B 96b6cb8cce9778099001d9c3066b9d3b7f4c3c4b4283e521f7b41e93cf5f3990a8758853c261e3458cd6a8c8c48661526e1dd2ce2208e02d3ee895358a135b4a SHA512 c311a464e79c769be92b08a216d52487a47af6c8807e880b6c2225d04eb7cd772808a6675660a2e727ce3ddf47746203646fb96f9a947d4ae2ad4b916f8dc984
+DIST GitPython-3.1.7.tar.gz 169134 BLAKE2B aba0464b18bfbcfd5e219c6483a1af70cb89da45d26e41e18a26b661985d2ab414e72b60a5366a9dd1ff0603876907a7fd642bc49bae01973ef6c8ba7906ec31 SHA512 7c434312be303288b58fabea4d6a84bf417dfff60d61695384af594e5f1231efc8d79d250aa63e04263b4c9aa4f19efceb98c5eea1a466fb0b433113ddb4af46
+DIST gitdb-4.0.5.gitbundle 1497722 BLAKE2B 8ee85368db7f408f96f0b48250f1ed96c8df28b0439d355ce2eecbdcc5dc94382883510c57142e7e4b6ba7cd8e82b1140eca538b45692dbe8c55bce32e1b5b4f SHA512 2c55a8e402a61ebcc362a8aee4a6154705d8ff2f5e582d13c855562dd074427681f4147641fe76681b76c99ec46040c7577dfca8bbfd575fc52772a9a6f17326
+DIST smmap-3.0.4.gitbundle 276552 BLAKE2B 2d17b927b2c644d2f1984168ee99fe5a9a58392401ac0b2894a1d5e5f9c292f32311a7a5d7669bd93c642ff791f4801d61ef3236c1dafa1434e99a17fd8751f6 SHA512 6deb282c6ece3b556c59c458b5242ff362b903441db63c005a0ab1ac055b3f974f9b34f30e0a4a41ef9246696e08b191254f72db61a8f24d4eb2f0e48a08937b
+EBUILD GitPython-3.1.7.ebuild 1591 BLAKE2B b28668afcd02953756d822212888cd7d05f3e27ab6407b9d963aa9a877852db082fd82d72b66be85bd25b1fd8ddac02fe65dae43f892ab0ed8164930f947668a SHA512 2ddca8c8fe89ff8c7a2402c9a81883d61af089ea92c554149fe08bb89467da87ba869d31cd64fb6942fd202d61e4c2307d8de7b4640e18369b50244365185401
+MISC metadata.xml 406 BLAKE2B ae639878f2162f9c2e313d10ba8122ede602251b28c0e82f36f73c92822d2626601bc6ce575cbd4bd5087acaea1a048079901ef67d787849c2061c68b2ad77a9 SHA512 2942febc2c1edbd075b64bdb5b6cffc2ecfa07231e8d210de4dbbaef3dd64a4df876dfddd8f1227ff2b1b9264d8746d951dc9e08db64bebddf0b0e1dea2a641a
diff --git a/dev-python/GitPython/metadata.xml b/dev-python/GitPython/metadata.xml
index 7e626312fece..1e0c7269c568 100644
--- a/dev-python/GitPython/metadata.xml
+++ b/dev-python/GitPython/metadata.xml
@@ -5,6 +5,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">GitPython</remote-id>
<remote-id type="github">gitpython-developers/GitPython</remote-id>