summaryrefslogtreecommitdiff
path: root/dev-python/GitPython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-python/GitPython
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-python/GitPython')
-rw-r--r--dev-python/GitPython/GitPython-3.1.13.ebuild59
-rw-r--r--dev-python/GitPython/Manifest4
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.13.ebuild b/dev-python/GitPython/GitPython-3.1.13.ebuild
new file mode 100644
index 000000000000..29261d5b7df4
--- /dev/null
+++ b/dev-python/GitPython/GitPython-3.1.13.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+TEST_P=GitPython-${PV}
+GITDB_P=gitdb-4.0.5-r1
+SMMAP_P=smmap-3.0.4
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
+ )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+src_test() {
+ git config --global user.email "travis@ci.com" || die
+ git config --global user.name "Travis Runner" || die
+
+ git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
+ git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb || die
+ git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
+
+ cd "${T}"/test || die
+ TRAVIS=1 ./init-tests-after-clone.sh || die
+ cat test/fixtures/.gitconfig >> ~/.gitconfig || die
+ rm -r test/performance || die
+ # tests requiring network access
+ sed -i -e 's:test_fetch_error:_&:' test/test_remote.py || die
+ rm test/test_installation.py || die
+ # broken with git 2.30+
+ sed -i -e 's:test_index_file_diffing:_&:' test/test_index.py || die
+
+ distutils-r1_src_test
+}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index 04a072c4a089..9358f9d4b704 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -2,8 +2,12 @@ DIST GitPython-3.1.11.gitbundle 4421698 BLAKE2B 96a4be2b12149c34f0e81580cb890692
DIST GitPython-3.1.11.tar.gz 170908 BLAKE2B b327f38bbe9d92caf8b5ba6f3c1e353ad00bad2c3e7b3ae59991eaee5a5dd9f228fd80b86fd7e908fa71563e369d7340070ddc0e093549bfc8378cdf20ba9723 SHA512 fe4baf9c8b3668f29fbc476ec2ba0a8d58a50ffe596b9f3037ddb4cb5c0c7faf0d34c6efac7567074f1b28b866e42dad19c91a5381eef606d3b3ff74b77649de
DIST GitPython-3.1.12.gitbundle 8721154 BLAKE2B d00ba18e53797ebc2067de8422506db0fafc27860cd3f99a36ad4740956518cfcab98d8211d595e1347c22df3d0ac13557881f471829c429db1527099f53438e SHA512 c84c76668bbc593998cf834d18d0207ae282cf0fd6fd22e5491435884855bb2b6699b61e51b35e6bbcfc4cd2f3c15aa9b435115fe5b0957ab4c63c7aa640ed6b
DIST GitPython-3.1.12.tar.gz 171126 BLAKE2B e74a613f5269893f29f41add6f39c34497613b728b14c4c65c5fcbd52bee52a2ef53c4db3bc63f843ce4ec1e63f3988029852e9195677db32b704d0429480130 SHA512 4a2915991831fcf0dc0326d9e9be0f06fba1e93560d07c19fad5cbcb9ff04262e7d2225c5174a8c2f55e4c44b1c027bec4ff61d7dc137d8bf110ab96026742cc
+DIST GitPython-3.1.13.gitbundle 4434559 BLAKE2B d8a2478d40f908d7913d08a3a5e98bea3a50366659838a8d3ec335ce7864e7ddbe290de0581b7c4315c83f1cd9ed517af06a7b9232378ee299090accde0b595e SHA512 6d62488a3c9ff66b4f25dd3f1419835591379736ca3faf57055121a8ccb5b8da933e3b37836a6da59de29cb62b03ebef6c38d7387c86dc95da2206024c58f289
+DIST GitPython-3.1.13.tar.gz 171249 BLAKE2B ec653a40654e42d93ba552e1b0a40c5241cd7f86a110f1a0570d6a3ca35cb7522955650a171a8a4113248e508f84a4f5cd021edf941fb41057aec01ef6f30194 SHA512 9618be674e592e3653eb8f59e5878f72b3583d2052184f6321d24130e4cdd16236c9ee4823ee38036c2361685d78ab7ed79660746506a8f98285ab776e1c98b0
+DIST gitdb-4.0.5-r1.gitbundle 1499071 BLAKE2B e429014def18d645b7117b27f592ead9c518076eeee2f6cc42c4a231f9a4f61c8275ccb1def5d042d44f34863528570163e9e154bb1536a0917b10f135e2462c SHA512 6fcf345af9f72afa39f4ba931bf474b2596678f1b790e3d4e1e3f7420baafbad04689bcdee9e99407f7c2b1c6f0d36fcf524b408ceb37b95dc4980e9423b1ad7
DIST gitdb-4.0.5.gitbundle 1497722 BLAKE2B 8ee85368db7f408f96f0b48250f1ed96c8df28b0439d355ce2eecbdcc5dc94382883510c57142e7e4b6ba7cd8e82b1140eca538b45692dbe8c55bce32e1b5b4f SHA512 2c55a8e402a61ebcc362a8aee4a6154705d8ff2f5e582d13c855562dd074427681f4147641fe76681b76c99ec46040c7577dfca8bbfd575fc52772a9a6f17326
DIST smmap-3.0.4.gitbundle 276552 BLAKE2B 2d17b927b2c644d2f1984168ee99fe5a9a58392401ac0b2894a1d5e5f9c292f32311a7a5d7669bd93c642ff791f4801d61ef3236c1dafa1434e99a17fd8751f6 SHA512 6deb282c6ece3b556c59c458b5242ff362b903441db63c005a0ab1ac055b3f974f9b34f30e0a4a41ef9246696e08b191254f72db61a8f24d4eb2f0e48a08937b
EBUILD GitPython-3.1.11.ebuild 1591 BLAKE2B e6f92dc504aab3c0dd9fbd04b7d47d233dff59cbca6f8189f899d6c3c9ecfbc715e5584a417a82132f9f103c974cccc226a437eae1ecbec49e749007d79babf7 SHA512 dcf70c3db925e29177cdf0f6bf45766fe0a2e4765cf197cf2f875b5f7c557f0eb79677136cd8d067372bec47e0fb7c2364dcaf02edfdecd5f986c97b42158030
EBUILD GitPython-3.1.12.ebuild 1683 BLAKE2B a7ed728bf5e20b0f02ce2c1e5924b09e85bc5292c90cbc28b95dace511202287a2dc96c1e0c0a79120171ad921161e4795176b0cc03943acda735bcd203c8485 SHA512 57e550000fcb7c22895766e9d0944d1c5396572a9794683691cce2a51f3e3f336f5293141cd88bf78186ae16b4cc8b4b8ba08f74c2bb2832c61d72c96b1387b5
+EBUILD GitPython-3.1.13.ebuild 1686 BLAKE2B 657bb1aee42e191d181ff7e875d9b76790e819de8b61bfe4bb267e6ae0aba7c8d0eb310f123b7e5da16ba2262167f340877f34f988913b0f2ec2bdeec3440b14 SHA512 802016f7d4cbd9359eadac37e3337499cd4b1f3d40cb190af99c86dfd96aeecf93ec0c60c6ad0b4d67e2e7f1e7faf122d7e356e9b7d079fdf207b1a273287ed2
MISC metadata.xml 406 BLAKE2B ae639878f2162f9c2e313d10ba8122ede602251b28c0e82f36f73c92822d2626601bc6ce575cbd4bd5087acaea1a048079901ef67d787849c2061c68b2ad77a9 SHA512 2942febc2c1edbd075b64bdb5b6cffc2ecfa07231e8d210de4dbbaef3dd64a4df876dfddd8f1227ff2b1b9264d8746d951dc9e08db64bebddf0b0e1dea2a641a