summaryrefslogtreecommitdiff
path: root/dev-python/GitPython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/GitPython
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/GitPython')
-rw-r--r--dev-python/GitPython/GitPython-2.1.11.ebuild37
-rw-r--r--dev-python/GitPython/GitPython-3.1.1.ebuild2
-rw-r--r--dev-python/GitPython/GitPython-3.1.2.ebuild (renamed from dev-python/GitPython/GitPython-3.1.0.ebuild)5
-rw-r--r--dev-python/GitPython/Manifest8
4 files changed, 7 insertions, 45 deletions
diff --git a/dev-python/GitPython/GitPython-2.1.11.ebuild b/dev-python/GitPython/GitPython-2.1.11.ebuild
deleted file mode 100644
index c995e67a79ea..000000000000
--- a/dev-python/GitPython/GitPython-2.1.11.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-MY_PN="GitPython"
-MY_PV="${PV/_rc/.RC}"
-MY_P="${MY_PN}-${MY_PV}"
-
-DESCRIPTION="Library used to interact with Git repositories"
-HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# Tests only work with the GitPython repo
-RESTRICT="test"
-
-RDEPEND="
- dev-vcs/git
- >=dev-python/gitdb2-2.0.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/GitPython/GitPython-3.1.1.ebuild b/dev-python/GitPython/GitPython-3.1.1.ebuild
index 4c35f34de642..828e9672b499 100644
--- a/dev-python/GitPython/GitPython-3.1.1.ebuild
+++ b/dev-python/GitPython/GitPython-3.1.1.ebuild
@@ -23,7 +23,7 @@ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 arm64 x86 ~amd64-linux ~x86-linux"
RDEPEND="
dev-vcs/git
diff --git a/dev-python/GitPython/GitPython-3.1.0.ebuild b/dev-python/GitPython/GitPython-3.1.2.ebuild
index 8d0903d98997..4c35f34de642 100644
--- a/dev-python/GitPython/GitPython-3.1.0.ebuild
+++ b/dev-python/GitPython/GitPython-3.1.2.ebuild
@@ -8,6 +8,7 @@ PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
+TEST_P=GitPython-3.1.0
GITDB_P=gitdb-4.0.2
SMMAP_P=smmap-3.0.1
@@ -15,7 +16,7 @@ DESCRIPTION="Library used to interact with Git repositories"
HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
test? (
- https://dev.gentoo.org/~mgorny/dist/${P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
)"
@@ -38,7 +39,7 @@ src_test() {
git config --global user.email "you@example.com" || die
git config --global user.name "Your Name" || die
- git clone "${DISTDIR}/${P}.gitbundle" "${T}"/test || die
+ git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
"${T}"/test/git/ext/gitdb || die
git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index 11817c217e52..d8f2be879061 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,10 +1,8 @@
-DIST GitPython-2.1.11.tar.gz 428531 BLAKE2B 18b00f1e622c6588c14e1625f944d117348fb77e67161117510f42c8381db8cde8c6e16fa911edabfc4410239622fb845931b247bab4133585d2ec27969fea4c SHA512 5f964ee56c3f27c28f502150216af29b8463b19d9c0f773458dbabf17ba8587ee5c5e3fbcb31ad46c55e202d06bae447fd40007890a1bc116fe0370cdfc6401f
DIST GitPython-3.1.0.gitbundle 8618276 BLAKE2B a1ecf49c47804b399453c6931fb54903309944b47a5a8ccd02d62f4b27943e60b4b58a9e67567008fa4d5bc791b1c86642659c045c885e2155e2c44bb1a4ea81 SHA512 a71463f861f840d3169a8351155665243d9f0f0a72e210940f9f7872cfd49b6ddfac827f0ec5bc61079d8066fc7ba210a03dd99f3bbd598e22ccbcacfe8e61b3
-DIST GitPython-3.1.0.tar.gz 430079 BLAKE2B eaf4d4bb2f589a96bcdcf28e7ac6c0b8eab691a1dee5fbbec6d4a93bab9f123b07073af8a1b85aa5547057e46e6c8c004215167790b559f3848bf20c3ec1697f SHA512 6dab8449cc1736d7f58f9788b56bf63cc2bf0f420104d6e010a9624d21f53f5b5d33135bad4d91b40d9543b454be839f8003828ffe512c35a6513c27a2dd4b53
DIST GitPython-3.1.1.tar.gz 430310 BLAKE2B f6402c4f8d72f4352bf97b72ac0c39b347683c411dcb7b74405119773954a185fe7dc11e13232d56f4a9f938e64b865f42cbd3a857427d985e29f024eb4e0880 SHA512 a913fb611479456d4b804c56039ed8d8ac8cb183f58c874e265141f2b5b46befd4a8a2f5d94ac1cf8ea7fc99e901568a9fc054d50df0ac242d7d184add8ca1b3
+DIST GitPython-3.1.2.tar.gz 430474 BLAKE2B bda0fc9d591dd3b64158e318386349c18ed0775f462c487726faed7ce10781296103133b64cdbfd56947e38621790b177b6c9869596dc8a523a17b00690fe5e4 SHA512 051b59b56a163839bf7754860bfc8e21cfde08b8e7d0fd66239c234b89ba5a83fa7e8540a12c5df3563e5353d1e01119dd1b0a5ea1c22daf7e071fb963cbc3a4
DIST gitdb-4.0.2.gitbundle 1474197 BLAKE2B 93dc8aeb3a43f0950bec1e8dc0c0156543a0a1ce1f20a7f0b2cd05c110338af05b6c6300c3f4b2c05e0f895496248e5fdca74eb599a4ea9aa983ed399d91f7c6 SHA512 8d4ebc93d6869a60b7717fc090000067e86a7e0373c281d0fb9939a6e2e283864256f827919eeb13be977254c0c71a4864d8e7c9b4b6dcc0af6275aa59681960
DIST smmap-3.0.1.gitbundle 263781 BLAKE2B 6e06586010814ce0f59367c7f9289dad4891ee1debbc020b192af3945207da05b1e34907f1871f5b6b9638706b9e2fdacf390fcfff6bd06af84b9fd80f7e63a8 SHA512 c2b6c0b295c2997ed53727d3d1458ae7ec5ddbde9c83349286904726865fc026a70161955498b1a06371fb8d937e7386b80b4ea0c2e5d1c647718e6dbea93104
-EBUILD GitPython-2.1.11.ebuild 873 BLAKE2B d9ae7f3f9cada4731bb07ac4d2cf0770dafeed0645264975250f388304b240c487ff7d627726e263b54fcddfafdbbb768d863f7dbb459d8c637bb4393b6e730a SHA512 203cea364596aeb9492b58b576d33edfe460b03f91fa394acdf9532458ae28ace2492432075157b0f26be5bd03fcaedda05f839dde52c47098bc7b7ae4e2e88f
-EBUILD GitPython-3.1.0.ebuild 1535 BLAKE2B 28d5074ed17d3e54c6df663ef73d57a7fb700fc6e7cfac481ef0281333e6341c9c6de7501b91330bb26b1c6e13a6f5cb9ce4461f6c96e3bd8327a5c0ca79d1df SHA512 e4ea4cdb8811b0f4235edeb38916fc4df085e1489555b164c3f8daaa97a1c34f252ff66b3f4e7f7eb175a17184e4b1c258242dd7f96dd81eae729b1f56c6caeb
-EBUILD GitPython-3.1.1.ebuild 1568 BLAKE2B 5bd129321bc6012432a32586c2c6c13dc96821bc7cb6f322cf7cb03763c06d746d4907e628c9376fcb154d2c45f52a6dd40d61f08372f91d778a8ccbba1ce331 SHA512 4688e66c53578accc218eaa25f4aa2fcbffc4c24782a5dd2a23067e6c60f9bdfb008771aee62f8dd98082766da16b4a71d777307a25aa5378144946d62d0aba8
+EBUILD GitPython-3.1.1.ebuild 1565 BLAKE2B 188eee0c7d2caafe5aa17989fa5bec5f903b42ec644805b69b03fedb82325aaa3a47987062d685e5b427775505b6320b974cc594cff1ceb5878468914796cf9b SHA512 5153569d57e66bd7698de8e7adc3fcfa8ecbf79ab929364bd16a368afdb01390d79195f1880b17e9e9e2e67b22aa4713e812eeea4c65e00c19cca329fde47723
+EBUILD GitPython-3.1.2.ebuild 1568 BLAKE2B 5bd129321bc6012432a32586c2c6c13dc96821bc7cb6f322cf7cb03763c06d746d4907e628c9376fcb154d2c45f52a6dd40d61f08372f91d778a8ccbba1ce331 SHA512 4688e66c53578accc218eaa25f4aa2fcbffc4c24782a5dd2a23067e6c60f9bdfb008771aee62f8dd98082766da16b4a71d777307a25aa5378144946d62d0aba8
MISC metadata.xml 382 BLAKE2B 9853412552202bb0134ea88f7eae6b36c5c17920cd2834bec4a487cd6e1e6a5421db13a5b5ca7de1bc366ca057c17e2d89f3ea0973023de76a0a0783065d6dc6 SHA512 3f31be6d8a7fc5622f56141778f1779ff092a7e50f6ee162edc7854eb84b896206382edacf678e3f53f513727ca67e3cce0b6b6f50be7cbc93533201533ebe85