summaryrefslogtreecommitdiff
path: root/dev-python/GridDataFormats
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/GridDataFormats
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/GridDataFormats')
-rw-r--r--dev-python/GridDataFormats/GridDataFormats-0.4.0.ebuild22
-rw-r--r--dev-python/GridDataFormats/Manifest3
-rw-r--r--dev-python/GridDataFormats/metadata.xml12
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/GridDataFormats/GridDataFormats-0.4.0.ebuild b/dev-python/GridDataFormats/GridDataFormats-0.4.0.ebuild
new file mode 100644
index 000000000000..df56899b8a3e
--- /dev/null
+++ b/dev-python/GridDataFormats/GridDataFormats-0.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Reading and writing of data on regular grids in Python"
+HOMEPAGE="https://pypi.org/project/GridDataFormats/ https://github.com/MDAnalysis/GridDataFormats"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/numpy-1.0.3[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]"
diff --git a/dev-python/GridDataFormats/Manifest b/dev-python/GridDataFormats/Manifest
new file mode 100644
index 000000000000..21815a565755
--- /dev/null
+++ b/dev-python/GridDataFormats/Manifest
@@ -0,0 +1,3 @@
+DIST GridDataFormats-0.4.0.tar.gz 63643 BLAKE2B cbc0bc259c30c9eccf61b11a7ed6e8004979fe2adb2b049f137caddbb71190291011664462c2c1aa4fe2baf822102d59d3079e9e48620b76d37a4812ca150328 SHA512 b480293e2dd17cb484336aa1469a8f0e739fbe7d925190f6a6502e96d0ab26a36271b0a0676c711716abd3e025e86fbec961cf965e950f89be167e0a83ef904c
+EBUILD GridDataFormats-0.4.0.ebuild 617 BLAKE2B c991324f33c73c27ba3fa4e353b4f4989d2c695e448f18b17d8a7f2d437affdbf99ca4e82363c0a846cef94bb47c1c87746233d8e53935a19ca481cba93a6271 SHA512 f759b99915137b863540f3ffbbb544d6f36a1342aa1500a14516f0ee071d52aba0715941d4cd0f91143cc545ea7484b0d04c444a0998f20ee57896f0882fa340
+MISC metadata.xml 409 BLAKE2B db4d61405b860e8c4f2623bfc4368602daf282d4f9ea847d93c61e471b92c05d394ff537219ae9303f9c6b96c7e1ed1ffbfedd89c04f4c8894f600efbded9c2e SHA512 df3e3ac019c5e6c7f40fc2ff42f22d43c2b70c1a4af159e3c05fe828148cbb2d0d48223201a7a35526a5fdb9bb289bb851d61479dfa6d1bd56f0ff830b35ec6d
diff --git a/dev-python/GridDataFormats/metadata.xml b/dev-python/GridDataFormats/metadata.xml
new file mode 100644
index 000000000000..cc867877923b
--- /dev/null
+++ b/dev-python/GridDataFormats/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">GridDataFormats</remote-id>
+ <remote-id type="github">MDAnalysis/GridDataFormats</remote-id>
+ </upstream>
+</pkgmetadata>