summaryrefslogtreecommitdiff
path: root/dev-python/HeapDict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/HeapDict
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/HeapDict')
-rw-r--r--dev-python/HeapDict/HeapDict-1.0.0.ebuild20
-rw-r--r--dev-python/HeapDict/Manifest3
-rw-r--r--dev-python/HeapDict/metadata.xml15
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/HeapDict/HeapDict-1.0.0.ebuild b/dev-python/HeapDict/HeapDict-1.0.0.ebuild
new file mode 100644
index 000000000000..bcc1e17ee916
--- /dev/null
+++ b/dev-python/HeapDict/HeapDict-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Heap with decrease-key and increase-key operations"
+HOMEPAGE="http://stutzbachenterprises.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/HeapDict/Manifest b/dev-python/HeapDict/Manifest
new file mode 100644
index 000000000000..646c5626eff4
--- /dev/null
+++ b/dev-python/HeapDict/Manifest
@@ -0,0 +1,3 @@
+DIST HeapDict-1.0.0.tar.gz 7713 SHA256 40c9e3680616cfdf942f77429a3a9e0a76f31ce965d62f4ffbe63a83a5ef1b5a SHA512 1210acd3a6f3e091132d8b87963ec46c81d3141e1788c2a127fe348a9052d73225036aeabffc6a2089c7811b8571a43477055b746df6b128a645123862076bb5 WHIRLPOOL ad5ea24622e8a78688ee6a7e4e0bca188fbccf477d521fc42b223319ca610fd7c255c0ad817e31e0c0ef429645e71bc650089bd16e45698a4df1d16b97613927
+EBUILD HeapDict-1.0.0.ebuild 484 SHA256 870652ad01ef35ebf3f8e0f6c39d876d988991244e247e1270c52a0d88f91b87 SHA512 e9d18962b815e64e9603b68c02b58077b3095583c645be7dbbd678e6a7b3bed2bf8643b963555adb0e01c35634ee980fb4b0c3930e36af1e3c657d43436f1381 WHIRLPOOL b0b698ce2b05c5a575feebfa6f9e6771232b2359d714b78592d0bf31dda17c6f3e65e5809a3c909c10dd6ddcbbc29b4d7485c5143e91c4ebd7fe7a68a18fdc79
+MISC metadata.xml 522 SHA256 1f5161966b6e74d5dcc4285864c8291ccfbc2c958619ca9a4a68a459d56ac9b6 SHA512 aca6d43cfb9d6eee3f47079bc26874f12e95f8efbdd4bdcf2685b65374b5a6500de2f12d065bdbce12b82496b931c3c00ff9ffb7aa1e040c11ea033e12304be8 WHIRLPOOL 1b8720370884ca89fea200d4803be47435f9a4c84975b14ed7ae852334c4b42f54c875fc8ba38f9511c902855969ef7ac07e3271cc9bc39d507aedf60b677372
diff --git a/dev-python/HeapDict/metadata.xml b/dev-python/HeapDict/metadata.xml
new file mode 100644
index 000000000000..a59ab0464cae
--- /dev/null
+++ b/dev-python/HeapDict/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ heapdict implements the MutableMapping ABC, meaning it works pretty much like a regular Python dict.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">HeapDict</remote-id>
+ <remote-id type="github">dask/zict</remote-id>
+ </upstream>
+</pkgmetadata>