summaryrefslogtreecommitdiff
path: root/dev-python/IPy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/IPy
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/IPy')
-rw-r--r--dev-python/IPy/IPy-1.01-r1.ebuild36
-rw-r--r--dev-python/IPy/Manifest3
-rw-r--r--dev-python/IPy/metadata.xml13
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/IPy/IPy-1.01-r1.ebuild b/dev-python/IPy/IPy-1.01-r1.ebuild
new file mode 100644
index 000000000000..3e7455c57296
--- /dev/null
+++ b/dev-python/IPy/IPy-1.01-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
+HOMEPAGE="
+ https://github.com/autocracy/python-ipy/
+ https://pypi.org/project/IPy/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc x86"
+IUSE="examples"
+
+python_test() {
+ "${EPYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
+ "${EPYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/IPy/Manifest b/dev-python/IPy/Manifest
new file mode 100644
index 000000000000..47be4e617961
--- /dev/null
+++ b/dev-python/IPy/Manifest
@@ -0,0 +1,3 @@
+DIST IPy-1.01.tar.gz 33641 BLAKE2B 10d5ac5c3df00a562393ee762e9ad0f458ecf4745f894ab23e686b7112842adcbb3f25064c0010630745273fa72280ba5ef92a951d687d0f46f341acd6c041ad SHA512 f0983254523025a1819d543877d9651fb6a9e39dabd3b043488495f681b02e43b544a0121658a0430a418a1c39b360a59db1699af87a75a16a2bdc29fcb2b74c
+EBUILD IPy-1.01-r1.ebuild 844 BLAKE2B 7bdd370dbfdae3853f79396b43a376610bc3a71b5dba967adfe61c65ebff74d577835c48a486ccfb1be30886cf39df23c8c7c6b22cc903ee14ec1aa3fa31a8cb SHA512 a4f724872467cc3a2044519f82dbf91006e4c330a8ac2a7a8bce032f7d20dcb8e485c985cbdf40e9d0c3bf97d8155ff8452d0c42e841170f0be8cd0b1e8ce48f
+MISC metadata.xml 404 BLAKE2B 9b453bad2b9cc6b6f7b6bca5bd69afbc1c8181f8250d5889b8a192f6a242e94b546b650d0ca05acd7668cee160642d519d2eaa3f3d8755ffa228b43efbd3a6a0 SHA512 fb2d4c33ea00c87f1106ebf2ea4150476c62acd544f9c94cf28d5113cd272179df4710595135f5edd26cded036977fb7253e77c83d34ae362bd4b35eebbe356c
diff --git a/dev-python/IPy/metadata.xml b/dev-python/IPy/metadata.xml
new file mode 100644
index 000000000000..29540e39f370
--- /dev/null
+++ b/dev-python/IPy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">IPy</remote-id>
+ <remote-id type="github">autocracy/python-ipy</remote-id>
+ </upstream>
+</pkgmetadata>