summaryrefslogtreecommitdiff
path: root/dev-python/Levenshtein/Levenshtein-0.20.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-18 23:20:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-18 23:20:40 +0100
commitf39c6dab71f5188f95650d367ece1df4f263e474 (patch)
tree9c30c203b3f09174814c41e6a63aa3522c7b7610 /dev-python/Levenshtein/Levenshtein-0.20.3.ebuild
parent1b295861f983d29f9bd5d5906c7ca3cee4cf1f9a (diff)
gentoo auto-resync : 18:09:2022 - 23:20:40
Diffstat (limited to 'dev-python/Levenshtein/Levenshtein-0.20.3.ebuild')
-rw-r--r--dev-python/Levenshtein/Levenshtein-0.20.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/Levenshtein/Levenshtein-0.20.3.ebuild b/dev-python/Levenshtein/Levenshtein-0.20.3.ebuild
new file mode 100644
index 000000000000..3b7310807ac8
--- /dev/null
+++ b/dev-python/Levenshtein/Levenshtein-0.20.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Functions for fast computation of Levenshtein distance, and edit operations"
+HOMEPAGE="
+ https://pypi.org/project/Levenshtein/
+ https://github.com/maxbachmann/Levenshtein/
+"
+SRC_URI="
+ https://github.com/maxbachmann/Levenshtein/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-cpp/rapidfuzz-cpp-1.0.4
+"
+RDEPEND="
+ <dev-python/rapidfuzz-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.13.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest