summaryrefslogtreecommitdiff
path: root/dev-python/Levenshtein/Levenshtein-0.20.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-30 09:03:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-30 09:03:01 +0000
commita41f630aea0b4b71a6c9a088571f1eaaf8413d53 (patch)
tree2434c552b001d6b577a10a50bea2dd828676f27d /dev-python/Levenshtein/Levenshtein-0.20.6.ebuild
parentb77e1a6cc7c668e135d139c5ec5ad0ae1c11b857 (diff)
gentoo auto-resync : 30:10:2022 - 09:03:01
Diffstat (limited to 'dev-python/Levenshtein/Levenshtein-0.20.6.ebuild')
-rw-r--r--dev-python/Levenshtein/Levenshtein-0.20.6.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/Levenshtein/Levenshtein-0.20.6.ebuild b/dev-python/Levenshtein/Levenshtein-0.20.6.ebuild
deleted file mode 100644
index 8887977b011f..000000000000
--- a/dev-python/Levenshtein/Levenshtein-0.20.6.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# custom wrapper over setuptools
-DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Functions for fast computation of Levenshtein distance, and edit operations"
-HOMEPAGE="
- https://pypi.org/project/Levenshtein/
- https://github.com/maxbachmann/Levenshtein/
-"
-SRC_URI="
- https://github.com/maxbachmann/Levenshtein/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-DEPEND="
- >=dev-cpp/rapidfuzz-cpp-1.7.0
-"
-RDEPEND="
- <dev-python/rapidfuzz-3.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- >=dev-python/scikit-build-0.13.0[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # sterilize build flags
- sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
-
- distutils-r1_src_prepare
-}