summaryrefslogtreecommitdiff
path: root/dev-python/Nuitka
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-11 22:34:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-11 22:34:01 +0000
commit55d85b00f95c52ff327d35d9cc5bf240ab37f11f (patch)
tree20c24154d7233e2953d7f71952d15d62f6761e55 /dev-python/Nuitka
parent9990da9e2db6d5094701a2f4035e781826eff014 (diff)
gentoo auto-resync : 11:11:2023 - 22:34:00
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest2
-rw-r--r--dev-python/Nuitka/Nuitka-1.8.6.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 26bd73c64c03..54eee07079c7 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,5 +1,7 @@
DIST Nuitka-1.8.4.tar.gz 3604833 BLAKE2B 32a5169e981e1323e0cc30147bbd6327521f496d3a4bcd0e6d3e811b291c596c50a3cf7602221f24b7a6d82936286bab1a045e65abfa4ddb9f366e23edaad9a2 SHA512 632453e937ca6c895646910ca650d83f9610e0aa4a28d2b2fe608c1bf4138ea06496c2bd2fee24fb4e6224a844437242ff9d21af2221ad2eed2edc77262050c2
DIST Nuitka-1.8.5.tar.gz 3604649 BLAKE2B 146e4f5fafb37fee7c7824fe448db85d3d77d57cadad63c10f237cba969ad81cc7c73eecbf68fcbfb8a1b2e0d8a9439c2435c5c7db16dde04324c3dd0ddb1770 SHA512 660f1480835491473cb4c512ce14109a9d27887e64fdfdfe6c92a59cf59445e7d6068c7859af9942330345b918fe81593c52f8f3b6166d55bad8bbbf362cc05c
+DIST Nuitka-1.8.6.tar.gz 3605120 BLAKE2B 5bf40eb8e62f0bd656f94f1c251b8de222d07808c6cbd0be3913b4f10f514c106b0db171a8122d6aaa163376eab9cc835d42a693519e06bb607f06b257a3fe5a SHA512 4cb1737bf95286b69f032ac49b4b2f0b15f068ea7cc22f737388257fe5c400bb3c47561144152a7c8e48426d10579912e5350f7ca7079d73a5a04bfe379ca9d3
EBUILD Nuitka-1.8.4.ebuild 1115 BLAKE2B 71600bcba8ba9422125dc6e145f919853e241a089aa855beb488ccb72bd3d5490ad4b986e1616dc4ac099023d88ee1fcbaf7efd5a84ad1f74ce17672efc7fff7 SHA512 28485d128e06c298f4aa512cf455dd38fe6dc34dce424246bb8bc69d531274158e377631b96c82cccea29a03492721a2bb71791ad2bbb4765475972347ea18ab
EBUILD Nuitka-1.8.5.ebuild 1115 BLAKE2B 71600bcba8ba9422125dc6e145f919853e241a089aa855beb488ccb72bd3d5490ad4b986e1616dc4ac099023d88ee1fcbaf7efd5a84ad1f74ce17672efc7fff7 SHA512 28485d128e06c298f4aa512cf455dd38fe6dc34dce424246bb8bc69d531274158e377631b96c82cccea29a03492721a2bb71791ad2bbb4765475972347ea18ab
+EBUILD Nuitka-1.8.6.ebuild 1115 BLAKE2B 71600bcba8ba9422125dc6e145f919853e241a089aa855beb488ccb72bd3d5490ad4b986e1616dc4ac099023d88ee1fcbaf7efd5a84ad1f74ce17672efc7fff7 SHA512 28485d128e06c298f4aa512cf455dd38fe6dc34dce424246bb8bc69d531274158e377631b96c82cccea29a03492721a2bb71791ad2bbb4765475972347ea18ab
MISC metadata.xml 943 BLAKE2B d7ab883773e7480dcfb4b79932a3874e2274669169a24a54aa622a2a0ac079e0296da4bd196d166cb11fcff785985da0b10d0fae351032914ccf312c9bb9833c SHA512 625d8760b8e849c6e014856f584cb42f50bb5ebb1fa648cb704a5a1baf175e7d2ce9f43f6f724d11c81a68e364b6ac1c38459540b58f2ccd6a675902af5b1cc9
diff --git a/dev-python/Nuitka/Nuitka-1.8.6.ebuild b/dev-python/Nuitka/Nuitka-1.8.6.ebuild
new file mode 100644
index 000000000000..f511685d5ce1
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.8.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}