summaryrefslogtreecommitdiff
path: root/dev-python/PyQt-builder/PyQt-builder-1.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-11 11:38:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-11 11:38:54 +0100
commit9d8d34d0eedfd7319f905092519980bf1b4ce3e5 (patch)
tree75f96ca3abc9e54aeb3960716b735719c2447b6a /dev-python/PyQt-builder/PyQt-builder-1.15.0.ebuild
parentd6260e76da0a436affc6839e470dd8619841cadc (diff)
gentoo auto-resync : 11:04:2023 - 11:38:54
Diffstat (limited to 'dev-python/PyQt-builder/PyQt-builder-1.15.0.ebuild')
-rw-r--r--dev-python/PyQt-builder/PyQt-builder-1.15.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/PyQt-builder/PyQt-builder-1.15.0.ebuild b/dev-python/PyQt-builder/PyQt-builder-1.15.0.ebuild
new file mode 100644
index 000000000000..260560a447aa
--- /dev/null
+++ b/dev-python/PyQt-builder/PyQt-builder-1.15.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="The PEP 517 compliant PyQt build system"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt-builder/ https://pypi.org/project/PyQt-builder/"
+
+if [[ ${PV} == *_pre* ]]; then
+ MY_P=${PN}-${PV/_pre/.dev}
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+ S=${WORKDIR}/${MY_P}
+fi
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/sip-6.7.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc --no-autodoc
+
+python_prepare_all() {
+ # don't install prebuilt Windows DLLs
+ sed -i -e "s:'dlls/\*/\*',::" setup.py || die
+ rm -r "${PN/-/_}.egg-info" || die
+
+ distutils-r1_python_prepare_all
+}