summaryrefslogtreecommitdiff
path: root/dev-python/PyQt5-sip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
commit482a48c0e1675b1e92663b8b5222bb7261aa7956 (patch)
treeb81e02db1810214fc690a762e3a9c687d0f0c5ab /dev-python/PyQt5-sip
parent37bccfe5e76c5740c4ef5ba1179e9488d8404075 (diff)
gentoo auto-resync : 13:07:2024 - 12:26:41
Diffstat (limited to 'dev-python/PyQt5-sip')
-rw-r--r--dev-python/PyQt5-sip/Manifest4
-rw-r--r--dev-python/PyQt5-sip/PyQt5-sip-12.15.0.ebuild21
-rw-r--r--dev-python/PyQt5-sip/metadata.xml8
3 files changed, 25 insertions, 8 deletions
diff --git a/dev-python/PyQt5-sip/Manifest b/dev-python/PyQt5-sip/Manifest
index 578181f599d3..dbc488e76b83 100644
--- a/dev-python/PyQt5-sip/Manifest
+++ b/dev-python/PyQt5-sip/Manifest
@@ -1,4 +1,6 @@
AUX PyQt5-sip-12.13.0-c99.patch 522 BLAKE2B 72f6d0a501fcc7f43cb11291833b7714ba2acc35813c4762a95ec2ce5b95ba955cfa7f5501e38e24f348b73e835487e151082c205c4d434044362b80d2a0f44a SHA512 768c88fab736a57f55e4adb4843b918f84ecf0e976246abbf83a9b45d69a1e6729e738eb4cbac3553ae76a36ace64abf798e073f8ec88fdb3065583a38801773
DIST PyQt5_sip-12.13.0.tar.gz 123225 BLAKE2B e3b7233e5405f7b24de157e1f0ed0f2ff47a9c331a76672892d8a7adc8aba8c7b738354d9f1c2fe9c29501b5bfe8c6302307c6731273b980a04dd327048a3a94 SHA512 ef363b21899f6d089fbc6d5adf700dc6c8838501343070ed1cf0826e05dd860343eba608d5aee5d8bece39b8ddca1f37866bb56aa07db18384ac0a372ca3532f
+DIST PyQt5_sip-12.15.0.tar.gz 104024 BLAKE2B 40fdf25bfb8ca321f50926d7041e33edee9fbebafaded50d283ea95b04ea050e368d2b8470110d758f68f3ac08ada68b65b2f6ebcb9d7dd43707636e26701854 SHA512 1a009b53e80fc8231478f741839d8a88ab26f531c4ab0d41ccc00c8b0650c13c95c3c89cc949858a99bd1d817d736507df519384dff029530edc554f4b35b4cc
EBUILD PyQt5-sip-12.13.0-r1.ebuild 600 BLAKE2B 65a3f0410c9b3ad2618dfe040f7e8fad0186e07851ddc07c93d1c9f2a6b75529ff21928d081989d17c9e0f638513bec412f6fe599b1f242526f59a69ce18559e SHA512 3522c3d06753a9ef521fd531363f8cfcc13ca74ea549e535cf00dbf10757b0554d3bc74f2d2241260a33c3a652f6e99dde39e7aa8b096113d2f528257cc68e14
-MISC metadata.xml 649 BLAKE2B 0a6faee65b39f122f65965490284b17856ba6d86537f3f3780f8604366739c346b01e29e933a91c7edb5ff898e5d51a10e4bf288228d1943a1c9e9970eac4c86 SHA512 3af9be87db6da5cb071f4025cd6fc1964a4b0629ebe93239f6c5a3734d4ef8ef06e652abbac5c9bd86f882a6235bf3b1f0fec6f0035c77ea42571e47c6045e29
+EBUILD PyQt5-sip-12.15.0.ebuild 637 BLAKE2B fe20f2690cfdd8096008641cf8376815238f7e936991c1f47bb0dd486ace13162f3d017910632b059a6647b91c549ea10c9cf010b3244a10ad0786332a536465 SHA512 ae92d71520ad53db6497e83e63d4b73545d83071faeab78c5d8c4151a4e01b117661634f8d1255b895d3a216f04092e25ca44dca6870983f33bb0ea907d93b29
+MISC metadata.xml 382 BLAKE2B 1924bdd8d05a7a04546d994004f1902edf06ca681fc557a47841e41e529cad483f2d6729b1be2b48d906dc94162eeed19f7749a4e431a3d95050d5ac08246fe7 SHA512 2296c770ba9ba38cebbd37474a6ed8bbd6221c6848555242529ee5cee1b3fff928bf9a6fc8e5ed4859af72f030588f1ef493a0edb54955968ac3f514b3cd9ec5
diff --git a/dev-python/PyQt5-sip/PyQt5-sip-12.15.0.ebuild b/dev-python/PyQt5-sip/PyQt5-sip-12.15.0.ebuild
new file mode 100644
index 000000000000..a85f804144fa
--- /dev/null
+++ b/dev-python/PyQt5-sip/PyQt5-sip-12.15.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/_}
+# keep compat in sync with PyQt5 or else it confuses some revdeps
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="sip extension module for PyQt5"
+# note that PyQt5-sip is currently not on github, but this is the
+# homepage listed upstream as of the writing of this
+HOMEPAGE="https://github.com/Python-SIP/sip/"
+
+LICENSE="BSD-2"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
diff --git a/dev-python/PyQt5-sip/metadata.xml b/dev-python/PyQt5-sip/metadata.xml
index 249066785741..37c680d9291a 100644
--- a/dev-python/PyQt5-sip/metadata.xml
+++ b/dev-python/PyQt5-sip/metadata.xml
@@ -6,13 +6,7 @@
<name>Gentoo Qt Project</name>
</maintainer>
<upstream>
- <maintainer status="active">
- <email>phil@riverbankcomputing.com</email>
- <name>Phil Thompson</name>
- </maintainer>
- <changelog>https://www.riverbankcomputing.com/hg/sip/raw-file/tip/NEWS</changelog>
- <doc>https://www.riverbankcomputing.com/static/Docs/sip/</doc>
- <bugs-to>mailto:pyqt@riverbankcomputing.com</bugs-to>
+ <bugs-to>https://github.com/Python-SIP/sip/issues</bugs-to>
<remote-id type="pypi">PyQt5-sip</remote-id>
</upstream>
</pkgmetadata>