summaryrefslogtreecommitdiff
path: root/dev-python/PyQt5/PyQt5-5.15.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-17 18:28:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-17 18:28:08 +0000
commit1f254b1ee917690b4f8f7738fdcfc295ee304ff7 (patch)
tree136ad1b72b899873af1ab7e8fcc6ec343484f41f /dev-python/PyQt5/PyQt5-5.15.9.ebuild
parentbcf596975a1c2450e077c80c84017c54198f216c (diff)
gentoo auto-resync : 17:03:2023 - 18:28:08
Diffstat (limited to 'dev-python/PyQt5/PyQt5-5.15.9.ebuild')
-rw-r--r--dev-python/PyQt5/PyQt5-5.15.9.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/PyQt5/PyQt5-5.15.9.ebuild b/dev-python/PyQt5/PyQt5-5.15.9.ebuild
index 80b8a0cb9d4d..936b389127ca 100644
--- a/dev-python/PyQt5/PyQt5-5.15.9.ebuild
+++ b/dev-python/PyQt5/PyQt5-5.15.9.ebuild
@@ -3,19 +3,18 @@
EAPI=8
+PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{9..11} )
-inherit python-r1 qmake-utils
+inherit pypi python-r1 qmake-utils
DESCRIPTION="Python bindings for the Qt framework"
HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/ https://pypi.org/project/PyQt5/"
-MY_P=${PN}-${PV/_pre/.dev}
if [[ ${PV} == *_pre* ]]; then
+ MY_P=${PN}-${PV/_pre/.dev}
SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+ S=${WORKDIR}/${MY_P}
fi
-S=${WORKDIR}/${MY_P}
LICENSE="GPL-3"
SLOT="0"