summaryrefslogtreecommitdiff
path: root/dev-python/PyQt5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
commit530a5a826feeb71085fb8a01927f4d775a0b131b (patch)
treeb7669c45ea3f2a3a37b2437817a370226bb1c819 /dev-python/PyQt5
parent71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (diff)
gentoo auto-resync : 24:11:2024 - 03:02:54
Diffstat (limited to 'dev-python/PyQt5')
-rw-r--r--dev-python/PyQt5/Manifest3
-rw-r--r--dev-python/PyQt5/PyQt5-5.15.11.ebuild173
-rw-r--r--dev-python/PyQt5/metadata.xml42
3 files changed, 0 insertions, 218 deletions
diff --git a/dev-python/PyQt5/Manifest b/dev-python/PyQt5/Manifest
deleted file mode 100644
index c9cffd9cefe0..000000000000
--- a/dev-python/PyQt5/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST PyQt5-5.15.11.tar.gz 3216775 BLAKE2B 5bc6cb12b8189ec0767be891971a9fd35109236eb4753eb77940104b71bbf78db4ed2354c54adf5d45655a8ded1cb10033afc037d8a3604c5db3ea073d394e0c SHA512 e52ca215f65dbb035deff042112e26be38b77405a45caebdae3e626ffe6487c88c97c54bfa33cc83d96537daa82b67b7a1c621696538e154e5996714fc063a92
-EBUILD PyQt5-5.15.11.ebuild 5269 BLAKE2B 0cd5dd1f70836a1b422b5783aa9bda2cd7c5f7ef97b2de7badd99cd33e2a4c3ee160e3e3f52642f4e106e1912ae6c9091922a73dcad7059f688a0936bb6bf093 SHA512 4f76a77b4b147a1f70a18b8e60ad010af9dd19cc6b34a6b16a72f07afefe759b3fc2b82e17d6be42de86b1e4780b93727544a9f2b4f416d7fbe01502a5916fa7
-MISC metadata.xml 2287 BLAKE2B b4090aa2c55d05554a152bc3adfa76c68dc78175d26bb4ea6d25858ce2db922c168cc4ded6c7fa9114cf651417e0a6e435baebe460c8efbbd94be17adafd6f43 SHA512 12e3559ff04c32ebce2a382bf3b01730b0b69829c77cdf75f0061143cc19000e126daebbf9014beeae8bd1fba2675ef2ecfe7943296a8dc66000439c104c1351
diff --git a/dev-python/PyQt5/PyQt5-5.15.11.ebuild b/dev-python/PyQt5/PyQt5-5.15.11.ebuild
deleted file mode 100644
index a8fc4af027d4..000000000000
--- a/dev-python/PyQt5/PyQt5-5.15.11.ebuild
+++ /dev/null
@@ -1,173 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=sip
-PYPI_NO_NORMALIZE=1
-PYPI_PN=PyQt5
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 flag-o-matic multiprocessing pypi qmake-utils
-
-DESCRIPTION="Python bindings for the Qt framework"
-HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ~ppc ppc64 ~riscv x86"
-
-IUSE="
- bluetooth dbus debug declarative designer examples gles2-only gui help location
- multimedia network opengl positioning printsupport sensors serialport speech
- sql +ssl svg testlib webchannel websockets widgets x11extras xmlpatterns
-"
-
-# The requirements below were extracted from the qmake_QT declarations
-# in project.py and from the output of 'grep -r "%Import " ${S}/sip'
-REQUIRED_USE="
- bluetooth? ( gui )
- declarative? ( gui network )
- designer? ( widgets )
- help? ( gui widgets )
- location? ( positioning )
- multimedia? ( gui network )
- opengl? ( gui widgets )
- positioning? ( gui )
- printsupport? ( gui widgets )
- sensors? ( gui )
- serialport? ( gui )
- sql? ( widgets )
- svg? ( gui widgets )
- testlib? ( widgets )
- webchannel? ( network )
- websockets? ( network )
- widgets? ( gui )
- xmlpatterns? ( network )
-"
-
-# Minimal supported version of Qt.
-QT_PV="5.15:5"
-
-DEPEND="
- >=dev-qt/qtcore-${QT_PV}
- >=dev-qt/qtxml-${QT_PV}
- bluetooth? ( >=dev-qt/qtbluetooth-${QT_PV} )
- dbus? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- >=dev-qt/qtdbus-${QT_PV}
- sys-apps/dbus
- )
- declarative? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
- designer? ( >=dev-qt/designer-${QT_PV} )
- gui? ( >=dev-qt/qtgui-${QT_PV}[gles2-only=] )
- help? ( >=dev-qt/qthelp-${QT_PV} )
- location? ( >=dev-qt/qtlocation-${QT_PV} )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[widgets?] )
- network? ( >=dev-qt/qtnetwork-${QT_PV}[ssl=] )
- opengl? ( >=dev-qt/qtopengl-${QT_PV} )
- positioning? ( >=dev-qt/qtpositioning-${QT_PV} )
- printsupport? ( >=dev-qt/qtprintsupport-${QT_PV} )
- sensors? ( >=dev-qt/qtsensors-${QT_PV} )
- serialport? ( >=dev-qt/qtserialport-${QT_PV} )
- speech? ( >=dev-qt/qtspeech-${QT_PV} )
- sql? ( >=dev-qt/qtsql-${QT_PV} )
- svg? ( >=dev-qt/qtsvg-${QT_PV} )
- testlib? ( >=dev-qt/qttest-${QT_PV} )
- webchannel? ( >=dev-qt/qtwebchannel-${QT_PV} )
- websockets? ( >=dev-qt/qtwebsockets-${QT_PV} )
- widgets? ( >=dev-qt/qtwidgets-${QT_PV} )
- x11extras? ( >=dev-qt/qtx11extras-${QT_PV} )
- xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV} )
-"
-RDEPEND="
- ${DEPEND}
- >=dev-python/PyQt5-sip-12.15:=[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/PyQt-builder-1.14.1[${PYTHON_USEDEP}]
- >=dev-python/sip-6.8.6[${PYTHON_USEDEP}]
- >=dev-qt/qtcore-${QT_PV}
- dbus? ( virtual/pkgconfig )
-"
-
-src_prepare() {
- default
-
- # hack: PyQt-builder runs qmake without our arguments and calls g++
- # or clang++ depending on what qtbase was built with, not used for
- # building but fails with -native-symlinks
- mkdir "${T}"/cxx || die
- local cxx
- ! cxx=$(type -P "${CHOST}"-g++) || ln -s -- "${cxx}" "${T}"/cxx/g++ || die
- ! cxx=$(type -P "${CHOST}"-clang++) || ln -s -- "${cxx}" "${T}"/cxx/clang++ || die
- PATH=${T}/cxx:${PATH}
-}
-
-python_configure_all() {
- append-cxxflags ${CPPFLAGS} # respect CPPFLAGS notably for DISTUTILS_EXT=1
-
- pyqt_use_enable() {
- local state=$(usex ${1} --enable= --disable=)
- shift
- echo ${*/#/${state}}
- }
-
- DISTUTILS_ARGS=(
- --jobs="$(makeopts_jobs)"
- --qmake="$(qt5_get_bindir)"/qmake
- --qmake-setting="$(qt5_get_qmake_args)"
- --verbose
- --confirm-license
-
- --enable=pylupdate
- --enable=pyrcc
- --enable=Qt
- --enable=QtCore
- $(pyqt_use_enable bluetooth QtBluetooth)
- $(pyqt_use_enable dbus QtDBus)
- $(pyqt_use_enable declarative QtQml QtQuick \
- $(usev widgets QtQuickWidgets))
- $(pyqt_use_enable designer QtDesigner)
- $(pyqt_use_enable gui QtGui \
- $(use gles2-only && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
- $(pyqt_use_enable help QtHelp)
- $(pyqt_use_enable location QtLocation)
- $(pyqt_use_enable multimedia QtMultimedia \
- $(usev widgets QtMultimediaWidgets))
- $(pyqt_use_enable network QtNetwork)
- $(pyqt_use_enable opengl QtOpenGL)
- $(pyqt_use_enable positioning QtPositioning)
- $(pyqt_use_enable printsupport QtPrintSupport)
- $(pyqt_use_enable sensors QtSensors)
- $(pyqt_use_enable serialport QtSerialPort)
- $(pyqt_use_enable speech QtTextToSpeech)
- $(pyqt_use_enable sql QtSql)
- $(pyqt_use_enable svg QtSvg)
- $(pyqt_use_enable testlib QtTest)
- $(pyqt_use_enable webchannel QtWebChannel)
- $(pyqt_use_enable websockets QtWebSockets)
- $(pyqt_use_enable widgets QtWidgets)
- $(pyqt_use_enable x11extras QtX11Extras)
- --enable=QtXml
- $(pyqt_use_enable xmlpatterns QtXmlPatterns)
-
- $(usev debug '--debug --qml-debug --tracing')
-
- $(usev !dbus --no-dbus-python)
- # note: upstream currently intentionally skips installing these two
- # plugins when using wheels w/ pep517 so, *if* something does need
- # them, it will need to be handled manually
- $(usev !declarative --no-qml-plugin)
- $(usev !designer --no-designer-plugin)
-
- $(usev gles2-only --disabled-feature=PyQt_Desktop_OpenGL)
- $(usev !ssl --disabled-feature=PyQt_SSL)
- )
-}
-
-python_install_all() {
- einstalldocs
- use examples && dodoc -r examples
-}
diff --git a/dev-python/PyQt5/metadata.xml b/dev-python/PyQt5/metadata.xml
deleted file mode 100644
index 638d81c8245b..000000000000
--- a/dev-python/PyQt5/metadata.xml
+++ /dev/null
@@ -1,42 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>qt@gentoo.org</email>
- <name>Gentoo Qt Project</name>
- </maintainer>
- <use>
- <flag name="bluetooth">Build bindings for the QtBluetooth module</flag>
- <flag name="dbus">Build bindings for the QtDBus module</flag>
- <flag name="declarative">Build bindings for the QtQml and QtQuick modules and enable the qmlscene plugin</flag>
- <flag name="designer">Build bindings for the QtDesigner module and enable the designer plugin</flag>
- <flag name="gui">Build bindings for the QtGui module</flag>
- <flag name="help">Build bindings for the QtHelp module</flag>
- <flag name="location">Build bindings for the QtLocation module</flag>
- <flag name="multimedia">Build bindings for the QtMultimedia module</flag>
- <flag name="network">Build bindings for the QtNetwork module</flag>
- <flag name="opengl">Build bindings for the QtOpenGL module</flag>
- <flag name="positioning">Build bindings for the QtPositioning module</flag>
- <flag name="printsupport">Build bindings for the QtPrintSupport module</flag>
- <flag name="sensors">Build bindings for the QtSensors module</flag>
- <flag name="serialport">Build bindings for the QtSerialPort module</flag>
- <flag name="speech">Build bindings for the QtTextToSpeech module</flag>
- <flag name="sql">Build bindings for the QtSql module</flag>
- <flag name="svg">Build bindings for the QtSvg module</flag>
- <flag name="testlib">Build bindings for the QtTest module</flag>
- <flag name="webchannel">Build bindings for the QtWebChannel module</flag>
- <flag name="websockets">Build bindings for the QtWebSockets module</flag>
- <flag name="widgets">Build bindings for the QtWidgets module</flag>
- <flag name="x11extras">Build bindings for the QtX11Extras module</flag>
- <flag name="xmlpatterns">Build bindings for the QtXmlPatterns module</flag>
- </use>
- <upstream>
- <maintainer status="active">
- <email>phil@riverbankcomputing.com</email>
- <name>Phil Thompson</name>
- </maintainer>
- <doc>https://www.riverbankcomputing.com/static/Docs/PyQt5/</doc>
- <bugs-to>mailto:pyqt@riverbankcomputing.com</bugs-to>
- <remote-id type="pypi">PyQt5</remote-id>
- </upstream>
-</pkgmetadata>