summaryrefslogtreecommitdiff
path: root/dev-python/PyQt6-sip/PyQt6-sip-13.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 20:52:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 20:52:36 +0000
commitbdf6e70da7a28f45617c02a251bb6b3844202bc5 (patch)
treecf66e5dcf53b2ee6842fd3ff4d24d52aa30cfebc /dev-python/PyQt6-sip/PyQt6-sip-13.4.1.ebuild
parentd414c993cafd9e31a370c4a5aae042c710df2419 (diff)
gentoo auto-resync : 28:01:2023 - 20:52:36
Diffstat (limited to 'dev-python/PyQt6-sip/PyQt6-sip-13.4.1.ebuild')
-rw-r--r--dev-python/PyQt6-sip/PyQt6-sip-13.4.1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/PyQt6-sip/PyQt6-sip-13.4.1.ebuild b/dev-python/PyQt6-sip/PyQt6-sip-13.4.1.ebuild
new file mode 100644
index 000000000000..58d7f3e359c4
--- /dev/null
+++ b/dev-python/PyQt6-sip/PyQt6-sip-13.4.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="sip module support for PyQt6"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="0"
+KEYWORDS="~amd64"