summaryrefslogtreecommitdiff
path: root/dev-python/PyQtWebEngine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /dev-python/PyQtWebEngine
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'dev-python/PyQtWebEngine')
-rw-r--r--dev-python/PyQtWebEngine/Manifest4
-rw-r--r--dev-python/PyQtWebEngine/PyQtWebEngine-5.12.1.ebuild2
-rw-r--r--dev-python/PyQtWebEngine/PyQtWebEngine-5.13.0.ebuild73
3 files changed, 77 insertions, 2 deletions
diff --git a/dev-python/PyQtWebEngine/Manifest b/dev-python/PyQtWebEngine/Manifest
index c23c6f089182..a3d152885a7a 100644
--- a/dev-python/PyQtWebEngine/Manifest
+++ b/dev-python/PyQtWebEngine/Manifest
@@ -1,3 +1,5 @@
DIST PyQtWebEngine_gpl-5.12.1.tar.gz 42474 BLAKE2B 6cb333d8e429ae6b9f8c20a7486754767639693351605e85c0226ab3f1f065a549d40d69669d91f501fdf2c30346304a547e36b416d275a8bfe4ea621c0633b7 SHA512 2bcb0e4da51de9cfb5128e03c03ada77f2d4b99b0885da910584717681b96759ce4301c325cbbf43602d46746e2d37d81ed62f77dd63b33359fd5fae74d7f010
-EBUILD PyQtWebEngine-5.12.1.ebuild 1707 BLAKE2B adfb1b414e8501b0e384aa251f1e3e97d6ac709e8f68131a774cd5b2c1317633ae971d613b9ee545ba9a9c2a9c0a4a64ab4e32f67d4039db855a06e3fc531c4d SHA512 5f4007395a5878d7be14ec9b3e1afa5c0e21322f01911d79511b18a7f1a988fcea2df7ec35a9d68249849c054f6ee4ef06461875fdb8cb676c2429c86972af7c
+DIST PyQtWebEngine_gpl-5.13.0.tar.gz 43939 BLAKE2B 151bfb9b7a619fe581078ce9fd42f54377673fc8873719577cddc40a7254c37b794c31baef0086897f9ed3d7914add0ac5c930dadde916ddc11e37cee428a279 SHA512 2dedffb7bde073922b357118d4bbd0327b81baaba3c69c6cf85f57401b5998bac56e01f2f7b39268b4a1e13c0b34ed116564d7f4f5975d1075d4242b1b06c065
+EBUILD PyQtWebEngine-5.12.1.ebuild 1705 BLAKE2B b51701dfda0e9d66565a7af45b78ffa6533fd89ee5511682dd054518682f5d646998f78f3302e861572e3f5743ca023bf1c391cbe52bf1bf07e79ff6f84475f9 SHA512 8e544a85482823c00024f2f0675eb6f986e9cd3e5f34e1c2941e256ad4cad09d322011fab51b8674f2631aa49a2c0009e1ac3b4d974b75ce0a3fc5b1359a23f3
+EBUILD PyQtWebEngine-5.13.0.ebuild 1707 BLAKE2B 2eba1ecf7b3a889b29e7e38106f7b577f053e2afeb537ff3a2eb612746547c7252965d4f2e82f222010bb7b9152735bca46413300310a718f5d576824fc253f4 SHA512 33216824bd9ab45ce76a36d5b20b2e06b038bba5265b99b217a55883f070b99aaa69d7159bf5bdf307233d48d257242c6b14d5a2776a4067136f274b94ae2322
MISC metadata.xml 1059 BLAKE2B faf1e1abebc25799040955794a28cdec2f24f1cbe358f15df5fbc400a55453b5281acd7ce0925d122661a3b290771d280d6a2cd7a2d536a5cbe0b0dde4aa9a5b SHA512 b5721a82b18f9c5b9bdac1937d68616c20b290fd609e2cb02dd837b6f435eafc436d68f3aff9593eb43efd30ee2e7201efafad8a38b41a198076305ab9de3862
diff --git a/dev-python/PyQtWebEngine/PyQtWebEngine-5.12.1.ebuild b/dev-python/PyQtWebEngine/PyQtWebEngine-5.12.1.ebuild
index 3ce48a7c942e..db3904aa506e 100644
--- a/dev-python/PyQtWebEngine/PyQtWebEngine-5.12.1.ebuild
+++ b/dev-python/PyQtWebEngine/PyQtWebEngine-5.12.1.ebuild
@@ -19,7 +19,7 @@ fi
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE="debug"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
diff --git a/dev-python/PyQtWebEngine/PyQtWebEngine-5.13.0.ebuild b/dev-python/PyQtWebEngine/PyQtWebEngine-5.13.0.ebuild
new file mode 100644
index 000000000000..7ca87eb7b53c
--- /dev/null
+++ b/dev-python/PyQtWebEngine/PyQtWebEngine-5.13.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit python-r1 qmake-utils
+
+DESCRIPTION="Python bindings for QtWebEngine"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqtwebengine/intro"
+
+MY_PN=PyQtWebEngine
+MY_P=${MY_PN}_gpl-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${MY_PN}/${PV}/${MY_P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/PyQt5-5.13[gui,network,printsupport,webchannel,widgets,${PYTHON_USEDEP}]
+ >=dev-python/PyQt5-sip-4.19.14:=[${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtwebengine:5[widgets]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/sip-4.19.14[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ "${PYTHON}"
+ "${S}"/configure.py
+ --qmake="$(qt5_get_bindir)"/qmake
+ $(usex debug '--debug --trace' '')
+ --verbose
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Fix parallel install failure
+ sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets' ${MY_PN}.pro || die
+
+ # Run eqmake to respect toolchain and build flags
+ eqmake5 -recursive ${MY_PN}.pro
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+
+ einstalldocs
+}