summaryrefslogtreecommitdiff
path: root/dev-python/PyQtWebEngine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-python/PyQtWebEngine
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-python/PyQtWebEngine')
-rw-r--r--dev-python/PyQtWebEngine/Manifest3
-rw-r--r--dev-python/PyQtWebEngine/PyQtWebEngine-5.12.1.ebuild73
-rw-r--r--dev-python/PyQtWebEngine/metadata.xml32
3 files changed, 108 insertions, 0 deletions
diff --git a/dev-python/PyQtWebEngine/Manifest b/dev-python/PyQtWebEngine/Manifest
new file mode 100644
index 000000000000..9c2d28ac6dd4
--- /dev/null
+++ b/dev-python/PyQtWebEngine/Manifest
@@ -0,0 +1,3 @@
+DIST PyQtWebEngine_gpl-5.12.1.tar.gz 42474 BLAKE2B 6cb333d8e429ae6b9f8c20a7486754767639693351605e85c0226ab3f1f065a549d40d69669d91f501fdf2c30346304a547e36b416d275a8bfe4ea621c0633b7 SHA512 2bcb0e4da51de9cfb5128e03c03ada77f2d4b99b0885da910584717681b96759ce4301c325cbbf43602d46746e2d37d81ed62f77dd63b33359fd5fae74d7f010
+EBUILD PyQtWebEngine-5.12.1.ebuild 1707 BLAKE2B adfb1b414e8501b0e384aa251f1e3e97d6ac709e8f68131a774cd5b2c1317633ae971d613b9ee545ba9a9c2a9c0a4a64ab4e32f67d4039db855a06e3fc531c4d SHA512 5f4007395a5878d7be14ec9b3e1afa5c0e21322f01911d79511b18a7f1a988fcea2df7ec35a9d68249849c054f6ee4ef06461875fdb8cb676c2429c86972af7c
+MISC metadata.xml 1183 BLAKE2B 3f8f174a06bb6b662a853d1b974ca117724fd464043a3e272348fa297c19ae18ddb4e572f9c31214cd1fbb79b89b1ccfdf5c2ccfec5519ae1cb0985b718c3a5a SHA512 3172a5090e929699886d0bd4e15d6ef18b069910b572aee49908d62f96ed0401036c20767bd8ab7d7a041ea176be3caa28002e56ca9a1b911907dec8b60eb48e
diff --git a/dev-python/PyQtWebEngine/PyQtWebEngine-5.12.1.ebuild b/dev-python/PyQtWebEngine/PyQtWebEngine-5.12.1.ebuild
new file mode 100644
index 000000000000..3ce48a7c942e
--- /dev/null
+++ b/dev-python/PyQtWebEngine/PyQtWebEngine-5.12.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit python-r1 qmake-utils
+
+DESCRIPTION="Python bindings for QtWebEngine"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqtwebengine/intro"
+
+MY_PN=PyQtWebEngine
+MY_P=${MY_PN}_gpl-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${MY_PN}/${PV}/${MY_P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/PyQt5-5.12[gui,network,printsupport,webchannel,widgets,${PYTHON_USEDEP}]
+ >=dev-python/PyQt5-sip-4.19.14:=[${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtwebengine:5[widgets]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/sip-4.19.14[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ "${PYTHON}"
+ "${S}"/configure.py
+ --qmake="$(qt5_get_bindir)"/qmake
+ $(usex debug '--debug --trace' '')
+ --verbose
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Fix parallel install failure
+ sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets' ${MY_PN}.pro || die
+
+ # Run eqmake to respect toolchain and build flags
+ eqmake5 -recursive ${MY_PN}.pro
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+
+ einstalldocs
+}
diff --git a/dev-python/PyQtWebEngine/metadata.xml b/dev-python/PyQtWebEngine/metadata.xml
new file mode 100644
index 000000000000..c63098a37ce9
--- /dev/null
+++ b/dev-python/PyQtWebEngine/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>stefan.strogin@gmail.com</email>
+ <name>Stefan Strogin</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ PyQtWebEngine is a set of Python bindings for The Qt Company's
+ Qt WebEngine libraries. The bindings sit on top of PyQt5 and
+ are implemented as a set of three modules. Prior to v5.12 these
+ bindings were part of PyQt5 itself.
+ </longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>phil@riverbankcomputing.com</email>
+ <name>Phil Thompson</name>
+ </maintainer>
+ <changelog>https://www.riverbankcomputing.com/static/Downloads/PyQtWebEngine/ChangeLog</changelog>
+ <doc>https://www.riverbankcomputing.com/static/Docs/PyQt5/</doc>
+ <bugs-to>mailto:pyqt@riverbankcomputing.com</bugs-to>
+ <remote-id type="pypi">PyQtWebEngine</remote-id>
+ </upstream>
+</pkgmetadata>