summaryrefslogtreecommitdiff
path: root/dev-python/PySDL2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-30 23:46:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-30 23:46:05 +0000
commitbb262580ec0b56a32797f121e627928d103e6bb1 (patch)
treeb3b80cb753a087635c972352ce99fed1d01f286b /dev-python/PySDL2
parent35e3ee5faf74dc69409f957f81a6848d4d24c49f (diff)
gentoo auto-resync : 30:12:2023 - 23:46:05
Diffstat (limited to 'dev-python/PySDL2')
-rw-r--r--dev-python/PySDL2/Manifest2
-rw-r--r--dev-python/PySDL2/PySDL2-0.9.13.ebuild66
2 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/PySDL2/Manifest b/dev-python/PySDL2/Manifest
index 40cfd1448bd0..9fb6e9e0298f 100644
--- a/dev-python/PySDL2/Manifest
+++ b/dev-python/PySDL2/Manifest
@@ -1,5 +1,3 @@
-DIST PySDL2-0.9.13.tar.gz 754811 BLAKE2B fe9d3fb32cac104303d67741c3b9e0d78d3d03198ed512464bbdf5bc487a5f4c9a92aafb100c53c02d8be87bb107034f67ebb72294ad67cc0a8b42ab7a678a31 SHA512 f866e7ed35e3ccfbb5b98f797e87d5b20c6f7dadbc3396b297cbb6c2d83a7f3290fde63940a4d8f190e40a4a9269d2df9efc1932d9578d3df1617e5fcbe6ecad
DIST PySDL2-0.9.16.tar.gz 773537 BLAKE2B 5cfe4ab3981a665fc7f7606c07a3252e58c2706e45ab41d0d6444b4d3fb1c8805b5fd67e770a8a64538d305be0013a4d599ee81f5de0c5370146edc9d4d858df SHA512 ffe7abe8e828926934677c81a42c9af794c4817144eba50c40430c150d476dea40f0b36e639b2c270cbd8e00ab5bf5b032a4c0e514255cceef8161c8d76f8cb2
-EBUILD PySDL2-0.9.13.ebuild 1648 BLAKE2B c2dc6b6b922fa4b206e8c2e3239c22daa3d534fad0e1a2d05ff115f53f2ea517a06bcfb3a4af2626306e2a801edaa47742072597b9540ddf1ae393f0a31e4251 SHA512 cf22ae9d778fa836477ba8d968a4599b05b99576aa892db1073881c079597e9aa901b29a660b45af9a9a3c34989c96cbebfd06b15592e61c8df2f54a1c7daf34
EBUILD PySDL2-0.9.16.ebuild 1784 BLAKE2B 9f8c8d3a0f96e88b6d857f0cbe219204d9012143fb37bde2f45a4943e771ce13931988db2375c5619461977508e2e6de72e32e71af81f6ce98428507d8886738 SHA512 5329aae968144c9bc6c50e575c560be338c7d868f21506dfef753debe708f448635f9e8db8a4bcf4c832e666b31dc2b86293e7dac6cbc66e00517646f5aa125d
MISC metadata.xml 450 BLAKE2B f92f2f7529e3a09d18c88a51f78ed520d7b4756a99776d70bb7ad4e452ae6cd9a67560ebfaafcacbd73e945282fc28ecdb48d54b2c2eb5b18d3f944401650349 SHA512 de7f757b195170ee865e34dcc214d0a57912e50631291045c485f58ba05fa87b7fc57878333021c7b9d3f8609e9afa4190f4c4062fb7a8136498875aecee615c
diff --git a/dev-python/PySDL2/PySDL2-0.9.13.ebuild b/dev-python/PySDL2/PySDL2-0.9.13.ebuild
deleted file mode 100644
index 2d34a3934ab3..000000000000
--- a/dev-python/PySDL2/PySDL2-0.9.13.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python (ctypes) bindings for SDL2 libraries"
-HOMEPAGE="
- https://github.com/py-sdl/py-sdl2/
- https://pypi.org/project/PySDL2/
-"
-
-LICENSE="|| ( public-domain CC0-1.0 ZLIB )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# Optional deps:
-# - dev-python/numpy,
-# - dev-python/pillow,
-# - media-libs/sdl2-* (loaded dynamically via ctypes).
-#
-# If a reverse dependency needs the specific module, it should
-# explicitly depend on the optional module in question. You also
-# probably need to explicitly require some media-libs/libsdl2 flags.
-RDEPEND="media-libs/libsdl2"
-
-# Require all of SDL2 libraries and at least the most common subsystems
-# for better test coverage.
-DEPEND="
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- media-libs/libsdl2[joystick,sound,video]
- media-libs/sdl2-gfx
- media-libs/sdl2-image[gif,jpeg,png,tiff,webp]
- || (
- media-libs/sdl2-mixer[flac]
- media-libs/sdl2-mixer[midi]
- media-libs/sdl2-mixer[mod]
- media-libs/sdl2-mixer[mp3]
- media-libs/sdl2-mixer[opus]
- )
- media-libs/sdl2-ttf
- )"
-
-EPYTEST_DESELECT=(
- # Both tests fail and seem machine-dependent?
- sdl2/test/sdlttf_test.py::test_TTF_SetFontSize
- sdl2/test/sdlttf_test.py::test_TTF_SetFontSizeDPI
-)
-
-distutils_enable_tests pytest
-
-src_test() {
- # from .travis.yml
- local -x SDL_VIDEODRIVER=dummy
- local -x SDL_AUDIODRIVER=dummy
- local -x SDL_RENDER_DRIVER=software
-
- distutils-r1_src_test
-}