summaryrefslogtreecommitdiff
path: root/dev-python/PySensors/PySensors-0.0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-06 13:21:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-06 13:21:55 +0100
commit275074c50dca7b941cc7cd7966a2ace71c29ecae (patch)
treee22b9ca529098f2d687b61bc9b0eb711b0990cc3 /dev-python/PySensors/PySensors-0.0.4-r1.ebuild
parent86b151cdc26e1566efef728aac4ebb2aabce776a (diff)
gentoo auto-resync : 06:10:2022 - 13:21:55
Diffstat (limited to 'dev-python/PySensors/PySensors-0.0.4-r1.ebuild')
-rw-r--r--dev-python/PySensors/PySensors-0.0.4-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/PySensors/PySensors-0.0.4-r1.ebuild b/dev-python/PySensors/PySensors-0.0.4-r1.ebuild
new file mode 100644
index 000000000000..c031b7cdf3f9
--- /dev/null
+++ b/dev-python/PySensors/PySensors-0.0.4-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to libsensors (via ctypes)"
+HOMEPAGE="https://pypi.org/project/PySensors/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=sys-apps/lm-sensors-3"