summaryrefslogtreecommitdiff
path: root/dev-python/PyUtilib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-27 13:58:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-27 13:58:28 +0000
commit8eccda982236f2cfe9188bdcaffd9168134f39a9 (patch)
treea2f9e1db038cdb1c9ae55a8ead0f9020b072d627 /dev-python/PyUtilib
parentf2299aed04cae8310f7fce0be5396370e346d966 (diff)
gentoo auto-resync : 27:01:2023 - 13:58:28
Diffstat (limited to 'dev-python/PyUtilib')
-rw-r--r--dev-python/PyUtilib/Manifest4
-rw-r--r--dev-python/PyUtilib/PyUtilib-6.0.0.ebuild49
-rw-r--r--dev-python/PyUtilib/files/PyUtilib-6.0.0-tests.patch12
-rw-r--r--dev-python/PyUtilib/metadata.xml15
4 files changed, 0 insertions, 80 deletions
diff --git a/dev-python/PyUtilib/Manifest b/dev-python/PyUtilib/Manifest
deleted file mode 100644
index 0a55d38d9964..000000000000
--- a/dev-python/PyUtilib/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX PyUtilib-6.0.0-tests.patch 510 BLAKE2B 729853aaeebbb3de8ed7a9a8e466a5df3addcbd755e9951d3745ca46a13c8a4b42844b80392c687acb586d8f4edfb04f43fe158395ad1e7f92ec1df919b93bd9 SHA512 3779c4d0c20b967275e67091500b00d7fae3c5ad655e518a50dc653eb11d17c468a46ff67bb928f1652b4cd95c81cff724f5cde875e1e5fd8667c76312c9ec3d
-DIST PyUtilib-6.0.0.tar.gz 1569916 BLAKE2B ee4085b597e928c5d6602b647f122c562f2e05dcaf300217cea9c5bc652f6acb5dbe5a075cbbbc1b81497987ab5c658f86cc3e44e16cae02a37d546b2e925a9b SHA512 7841a84ee8d66d2d7af3db810e4d787030acbd8e3e81c3f61251ea160931feddeab6f4d205977a411964359f1cb7e7e59e846593c113093e01c48b81784f7477
-EBUILD PyUtilib-6.0.0.ebuild 1131 BLAKE2B fe973305f656e21feb7c820974803d744b2c48cc01949d58c565fac503c78f6ac0ae06b8079269a23f32fe0ecc5db0577ddd27bd3a7f5d77dd0346a1081df33c SHA512 6fb3dc4f4f3b328d2ac766c6f671005b69ad4b4d64a68275ea828c6cac057ec1e04b488a6d6baacbee17bf34396ad50756c106cefb147872bd3b93afe3575342
-MISC metadata.xml 424 BLAKE2B b1f7f100094d235fc3d266bc84cf39208b5afd1fbf419fc796ed2884527a641dea52173d607e6d40f0292316695e8ead2d387cf4c427c0983ee32d8620b08f6b SHA512 be42d862d2b6af906fcd65cb073eb7daf1540cdfd41e451fc8a1766875e875e501d7deeaa3410146cd07fe78f94a9fed1d7cfbe935db47e44144844f573af154
diff --git a/dev-python/PyUtilib/PyUtilib-6.0.0.ebuild b/dev-python/PyUtilib/PyUtilib-6.0.0.ebuild
deleted file mode 100644
index 95679756d18e..000000000000
--- a/dev-python/PyUtilib/PyUtilib-6.0.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1
-
-DESCRIPTION="A collection of Python utilities"
-HOMEPAGE="https://github.com/PyUtilib/pyutilib"
-SRC_URI="https://github.com/${PN}/${PN,,}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN,,}-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-BDEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}/PyUtilib-6.0.0-tests.patch"
-)
-
-distutils_enable_tests unittest
-
-python_install_all() {
- distutils-r1_python_install_all
-
- find "${ED}" -name '*.pth' -delete || die
-}
-
-python_test() {
- distutils_install_for_testing --via-root
-
- local -x PYTHONPATH="${PWD}:${TEST_DIR}/lib" \
- COLUMNS=80
-
- if [[ ${EPYTHON} == python3.10 ]]; then
- # Fix for very small output change of expected output in new version
- sed -e 's/optional arguments/options/' -i \
- "${BUILD_DIR}/../doc/workflow/examples/"*.txt \
- pyutilib/misc/tests/test_config.py || die
- fi
-
- eunittest
-}
diff --git a/dev-python/PyUtilib/files/PyUtilib-6.0.0-tests.patch b/dev-python/PyUtilib/files/PyUtilib-6.0.0-tests.patch
deleted file mode 100644
index 33dcd4605818..000000000000
--- a/dev-python/PyUtilib/files/PyUtilib-6.0.0-tests.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/pyutilib/component/loader/tests/test_egg.py b/pyutilib/component/loader/tests/test_egg.py
-index c8674d0..7126e5c 100644
---- a/pyutilib/component/loader/tests/test_egg.py
-+++ b/pyutilib/component/loader/tests/test_egg.py
-@@ -23,6 +23,7 @@ except ImportError:
-
-
- @unittest.skipIf(not pkg_resources_avail, "Cannot import 'pkg_resources'")
-+@unittest.skipIf(sys.hexversion >= 0x03090000, "Example eggs not generated for python >= 3.9")
- class Test(pyutilib.th.TestCase):
-
- def test_egg1(self):
diff --git a/dev-python/PyUtilib/metadata.xml b/dev-python/PyUtilib/metadata.xml
deleted file mode 100644
index b6c9c5fcc9da..000000000000
--- a/dev-python/PyUtilib/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- </maintainer>
- <maintainer type="person">
- <email>chutzpah@gentoo.org</email>
- <name>Patrick McLean</name>
- </maintainer>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">PyUtilib</remote-id>
- </upstream>
-</pkgmetadata>