summaryrefslogtreecommitdiff
path: root/dev-python/PyUtilib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-python/PyUtilib
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-python/PyUtilib')
-rw-r--r--dev-python/PyUtilib/Manifest4
-rw-r--r--dev-python/PyUtilib/PyUtilib-5.6.5.ebuild51
-rw-r--r--dev-python/PyUtilib/files/pyutilib-5.6.5-tests.patch35
-rw-r--r--dev-python/PyUtilib/metadata.xml11
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/PyUtilib/Manifest b/dev-python/PyUtilib/Manifest
new file mode 100644
index 000000000000..ed6eb250bf92
--- /dev/null
+++ b/dev-python/PyUtilib/Manifest
@@ -0,0 +1,4 @@
+AUX pyutilib-5.6.5-tests.patch 1413 BLAKE2B 8cfb6abadbd0c83adccd69cd18dd85aa2c58ad6d8610de0912397e626704ff6921ed54869c0ea2e7dd1567070e5061fa424d7749236cd2e8321d17a6b60ad4a8 SHA512 00d838e4eab285e7eaa1fe802abd1fa22f3a662fd10220cc3811fab6d9025dcb327811e13ee13f2102ff1ff2b8b132a10c32cabfb94080940dec691b6a890298
+DIST PyUtilib-5.6.5.tar.gz 1504220 BLAKE2B 2d00b8b9a0a787413dce5dd4380382efa4c8788e9a8f5188eb0decf9e55bc07ce5ceb8e6f32ed2fa7cf58c331fe936ea07d9b599ff8e7e9593327d3c0f05d4e9 SHA512 5e7f86c29ff81cfffea5862d09ec8d026739f09b172606acd4d08dc4a9bde28c8b63b8e51634d17c3161b46e7e8c8881050044baa22bc07b0926efe46ed7331d
+EBUILD PyUtilib-5.6.5.ebuild 1082 BLAKE2B 59e6fa198c51f701b18dbf351d531056d330320e3f7c5ef2023185a1e93493a60c18905c0d7ad9775ad5389c39835ea731238f540c14cfd3a469565af4af5839 SHA512 fa645cb3436c97a1aa54bf94549a24082417acfc55c8b90017bf5d4d27bf5a02903e3e4de4a426c3ed13dce6708307d4089b317bb42513c7d7563ac81b9810ad
+MISC metadata.xml 338 BLAKE2B e8be381e5e42a081be3637b77a9b5356dd7d74d0352976badfca62bdf7b65c04554552703b3e12e169ec1c4b57d07cedcf75387a0fd65a8177213f0de8bffa9c SHA512 b3e03151085bcaa51e2108d7e69042523148aaba924415421323d53005c1d047103827ed99bf064cda4f02cc313b3ff4e5fc681bccb5f1f23a82b40a744ed9bc
diff --git a/dev-python/PyUtilib/PyUtilib-5.6.5.ebuild b/dev-python/PyUtilib/PyUtilib-5.6.5.ebuild
new file mode 100644
index 000000000000..0f3cc65d1085
--- /dev/null
+++ b/dev-python/PyUtilib/PyUtilib-5.6.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="A collection of Python utilities"
+HOMEPAGE="https://github.com/PyUtilib/pyutilib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/pyutilib-5.6.5-tests.patch"
+)
+
+python_prepare() {
+ # shells out to run nosetests
+ rm pyutilib/dev/tests/test_runtests.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ if ! python_is_python3; then
+ printf "# Placeholder for python2\n" \
+ > "${D}$(python_get_sitedir)/${PN,,}/__init__.py"
+ fi
+}
+
+python_test() {
+ COLUMNS="80" "${EPYTHON}" -W ignore::DeprecationWarning \
+ -m unittest discover -v || die
+}
diff --git a/dev-python/PyUtilib/files/pyutilib-5.6.5-tests.patch b/dev-python/PyUtilib/files/pyutilib-5.6.5-tests.patch
new file mode 100644
index 000000000000..780c586759af
--- /dev/null
+++ b/dev-python/PyUtilib/files/pyutilib-5.6.5-tests.patch
@@ -0,0 +1,35 @@
+diff --git a/pyutilib/dev/entry_point.py b/pyutilib/dev/entry_point.py
+index e571cc7..e0200e9 100644
+--- a/pyutilib/dev/entry_point.py
++++ b/pyutilib/dev/entry_point.py
+@@ -23,7 +23,8 @@ def run_entry_point(package, script, args=[], **kwds):
+ script = str(script)
+ assert type(args) is list
+ cmdLine \
+- = "import pkg_resources,sys; "\
++ = "import pkg_resources,sys,os; "\
++ "pkg_resources.fixup_namespace_packages(os.path.join(os.getcwd(),'build')); "\
+ "sys.argv=%r; "\
+ "sys.exit(pkg_resources.load_entry_point(%r,'console_scripts',%r)())" \
+ % ( [script]+args, package, script )
+diff --git a/pyutilib/enum/tests/test_enum.py b/pyutilib/enum/tests/test_enum.py
+index 52451ef..66313f4 100755
+--- a/pyutilib/enum/tests/test_enum.py
++++ b/pyutilib/enum/tests/test_enum.py
+@@ -11,7 +11,7 @@
+ """ Unit test for ‘enum’ module.
+ """
+
+-import unittest
++import unittest, sys
+
+ import pyutilib.enum.enum as enum
+
+@@ -355,6 +355,7 @@ class Test_EnumValue(unittest.TestCase):
+ for other_value in self.other_values:
+ self.assertNotEqual(test_value, other_value)
+
++ @unittest.skipIf(sys.hexversion > 0x03040000, "can't compare int and tuple on python3")
+ def test_sequence_other_values(self):
+ # An EnumValue should compare sequentially to other values.
+ test_value = enum.EnumValue(self.SimpleEnum, 0, 'test')
diff --git a/dev-python/PyUtilib/metadata.xml b/dev-python/PyUtilib/metadata.xml
new file mode 100644
index 000000000000..2541628cf9a8
--- /dev/null
+++ b/dev-python/PyUtilib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>