summaryrefslogtreecommitdiff
path: root/dev-python/Pyro4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/Pyro4
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/Pyro4')
-rw-r--r--dev-python/Pyro4/Manifest4
-rw-r--r--dev-python/Pyro4/Pyro4-4.81.ebuild55
-rw-r--r--dev-python/Pyro4/Pyro4-4.82.ebuild4
3 files changed, 3 insertions, 60 deletions
diff --git a/dev-python/Pyro4/Manifest b/dev-python/Pyro4/Manifest
index cd3a38ac086e..95c7d050f8bb 100644
--- a/dev-python/Pyro4/Manifest
+++ b/dev-python/Pyro4/Manifest
@@ -1,5 +1,3 @@
-DIST Pyro4-4.81.tar.gz 514678 BLAKE2B ffe9edcb947203b37cf1b13b2380f2b7d76357a5bca36e454fe67f6bd0d34574f5df429dd784ba2c2bc69c0188edd14e4572f12f5c137d87d2898f01ea3e855c SHA512 3848d473acd624ae1356ad3470c669eb0bc30287691ff8b9fc27fb0591ba305812c6be1946d6a2a91377e222a9e114f05ed18170d1b035dec24e436ab8dadc59
DIST Pyro4-4.82.tar.gz 516110 BLAKE2B ecd7b5cf1469896acfec1db92d99784aa316db5cadbb7fc595a5f9916ac705619d070771549fb8ba7379a7395e4449eabcfc84aa131d4b23b587b7467f4bf196 SHA512 f5916ce37ec52d8cd23bece79325480140621ac8412febb4877a32b1ce54502ef17d20bf591dc30eb20e9619741548b30a78165937d5e69e8d1911d95a23b1e1
-EBUILD Pyro4-4.81.ebuild 1242 BLAKE2B b7bb7476f62c689996e6518c19e2d3e4feaf8daf620a63a31832b7b47a9880a83f69f25e28a19ea1ee72c7a64a896057b0643f63c1e31761460a831b898591d6 SHA512 9c8864312719d06cf88b75d9794a399a4d439c65d51a2f48151d781e227132190686e5fe375ecf6a69640833140c501a3eee9d0c42e53031d030e30ac6c5c54a
-EBUILD Pyro4-4.82.ebuild 1254 BLAKE2B 62880b06fc30810c6c8fe209273a56006587eacc3e053fa5a0448d8e27a91c4269160c88d25e6525fb8729e7884a5f040b43e837a77a780737b36df4cd2ebd9d SHA512 0c0d223ec00e2ca6f1a8d75fc8aa6c2ef05a26854cb29e1553b54b6ee00ee75058d9337afbb3a69d83a9dd22d8e4d5723b2af527ec144f0c3da1f5da967d734a
+EBUILD Pyro4-4.82.ebuild 1251 BLAKE2B 7e14e212a8350b04f35174e1c7e9b8d3852c8462b0e306a88777b6e0f82306504ecf26f06173ad06a6c0b41838476e819c860e6528bb21b6c59ae11a51ef3754 SHA512 11e1063dcd0a51ffd52a809e459749bd404e7fd6278e805818c109a6e55495aa461b80fdc6099288bab79e679b6dc8c1a48dac9aa72526c3e3d43c2c20ee6ac6
MISC metadata.xml 384 BLAKE2B e0dcf58b7db6287f6912e1ce549f52fb269eeac53def37ff75b8c30957c02eaef506a44bc15c3fdfdf01c2607e803b8706cc3be6b50585383f30edcd8c3cebf6 SHA512 9f4ed623a9e07d84fd61b3eccf65d80c883265b3de24d79b888c5d880498325dd268e4e5390f60ed67b19101e072276b1d7eb80724bf7a0cd6713fc20d374e33
diff --git a/dev-python/Pyro4/Pyro4-4.81.ebuild b/dev-python/Pyro4/Pyro4-4.81.ebuild
deleted file mode 100644
index 66d4b212b769..000000000000
--- a/dev-python/Pyro4/Pyro4-4.81.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="Distributed object middleware for Python (RPC)"
-HOMEPAGE="https://pypi.org/project/Pyro4/
- https://github.com/irmen/Pyro4"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/serpent-1.27[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/cloudpickle-1.2.1[${PYTHON_USEDEP}]
- dev-python/dill[${PYTHON_USEDEP}]
- >=dev-python/msgpack-0.4.6[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # Disable tests requiring network connection.
- rm tests/PyroTests/test_naming.py || die
- sed \
- -e "s/testStartNSfunc/_&/" \
- -i tests/PyroTests/test_naming2.py || die
-
- sed \
- -e "s/testBroadcast/_&/" \
- -e "s/testGetIP/_&/" \
- -i tests/PyroTests/test_socket.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/. )
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}
diff --git a/dev-python/Pyro4/Pyro4-4.82.ebuild b/dev-python/Pyro4/Pyro4-4.82.ebuild
index 4d1a73752e5c..ee8e259935ab 100644
--- a/dev-python/Pyro4/Pyro4-4.82.ebuild
+++ b/dev-python/Pyro4/Pyro4-4.82.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+KEYWORDS="amd64 ~arm64 ppc x86"
IUSE="doc examples test"
RESTRICT="!test? ( test )"