summaryrefslogtreecommitdiff
path: root/dev-python/QtPy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
commit530a5a826feeb71085fb8a01927f4d775a0b131b (patch)
treeb7669c45ea3f2a3a37b2437817a370226bb1c819 /dev-python/QtPy
parent71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (diff)
gentoo auto-resync : 24:11:2024 - 03:02:54
Diffstat (limited to 'dev-python/QtPy')
-rw-r--r--dev-python/QtPy/Manifest5
-rw-r--r--dev-python/QtPy/QtPy-2.4.1-r2.ebuild245
-rw-r--r--dev-python/QtPy/QtPy-2.4.2.ebuild244
-rw-r--r--dev-python/QtPy/metadata.xml49
4 files changed, 0 insertions, 543 deletions
diff --git a/dev-python/QtPy/Manifest b/dev-python/QtPy/Manifest
deleted file mode 100644
index a7231aaeb416..000000000000
--- a/dev-python/QtPy/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST QtPy-2.4.1.tar.gz 65492 BLAKE2B 3816e3836c171f75fc1877984b533602c8929a791b09a1f53b14687eae7a1067e47fcae3a198d798417521a1a81829168d3af94178b28d8a3bd2c28e7d9f7865 SHA512 cb7c65cfec5aba9bdc4942b95108ac0300eac5ca8f0c984e8ea789b77fded3a1817f591d43bc45e9aa4feb3cb3da64c0d42ae67f12121a807cf7c247e7612e7d
-DIST qtpy-2.4.2.tar.gz 66849 BLAKE2B 1eb362e797950d6c1406fb02bb3047ca7f8fdecd2b75371ab34f39601c9bdebce33336e3809c0d35dca31673c88d1734721a6dfdfb65f2ce20729445c4a4ca27 SHA512 2f9a0e1a4839c8dca23b4364900a12c2bd00f518353785a41eb6bd62fdc469670457f18224e1150a5a216ff5d0c4e799c3a1711ff7703ea07fadd655538fa37a
-EBUILD QtPy-2.4.1-r2.ebuild 8786 BLAKE2B 5b9c0fbdd414c327f6ec0fefeb360b9829cc0f875497dbf55618bbee14a8d968cd6ed4e2bc1c775e1723e26968fa47bab2ceee6c5b7b1a999a937cd35fcc40cb SHA512 faaa99e2b0f8ea55a0cf30af3710b256c9cd79a16876bebe739087605a4aec7b14e0539c8325303d84c11046e0559a034ba5fc057fadd8ab3e8e887c3aae5bdc
-EBUILD QtPy-2.4.2.ebuild 8781 BLAKE2B 6f26b9a4710da0ecfc66156b25e0d69d72a9373e2dc44ac69f6d636d5ba4070c686ff75d1f503489a1a358ddd0eaccf108b3cc9898310c4073d243625db287f0 SHA512 51f590a8baf00d3e4d341a14d9b0c41094827add556d6545611b96e6a0832be32eaea743f9936a83558706473147cd360080d92fe7dadc961ea03fc6b6e33a66
-MISC metadata.xml 2851 BLAKE2B 4deaa44ead64f6a8475413012d05a96bdab411200c679a00ed915b411b642cd459fd1e26a923254f26a2fa47237a95accf106e54018f4b25b335581a5c721920 SHA512 6d7a7da2bf4678328327d6d816d7938628e1ee8f726090580e5691290a7da6e908617d2ebf93984d4266d42104aaec213e3c62b62852c94ae99e15d80ee70842
diff --git a/dev-python/QtPy/QtPy-2.4.1-r2.ebuild b/dev-python/QtPy/QtPy-2.4.1-r2.ebuild
deleted file mode 100644
index 22f79f3d25f1..000000000000
--- a/dev-python/QtPy/QtPy-2.4.1-r2.ebuild
+++ /dev/null
@@ -1,245 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=QtPy
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 virtualx pypi
-
-DESCRIPTION="Abstraction layer on top of PyQt and PySide with additional custom QWidgets"
-HOMEPAGE="
- https://github.com/spyder-ide/qtpy/
- https://pypi.org/project/QtPy/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
-
-_IUSE_QT_MODULES="
- designer +gui help multimedia +network opengl positioning
- printsupport qml quick sensors serialport speech +sql svg testlib
- webchannel webengine websockets +widgets +xml
-"
-IUSE="+pyqt5 +pyqt6 pyside2 pyside6 ${_IUSE_QT_MODULES}"
-unset _IUSE_QT_MODULES
-
-REQUIRED_USE="
- || ( pyqt5 pyqt6 pyside2 pyside6 )
- python_targets_python3_12? ( !pyside2 )
- python_targets_python3_13? ( !pyside2 )
-"
-
-# These flags are currently *not* common to the PySide2/6 and PyQt5/6 ebuilds
-# Disable them for now, please check periodically if this is still up to date.
-# bluetooth? ( pyqt5/6 and pyside6 only )
-# dbus? ( pyqt5/6 and pyside6 only )
-#
-# 3d? ( pyside2/6 only )
-# charts? ( pyside2 only )
-# concurrent? ( pyside2 only )
-# datavis? ( pyside2 only )
-# scxml? ( pyside2/6 only )
-#
-# x11extras? ( pyside2 and pyqt5 only )
-# xmlpatterns? ( pyside2 and pyqt5 only )
-#
-# location? ( pyside2/6 and pyqt5 only)
-# nfc? ( pyqt6 and pyside6 only)
-# spatialaudio? ( pyqt6 and pyside6 only)
-# pdfium? ( pyqt6 and pyside6 only)
-
-# WARNING: the obvious solution of using || for PyQt5/pyside2 is not going
-# to work. The package only checks whether PyQt5/pyside2 is installed, it does
-# not verify whether they have the necessary modules (i.e. satisfy the USE dep).
-#
-# Webengine is a special case, because PyQt5 provides this in a separate package
-# while PySide2 ships it in the same package.
-#
-# declarative/qml/quick is a special case, because PyQt5 bundles the bindings
-# for qml and quick in one flag: declarative PySide2 does not.
-#
-# The PyQt5 ebuild currently enables xml support unconditionally, the flag is
-# added anyway with a (+) to make it future proof if the ebuild were to change
-# this behaviour in the future.
-#
-# The PySide2 ebuild currently enables opengl and serialport support
-# unconditionally, the flag is added anyway with a (+) to make it future proof
-# if the ebuild were to change this behaviour in the future.
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[designer?,gui?,help?,multimedia?,network?,opengl?]
- dev-python/PyQt5[positioning?,printsupport?,sensors?,serialport?,speech?,sql?,svg?]
- dev-python/PyQt5[testlib?,webchannel?,websockets?,widgets?,xml(+)?]
- qml? ( dev-python/PyQt5[declarative] )
- quick? ( dev-python/PyQt5[declarative] )
- webengine? ( dev-python/PyQtWebEngine[${PYTHON_USEDEP}] )
- )
- pyqt6? (
- dev-python/PyQt6[${PYTHON_USEDEP}]
- dev-python/PyQt6[designer?,gui?,help?,multimedia?,network?,opengl?]
- dev-python/PyQt6[positioning?,printsupport?,qml?,quick?,sensors?,serialport?,sql?]
- dev-python/PyQt6[speech?,svg?,testlib?,webchannel?,websockets?,widgets?,xml?]
- webengine? ( dev-python/PyQt6-WebEngine[${PYTHON_USEDEP},widgets?,quick?] )
-
- )
- pyside2? (
- $(python_gen_cond_dep '
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[designer?,gui?,help?,multimedia?,network?,opengl(+)?]
- dev-python/pyside2[positioning?,printsupport?,qml?,quick?,sensors?,serialport(+)?]
- dev-python/pyside2[speech?,sql?,svg?,testlib?,webchannel?,webengine?,websockets?]
- dev-python/pyside2[widgets?,xml?]
- ' python3_{10..11})
- )
- pyside6? (
- dev-python/pyside6[${PYTHON_USEDEP}]
- dev-python/pyside6[designer?,gui?,help?,multimedia?,network?,opengl?]
- dev-python/pyside6[positioning?,printsupport?,qml?,quick?,sensors(-)?,serialport?]
- dev-python/pyside6[speech(-)?,sql?,svg?,testlib?,webchannel?,webengine?,websockets?]
- dev-python/pyside6[widgets?,xml?]
- )
-"
-
-# The QtPy testsuite skips tests for bindings that are not installed, so here we
-# ensure that everything is available and all tests are run. Note that not
-# all flags are available in PyQt5/PySide2, so some tests are still skipped.
-BDEPEND="
- test? (
- dev-python/pytest-qt[${PYTHON_USEDEP}]
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[bluetooth,dbus,declarative,designer,gui,help,location]
- dev-python/PyQt5[multimedia,network,opengl,positioning,printsupport]
- dev-python/PyQt5[sensors,serialport,speech(-),sql,svg,testlib,webchannel]
- dev-python/PyQt5[websockets,widgets,x11extras,xml(+),xmlpatterns]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- dev-qt/qtsql:5[sqlite]
- )
- pyqt6? (
- dev-python/PyQt6[${PYTHON_USEDEP}]
- dev-python/PyQt6[dbus,designer,gui,help,multimedia,network,nfc,opengl]
- dev-python/PyQt6[pdfium(-),positioning,printsupport,qml,quick,quick3d,serialport]
- dev-python/PyQt6[sensors(-),spatialaudio(-),speech(-),sql,ssl,svg,testlib,webchannel]
- dev-python/PyQt6[websockets,widgets,xml]
- dev-python/PyQt6-WebEngine[${PYTHON_USEDEP},widgets,quick]
- dev-qt/qtbase:6[sqlite]
- )
- pyside2? (
- $(python_gen_cond_dep '
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[3d,charts,concurrent,datavis,designer,gui,help]
- dev-python/pyside2[location,multimedia,network,opengl(+)]
- dev-python/pyside2[positioning,printsupport,qml,quick,scxml]
- dev-python/pyside2[sensors,serialport(+),speech,sql,svg,testlib]
- dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
- dev-python/pyside2[xml,xmlpatterns]
- dev-qt/qtsql:5[sqlite]
- dev-python/pyside2-tools[${PYTHON_USEDEP}]
- ' python3_{10..11})
- dev-qt/qtsql:5[sqlite]
- )
- pyside6? (
- dev-python/pyside6[${PYTHON_USEDEP}]
- dev-python/pyside6[3d(-),bluetooth(-),concurrent,dbus,designer,gui,help]
- dev-python/pyside6[location(-),multimedia,network,nfc(-),opengl,positioning,pdfium(-)]
- dev-python/pyside6[printsupport,qml,quick,quick3d,scxml(-),sensors(-)]
- dev-python/pyside6[serialport,spatialaudio(-),speech(-),sql,svg,testlib,webchannel]
- dev-python/pyside6[webengine,websockets,widgets,xml]
- dev-python/pyside6-tools[${PYTHON_USEDEP}]
- dev-qt/qtbase:6[sqlite]
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
- sed -i -e 's:--cov=qtpy --cov-report=term-missing::' pytest.ini || die
- # Disable Qt for Python implementations that are not selected
- if ! use pyqt5; then
- sed \
- -e '/from PyQt5.QtCore import/,/)/c\ \ \ \ \ \ \ \ raise ImportError #/' \
- -e '/if "PyQt5" in sys.modules:/,/"pyqt5"/c\' \
- -i qtpy/__init__.py || die
-
- # We need to ensure the first option is an 'if' not 'elif'
- sed -e 's/elif "PySide2" in sys.modules:/if "PySide2" in sys.modules:/g' -i qtpy/__init__.py || die
- fi
- if ! use pyside2; then
- sed \
- -e "s/from PySide2 import/raise ImportError #/" \
- -e "s/from PySide2.QtCore import/raise ImportError #/" \
- -e '/if "PySide2" in sys.modules:/,/"pyside2"/c\' \
- -i qtpy/__init__.py || die
-
- if ! use pyqt5; then
- sed \
- -e 's/elif "PyQt6" in sys.modules:/if "PyQt6" in sys.modules:/g' \
- -i qtpy/__init__.py || die
- fi
- fi
- if ! use pyqt6; then
- sed \
- -e '/from PyQt6.QtCore import/,/)/c\ \ \ \ \ \ \ \ raise ImportError #/' \
- -e '/if "PyQt6" in sys.modules:/,/"pyqt6"/c\' \
- -i qtpy/__init__.py || die
-
- if ! use pyqt5 && ! use pyside2; then
- sed \
- -e 's/elif "PySide6" in sys.modules:/if "PySide6" in sys.modules:/g' \
- -i qtpy/__init__.py || die
- fi
- fi
- if ! use pyside6; then
- sed \
- -e "s/from PySide6 import/raise ImportError #/" \
- -e "s/from PySide6.QtCore import/raise ImportError #/" \
- -e '/if "PySide6" in sys.modules:/,/"pyside6"/c\' \
- -i qtpy/__init__.py || die
- fi
-}
-
-python_test() {
- local -x QT_API
- local -a EPYTEST_DESELECT
- local other
-
- # Test for each enabled Qt4Python target.
- # Deselect the other targets, their test fails if we specify QT_API
- # or if we have disabled their corresponding inherit in __init__.py above
- for QT_API in PyQt{5,6} PySide{2,6}; do
- if use "${QT_API,,}"; then
- EPYTEST_DESELECT=()
- for other in PyQt{5,6} PySide{2,6}; do
- if [[ ${QT_API} != ${other} ]]; then
- EPYTEST_DESELECT+=(
- "qtpy/tests/test_main.py::test_qt_api_environ[${other}]"
- )
- fi
- done
-
- einfo "Testing with ${EPYTHON} and QT_API=${QT_API}"
- nonfatal epytest ||
- die -n "Tests failed with ${EPYTHON} and QT_API=${QT_API}" ||
- return 1
- fi
- done
-}
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-pkg_postinst() {
- elog "When multiple Qt4Python targets are enabled QtPy will default to"
- elog "the first enabled target in this order: PyQt5 PySide2 PyQt6 PySide6."
- elog "This can be overridden with the QT_API environment variable."
-}
diff --git a/dev-python/QtPy/QtPy-2.4.2.ebuild b/dev-python/QtPy/QtPy-2.4.2.ebuild
deleted file mode 100644
index a8486eb6f97e..000000000000
--- a/dev-python/QtPy/QtPy-2.4.2.ebuild
+++ /dev/null
@@ -1,244 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_PN=QtPy
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 virtualx pypi
-
-DESCRIPTION="Abstraction layer on top of PyQt and PySide with additional custom QWidgets"
-HOMEPAGE="
- https://github.com/spyder-ide/qtpy/
- https://pypi.org/project/QtPy/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
-
-_IUSE_QT_MODULES="
- designer +gui help multimedia +network opengl positioning
- printsupport qml quick sensors serialport speech +sql svg testlib
- webchannel webengine websockets +widgets +xml
-"
-IUSE="+pyqt5 +pyqt6 pyside2 pyside6 ${_IUSE_QT_MODULES}"
-unset _IUSE_QT_MODULES
-
-REQUIRED_USE="
- || ( pyqt5 pyqt6 pyside2 pyside6 )
- python_targets_python3_12? ( !pyside2 )
- python_targets_python3_13? ( !pyside2 )
-"
-
-# These flags are currently *not* common to the PySide2/6 and PyQt5/6 ebuilds
-# Disable them for now, please check periodically if this is still up to date.
-# bluetooth? ( pyqt5/6 and pyside6 only )
-# dbus? ( pyqt5/6 and pyside6 only )
-#
-# 3d? ( pyside2/6 only )
-# charts? ( pyside2 only )
-# concurrent? ( pyside2 only )
-# datavis? ( pyside2 only )
-# scxml? ( pyside2/6 only )
-#
-# x11extras? ( pyside2 and pyqt5 only )
-# xmlpatterns? ( pyside2 and pyqt5 only )
-#
-# location? ( pyside2/6 and pyqt5 only)
-# nfc? ( pyqt6 and pyside6 only)
-# spatialaudio? ( pyqt6 and pyside6 only)
-# pdfium? ( pyqt6 and pyside6 only)
-
-# WARNING: the obvious solution of using || for PyQt5/pyside2 is not going
-# to work. The package only checks whether PyQt5/pyside2 is installed, it does
-# not verify whether they have the necessary modules (i.e. satisfy the USE dep).
-#
-# Webengine is a special case, because PyQt5 provides this in a separate package
-# while PySide2 ships it in the same package.
-#
-# declarative/qml/quick is a special case, because PyQt5 bundles the bindings
-# for qml and quick in one flag: declarative PySide2 does not.
-#
-# The PyQt5 ebuild currently enables xml support unconditionally, the flag is
-# added anyway with a (+) to make it future proof if the ebuild were to change
-# this behaviour in the future.
-#
-# The PySide2 ebuild currently enables opengl and serialport support
-# unconditionally, the flag is added anyway with a (+) to make it future proof
-# if the ebuild were to change this behaviour in the future.
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[designer?,gui?,help?,multimedia?,network?,opengl?]
- dev-python/PyQt5[positioning?,printsupport?,sensors?,serialport?,speech?,sql?,svg?]
- dev-python/PyQt5[testlib?,webchannel?,websockets?,widgets?,xml(+)?]
- qml? ( dev-python/PyQt5[declarative] )
- quick? ( dev-python/PyQt5[declarative] )
- webengine? ( dev-python/PyQtWebEngine[${PYTHON_USEDEP}] )
- )
- pyqt6? (
- dev-python/PyQt6[${PYTHON_USEDEP}]
- dev-python/PyQt6[designer?,gui?,help?,multimedia?,network?,opengl?]
- dev-python/PyQt6[positioning?,printsupport?,qml?,quick?,sensors?,serialport?,sql?]
- dev-python/PyQt6[speech?,svg?,testlib?,webchannel?,websockets?,widgets?,xml?]
- webengine? ( dev-python/PyQt6-WebEngine[${PYTHON_USEDEP},widgets?,quick?] )
-
- )
- pyside2? (
- $(python_gen_cond_dep '
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[designer?,gui?,help?,multimedia?,network?,opengl(+)?]
- dev-python/pyside2[positioning?,printsupport?,qml?,quick?,sensors?,serialport(+)?]
- dev-python/pyside2[speech?,sql?,svg?,testlib?,webchannel?,webengine?,websockets?]
- dev-python/pyside2[widgets?,xml?]
- ' python3_{10..11})
- )
- pyside6? (
- dev-python/pyside6[${PYTHON_USEDEP}]
- dev-python/pyside6[designer?,gui?,help?,multimedia?,network?,opengl?]
- dev-python/pyside6[positioning?,printsupport?,qml?,quick?,sensors(-)?,serialport?]
- dev-python/pyside6[speech(-)?,sql?,svg?,testlib?,webchannel?,webengine?,websockets?]
- dev-python/pyside6[widgets?,xml?]
- )
-"
-
-# The QtPy testsuite skips tests for bindings that are not installed, so here we
-# ensure that everything is available and all tests are run. Note that not
-# all flags are available in PyQt5/PySide2, so some tests are still skipped.
-BDEPEND="
- test? (
- dev-python/pytest-qt[${PYTHON_USEDEP}]
- pyqt5? (
- dev-python/PyQt5[${PYTHON_USEDEP}]
- dev-python/PyQt5[bluetooth,dbus,declarative,designer,gui,help,location]
- dev-python/PyQt5[multimedia,network,opengl,positioning,printsupport]
- dev-python/PyQt5[sensors,serialport,speech(-),sql,svg,testlib,webchannel]
- dev-python/PyQt5[websockets,widgets,x11extras,xml(+),xmlpatterns]
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- dev-qt/qtsql:5[sqlite]
- )
- pyqt6? (
- dev-python/PyQt6[${PYTHON_USEDEP}]
- dev-python/PyQt6[dbus,designer,gui,help,multimedia,network,nfc,opengl]
- dev-python/PyQt6[pdfium(-),positioning,printsupport,qml,quick,quick3d,serialport]
- dev-python/PyQt6[sensors(-),spatialaudio(-),speech(-),sql,ssl,svg,testlib,webchannel]
- dev-python/PyQt6[websockets,widgets,xml]
- dev-python/PyQt6-WebEngine[${PYTHON_USEDEP},widgets,quick]
- dev-qt/qtbase:6[sqlite]
- )
- pyside2? (
- $(python_gen_cond_dep '
- dev-python/pyside2[${PYTHON_USEDEP}]
- dev-python/pyside2[3d,charts,concurrent,datavis,designer,gui,help]
- dev-python/pyside2[location,multimedia,network,opengl(+)]
- dev-python/pyside2[positioning,printsupport,qml,quick,scxml]
- dev-python/pyside2[sensors,serialport(+),speech,sql,svg,testlib]
- dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
- dev-python/pyside2[xml,xmlpatterns]
- dev-qt/qtsql:5[sqlite]
- dev-python/pyside2-tools[${PYTHON_USEDEP}]
- ' python3_{10..11})
- dev-qt/qtsql:5[sqlite]
- )
- pyside6? (
- dev-python/pyside6[${PYTHON_USEDEP}]
- dev-python/pyside6[3d(-),bluetooth(-),concurrent,dbus,designer,gui,help]
- dev-python/pyside6[location(-),multimedia,network,nfc(-),opengl,positioning,pdfium(-)]
- dev-python/pyside6[printsupport,qml,quick,quick3d,scxml(-),sensors(-)]
- dev-python/pyside6[serialport,spatialaudio(-),speech(-),sql,svg,testlib,webchannel]
- dev-python/pyside6[webengine,websockets,widgets,xml]
- dev-python/pyside6-tools[${PYTHON_USEDEP}]
- dev-qt/qtbase:6[sqlite]
- )
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
- sed -i -e 's:--cov=qtpy --cov-report=term-missing::' pytest.ini || die
- # Disable Qt for Python implementations that are not selected
- if ! use pyqt5; then
- sed \
- -e '/from PyQt5.QtCore import/,/)/c\ \ \ \ \ \ \ \ raise ImportError #/' \
- -e '/if "PyQt5" in sys.modules:/,/"pyqt5"/c\' \
- -i qtpy/__init__.py || die
-
- # We need to ensure the first option is an 'if' not 'elif'
- sed -e 's/elif "PySide2" in sys.modules:/if "PySide2" in sys.modules:/g' -i qtpy/__init__.py || die
- fi
- if ! use pyside2; then
- sed \
- -e "s/from PySide2 import/raise ImportError #/" \
- -e "s/from PySide2.QtCore import/raise ImportError #/" \
- -e '/if "PySide2" in sys.modules:/,/"pyside2"/c\' \
- -i qtpy/__init__.py || die
-
- if ! use pyqt5; then
- sed \
- -e 's/elif "PyQt6" in sys.modules:/if "PyQt6" in sys.modules:/g' \
- -i qtpy/__init__.py || die
- fi
- fi
- if ! use pyqt6; then
- sed \
- -e '/from PyQt6.QtCore import/,/)/c\ \ \ \ \ \ \ \ raise ImportError #/' \
- -e '/if "PyQt6" in sys.modules:/,/"pyqt6"/c\' \
- -i qtpy/__init__.py || die
-
- if ! use pyqt5 && ! use pyside2; then
- sed \
- -e 's/elif "PySide6" in sys.modules:/if "PySide6" in sys.modules:/g' \
- -i qtpy/__init__.py || die
- fi
- fi
- if ! use pyside6; then
- sed \
- -e "s/from PySide6 import/raise ImportError #/" \
- -e "s/from PySide6.QtCore import/raise ImportError #/" \
- -e '/if "PySide6" in sys.modules:/,/"pyside6"/c\' \
- -i qtpy/__init__.py || die
- fi
-}
-
-python_test() {
- local -x QT_API
- local -a EPYTEST_DESELECT
- local other
-
- # Test for each enabled Qt4Python target.
- # Deselect the other targets, their test fails if we specify QT_API
- # or if we have disabled their corresponding inherit in __init__.py above
- for QT_API in PyQt{5,6} PySide{2,6}; do
- if use "${QT_API,,}"; then
- EPYTEST_DESELECT=()
- for other in PyQt{5,6} PySide{2,6}; do
- if [[ ${QT_API} != ${other} ]]; then
- EPYTEST_DESELECT+=(
- "qtpy/tests/test_main.py::test_qt_api_environ[${other}]"
- )
- fi
- done
-
- einfo "Testing with ${EPYTHON} and QT_API=${QT_API}"
- nonfatal epytest -o addopts= ||
- die -n "Tests failed with ${EPYTHON} and QT_API=${QT_API}" ||
- return 1
- fi
- done
-}
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-pkg_postinst() {
- elog "When multiple Qt4Python targets are enabled QtPy will default to"
- elog "the first enabled target in this order: PyQt5 PySide2 PyQt6 PySide6."
- elog "This can be overridden with the QT_API environment variable."
-}
diff --git a/dev-python/QtPy/metadata.xml b/dev-python/QtPy/metadata.xml
deleted file mode 100644
index e4777803df88..000000000000
--- a/dev-python/QtPy/metadata.xml
+++ /dev/null
@@ -1,49 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Gentoo Python Project</name>
- </maintainer>
- <maintainer type="person">
- <email>nowa@gentoo.org</email>
- <name>Nowa Ammerlaan</name>
- </maintainer>
- <longdescription>
- QtPy is a small abstraction layer that lets you write applications using a single API call to either PyQt or PySide.
- It provides support for PyQt5, PyQt4, PySide2 and PySide using the Qt5 layout (where the QtGui module has been split into QtGui and QtWidgets).
- Basically, you can write your code as if you were using PySide2 but import Qt modules from qtpy instead of PySide2 (or PyQt5)
- </longdescription>
- <use>
- <flag name="pyqt5">Use <pkg>dev-python/PyQt5</pkg> as Qt for Python implementation</flag>
- <flag name="pyqt6">Use <pkg>dev-python/PyQt6</pkg> as Qt for Python implementation</flag>
- <flag name="pyside2">Use <pkg>dev-python/pyside2</pkg> as Qt for Python implementation</flag>
- <flag name="pyside6">Use <pkg>dev-python/pyside6</pkg> as Qt for Python implementation</flag>
- <flag name="designer">Pull in bindings for the QtDesigner module and enable the designer plugin</flag>
- <flag name="gui">Pull in bindings for the QtGui module</flag>
- <flag name="help">Pull in bindings for the QtHelp module</flag>
- <flag name="multimedia">Pull in QtMultimedia and QtMultimediaWidgets modules</flag>
- <flag name="network">Pull in bindings for the QtNetwork module</flag>
- <flag name="opengl">Pull in bindings for the QtOpenGL module</flag>
- <flag name="positioning">Pull in bindings for the QtPositioning module</flag>
- <flag name="printsupport">Pull in bindings for the QtPrintSupport module</flag>
- <flag name="qml">Build bindings for the QtQml</flag>
- <flag name="quick">Build bindings for the QtQuick</flag>
- <flag name="sensors">Pull in bindings for the QtSensors module</flag>
- <flag name="serialport">Pull in bindings for the QtSerialPort module</flag>
- <flag name="speech">Pull in bindings for the QtTextToSpeech module</flag>
- <flag name="sql">Pull in bindings for the QtSql module</flag>
- <flag name="svg">Pull in bindings for the QtSvg module</flag>
- <flag name="testlib">Pull in bindings for the QtTest module</flag>
- <flag name="webchannel">Pull in bindings for the QtWebChannel module</flag>
- <flag name="webengine">Pull in QtWebEngine and QtWebEngineWidgets modules</flag>
- <flag name="websockets">Pull in bindings for the QtWebSockets module</flag>
- <flag name="widgets">Pull in bindings for the QtWidgets module</flag>
- <flag name="xml">Pull in QtXml module</flag>
- </use>
- <upstream>
- <remote-id type="github">spyder-ide/qtpy</remote-id>
- <remote-id type="pypi">QtPy</remote-id>
- </upstream>
- <stabilize-allarches/>
-</pkgmetadata>