summaryrefslogtreecommitdiff
path: root/dev-python/QtPy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/QtPy
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/QtPy')
-rw-r--r--dev-python/QtPy/Manifest3
-rw-r--r--dev-python/QtPy/QtPy-1.9.0-r3.ebuild107
-rw-r--r--dev-python/QtPy/metadata.xml73
3 files changed, 156 insertions, 27 deletions
diff --git a/dev-python/QtPy/Manifest b/dev-python/QtPy/Manifest
index 70d3205ccf05..0e3157b7e2b6 100644
--- a/dev-python/QtPy/Manifest
+++ b/dev-python/QtPy/Manifest
@@ -1,3 +1,4 @@
DIST QtPy-1.9.0.tar.gz 35522 BLAKE2B 05b700c1f804cc535c3065c8f819d1d7fb0e02d43f199082d2e0d2c575ff8dbfdbf0053ddb3b155108cf55350ff4daf75166ab39a60374a35a86a1707724a4a1 SHA512 2492c531f0df3afc9e0f8875a2b2e39cc8b09542fb9f251900b8596c0db7767390bb85365cc39efd6cd37ae852a00655354e6f9f3d795023e4fd86dbf8bd5fa7
EBUILD QtPy-1.9.0-r2.ebuild 956 BLAKE2B 3a5efbef2e6ec3f5c2c175940f9f4825d578c57a7fa701db6ea9e8ca0441fd3e460f258e585b1b96ef28a482dfa25c31d6c9d13dfccda5c381743fb3f34d244c SHA512 b190a298d525dd9d02a3f110ef62bc40369e5d23a5c58facab74140da08ab1651f0a74a7c9e183550dba049df051aa4e70da6f049a1a1533b30bb2f06e13a02f
-MISC metadata.xml 1350 BLAKE2B 1871f64db7308ed1232a209c8e4b93b061727ceb3c39f4c1ec1f4e70341aafb422f2053070de1f3327e98dd904fe1933bb750f60170f07c77fa7628ff1bd65b2 SHA512 6dc3acac74cb60e1b1c9fbd357d14fca2ca1c49d3ca8ff1fcbfd923c53c5e862c7c580857329a00fb1ba707f856dcf171e1441e8bedb7622501717c9bdfcbe62
+EBUILD QtPy-1.9.0-r3.ebuild 4249 BLAKE2B 8d9f5f2649006c32b94f06dba70da730cf134e9a0f6ba7c69c41c86878159b60f88a5fd5c8f4b70db92215a2285ca74cd4758c2efa6c22e2bce27bc60156704f SHA512 6e4e0940b2033d8f7ce61ed34977cb5519e035d6643a86d7dae43e684503a840f6e9055d8c3151c4574d4de142b679a6a71522ff7df2e1091fc9f848ab30cb59
+MISC metadata.xml 2850 BLAKE2B 3548a7feb6ab18f1ae067a5faca9ac68735ca171c2d23c6400714a581934adcdc86910e322e606f010e7111d63263b06efea15a170c5379aa452fb407b8218af SHA512 e6139ad7820b1cbf18d322b305e2cd3e884fc5939c3cd1522f658a644701dd632c96749ff158963c4c7e46eea2898ff7e60530b17104dbe4281ad8320551cde4
diff --git a/dev-python/QtPy/QtPy-1.9.0-r3.ebuild b/dev-python/QtPy/QtPy-1.9.0-r3.ebuild
new file mode 100644
index 000000000000..e707c30eebb6
--- /dev/null
+++ b/dev-python/QtPy/QtPy-1.9.0-r3.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..8} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Abstraction layer on top of PyQt5 and PySide2 and additional custom QWidgets"
+HOMEPAGE="https://github.com/spyder-ide/qtpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE="
+ declarative designer gui help location multimedia network
+ opengl positioning printsupport qml quick sensors serialport
+ sql svg test testlib webchannel webengine websockets
+ widgets x11extras xml xmlpatterns
+"
+
+# Webengine is a special case, because PyQt5 provides this in a
+# separate package , while PySide2 ships it in the same package
+#
+# declarative/qml/quick is a special case, because PyQt5 bundles
+# the bindings for qml and quick in one flag: declarative,
+# PySide2 does not.
+#
+# The PyQt5 ebuild currently enables xml support unconditionally,
+# the flag is added anyway with a (+) to make it future proof
+# if the ebuild were to change this behaviour in the future.
+#
+# The PySide2 ebuild currently enables opengl and serialport
+# support unconditionally, the flag is added anyway with a (+)
+# to make it future proof if the ebuild were to change this
+# behaviour in the future.
+#
+RDEPEND="
+ app-eselect/eselect-QtPy
+ || (
+ dev-python/PyQt5[${PYTHON_USEDEP},designer?,gui?,help?,location?,multimedia?,network?,opengl?,positioning?,printsupport?,sensors?,serialport?,sql?,svg?,testlib?,webchannel?,websockets?,widgets?,x11extras?,xml(+)?,xmlpatterns?]
+ dev-python/pyside2[${PYTHON_USEDEP},designer?,gui?,help?,location?,multimedia?,network?,opengl(+)?,positioning?,printsupport?,sensors?,serialport(+)?,sql?,svg?,testlib?,webchannel?,websockets?,widgets?,x11extras?,xml?,xmlpatterns?]
+ )
+
+ webengine? ( || (
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/pyside2[${PYTHON_USEDEP},webengine]
+ ) )
+
+ qml? ( || (
+ dev-python/PyQt5[${PYTHON_USEDEP},declarative]
+ dev-python/pyside2[${PYTHON_USEDEP},qml]
+ ) )
+
+ quick? ( || (
+ dev-python/PyQt5[${PYTHON_USEDEP},declarative]
+ dev-python/pyside2[${PYTHON_USEDEP},quick]
+ ) )
+
+ declarative? ( || (
+ dev-python/PyQt5[${PYTHON_USEDEP},declarative]
+ dev-python/pyside2[${PYTHON_USEDEP},qml,quick]
+ ) )
+"
+
+# These bindings are currently only provided by PyQt5 or PySide2
+# but not by both. Just DEPEND on these directly if they are
+# required.
+# Please check periodically if this list is still up to date
+#
+# bluetooth? ( dev-python/PyQt5[${PYTHON_USEDEP},bluetooth] )
+# dbus? ( dev-python/PyQt5[${PYTHON_USEDEP},dbus] )
+# examples? ( dev-python/PyQt5[${PYTHON_USEDEP},examples] )
+# networkauth? ( dev-python/PyQt5[${PYTHON_USEDEP},networkauth] )
+# ssl? ( dev-python/PyQt5[${PYTHON_USEDEP},ssl] )
+# webkit? ( dev-python/PyQt5[${PYTHON_USEDEP},webkit] )
+#
+# 3d? ( dev-python/pyside2[${PYTHON_USEDEP},3d] )
+# charts? ( dev-python/pyside2[${PYTHON_USEDEP},charts] )
+# concurrent? ( dev-python/pyside2[${PYTHON_USEDEP},concurrent] )
+# datavis? ( dev-python/pyside2[${PYTHON_USEDEP},datavis] )
+# scxml? ( dev-python/pyside2[${PYTHON_USEDEP},scxml] )
+# script? ( dev-python/pyside2[${PYTHON_USEDEP},script] )
+# scripttools? ( dev-python/pyside2[${PYTHON_USEDEP},scripttools] )
+# speech? ( dev-python/pyside2[${PYTHON_USEDEP},speech] )
+
+# The QtPy testsuite skips tests for bindings that are
+# not installed, so here we ensure that everything
+# is available and all tests are run.
+BDEPEND="test? (
+ dev-python/PyQt5[${PYTHON_USEDEP},bluetooth,dbus,declarative,designer,gui,help,location,multimedia,network,networkauth,opengl,positioning,printsupport,sensors,serialport,sql,ssl,svg,testlib,webchannel,webkit,websockets,widgets,x11extras,xml(+),xmlpatterns]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
+ dev-python/pyside2[${PYTHON_USEDEP},3d,charts,concurrent,datavis,designer,gui,help,location,multimedia,network,opengl(+),positioning,printsupport,qml,quick,script,scripttools,scxml,sensors,serialport(+),speech,sql,svg,testlib,webchannel,webengine,websockets,widgets,x11extras,xml,xmlpatterns]
+)"
+
+distutils_enable_tests pytest
+
+python_test() {
+ export QT_API="pyqt5"
+ virtx pytest -vv
+ export QT_API="pyside2"
+ virtx pytest -vv
+ unset QT_API
+}
diff --git a/dev-python/QtPy/metadata.xml b/dev-python/QtPy/metadata.xml
index a19bcec18947..5b164c14610b 100644
--- a/dev-python/QtPy/metadata.xml
+++ b/dev-python/QtPy/metadata.xml
@@ -1,30 +1,51 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Gentoo Python Project</name>
- </maintainer>
- <longdescription>
- QtPy is a small abstraction layer that lets you write
- applications using a single API call to either PyQt or
- PySide. QtPy also provides a set of additional QWidgets. It
- provides support for PyQt5, PyQt4 and PySide using the PyQt5
- layout (where the QtGui module has been split into QtGui and
- QtWidgets).
- Basically, you write your code as if you were using PyQt5 but
- import qt from QtPy instead of PyQt5.
- </longdescription>
- <use>
- <flag name="designer">Build bindings for the QtDesigner module and enable the designer plugin</flag>
- <flag name="gui">Build bindings for the QtGui module</flag>
- <flag name="printsupport">Build bindings for the QtPrintSupport module</flag>
- <flag name="svg">Build bindings for the QtSvg module</flag>
- <flag name="testlib">Build bindings for the QtTest module</flag>
- <flag name="webengine">Build bindings for the QtWebEngine module</flag>
- </use>
- <upstream>
- <remote-id type="github">spyder-ide/qtpy</remote-id>
- <remote-id type="pypi">QtPy</remote-id>
- </upstream>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Gentoo Python Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ QtPy is a small abstraction layer that lets you write applications using a single API call to either PyQt or PySide.
+ It provides support for PyQt5, PyQt4, PySide2 and PySide using the Qt5 layout (where the QtGui module has been split into QtGui and QtWidgets).
+ Basically, you can write your code as if you were using PySide2 but import Qt modules from qtpy instead of PySide2 (or PyQt5)
+ </longdescription>
+ <use>
+ <flag name="declarative">Pull in bindings for the QtQml/QtQuick modules and enable the qmlscene plugin</flag>
+ <flag name="designer">Pull in bindings for the QtDesigner module and enable the designer plugin</flag>
+ <flag name="gui">Pull in bindings for the QtGui module</flag>
+ <flag name="help">Pull in bindings for the QtHelp module</flag>
+ <flag name="location">Pull in bindings for the QtLocation module</flag>
+ <flag name="multimedia">Pull in QtMultimedia and QtMultimediaWidgets modules</flag>
+ <flag name="network">Pull in bindings for the QtNetwork module</flag>
+ <flag name="opengl">Pull in bindings for the QtOpenGL module</flag>
+ <flag name="positioning">Pull in bindings for the QtPositioning module</flag>
+ <flag name="printsupport">Pull in bindings for the QtPrintSupport module</flag>
+ <flag name="qml">Pull in QtQml module</flag>
+ <flag name="quick">Pull in QtQuick and QtQuickWidgets modules</flag>
+ <flag name="sensors">Pull in bindings for the QtSensors module</flag>
+ <flag name="serialport">Pull in bindings for the QtSerialPort module</flag>
+ <flag name="sql">Pull in bindings for the QtSql module</flag>
+ <flag name="svg">Pull in bindings for the QtSvg module</flag>
+ <flag name="testlib">Pull in bindings for the QtTest module</flag>
+ <flag name="webchannel">Pull in bindings for the QtWebChannel module</flag>
+ <flag name="webengine">Pull in QtWebEngine and QtWebEngineWidgets modules</flag>
+ <flag name="websockets">Pull in bindings for the QtWebSockets module</flag>
+ <flag name="widgets">Pull in bindings for the QtWidgets module</flag>
+ <flag name="x11extras">Pull in bindings for the QtX11Extras module</flag>
+ <flag name="xmlpatterns">Pull in bindings for the QtXmlPatterns module</flag>
+ <flag name="xml">Pull in QtXml module</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">spyder-ide/qtpy</remote-id>
+ <remote-id type="pypi">QtPy</remote-id>
+ </upstream>
</pkgmetadata>